This discussion is archived
7 Replies Latest reply: Mar 25, 2013 1:15 AM by HamidHelal RSS

FRM-41213

870213 Newbie
Currently Being Moderated
hi experts

1st machine:-
I am working on a XP machine with Oracle 10g Database and Developer Suite + AS . this machine working accordingly form and reports working on local computer as well as on network via browser.

2nd Machine:-
Currently I installed another XP machine with Oracle 10g Database and Developer Suite + AS. in this machine forms working fine on local machine and on network on via browser, but when I call report via form that is already working on my 1st machine, report not running and giving a error FRM-41213, all the file are same as 1st machine, no any change, I do not know what is problem why this machine is not running report.

I already check to run single form but showing same error.

I think I forgot to assigned values somewhere for reports, not sure, any one can help in this regard

my call report code is .( already working on 1st machine ...)
DECLARE 
QT char(1):='''';
repid REPORT_OBJECT;
v_rep VARCHAR2(100);
rep_status VARCHAR2(20);
 
BEGIN

if :RG = 1 then
repid := FIND_REPORT_OBJECT('REPORT_1');
elsif :RG = 2 then
repid := FIND_REPORT_OBJECT('REPORT_2');
elsif :RG = 3 then
repid := FIND_REPORT_OBJECT('REPORT_3');
End if;     
SET_REPORT_OBJECT_PROPERTY(repid,REPORT_COMM_MODE,SYNCHRONOUS);
SET_REPORT_OBJECT_PROPERTY(repid,REPORT_DESTYPE,cache);
SET_REPORT_OBJECT_PROPERTY(repid,REPORT_DESFORMAT,'PDF');
SET_REPORT_OBJECT_PROPERTY(repid,REPORT_OTHER,'paramform=no sdate='||:btn.sdate|| ' ' || 'edate='||:btn.edate || ' ' || 'emp='|| :btn.EID);  

v_rep := RUN_REPORT_OBJECT(repid);
rep_status := REPORT_OBJECT_STATUS(v_rep); 
WHILE rep_status in ('RUNNING','OPENING_REPORT','ENQUEUED') 
LOOP 
  rep_status := report_object_status(v_rep); 
END LOOP; 
 
if
 rep_status = 'FINISHED'
then
  WEB.SHOW_DOCUMENT('/reports/rwservlet/getjobid'||substr(v_rep,instr(v_rep,'_',-1)+1) ||
  '?server=rserver' ); 
else
  message ( 'error while running reports-object '  || error_text );
  message ( ' ' );
  clear_message;
end if;
end;
Thanks in advance.
  • 1. Re: FRM-41213
    mdra801108 Journeyer
    Currently Being Moderated
    You can not have two reports with same name on your network. Second report server is probably down, check log files.

    Regards
  • 2. Re: FRM-41213
    870213 Newbie
    Currently Being Moderated
    I am using one report server at time, not using both at a time.
  • 3. Re: FRM-41213
    mdra801108 Journeyer
    Currently Being Moderated
    1) Check reports server jobs with showjobs.
    2) If you have reports server on another machine you must change url in web.show_document to full URL of report server, not for relative:
    if you runnig report on second machine url will be: web.show_document('http://<machine_1:port>/report/rwservlet...')

    Regards
  • 4. Re: FRM-41213
    GregorM Explorer
    Currently Being Moderated
    Hi.

    Firstly check your report server on machine 2 is up and running.

    You can check it issuing http://machine1:port/reports/rwservlet/showenv from browser.

    Next describe how is your report object item in forms defined. I suspect you have fixed property values defined on your report object which are ok for machine 1 but not for machine 2.

    Best regards
  • 5. Re: FRM-41213
    HamidHelal Guru
    Currently Being Moderated
    867210 wrote:
    I am using one report server at time, not using both at a time.
    But i suggest,
    If both reports server has same name, please delete the second one and create with different name and change code as well.
    In the same network same name report server makes problem and not work.


    Hope this helps

    Hamid
  • 6. Re: FRM-41213
    870213 Newbie
    Currently Being Moderated
    Dear Hamid

    I changed server, my previous server was rserver now new server name is mserver and i made change accordingly in pl/sql,
    and also defined in report , report server = mserver , still showing same error.

    May I ask that there is any configuration for reports, like we make in formsweb and default file for FORMS.
    my Server detail :-
    Reports Servlet Environment Variables 10.1.2.0.2  
     
    Security Mode Non-secure  
    
     
      HTTP Environment Variables 10.1.2.0.2  
     
     
      
    SERVER_NAME   jahangirpc  
    SERVER_PORT   8889  
    SCRIPT_NAME   /rwservlet  
    SERVER_PROTOCOL   HTTP/1.1  
    SERVER_SOFTWARE   undefined  
    GATEWAY_INTERFACE   undefined  
    SERVER_PORT_SECURE   undefined  
    ACCEPT   image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, */*  
    REQUEST_METHOD   GET  
    REMOTE_HOST   JAHANGIRPC  
    REMOTE_ADDR   192.168.0.53  
    REMOTE_USER   undefined  
    AUTH_TYPE   undefined  
    PATH_INFO   showenv  
    QUERY_STRING   server=mserver  
    PATH_TRANSLATED   D:\DevSuiteHome_1\reports\j2ee\reports_ids\web\showenv  
    CONTENT_LENGTH   undefined  
    CONTENT_TYPE   undefined  
    AUTHORIZATION   undefined  
    USER-AGENT   Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; InfoPath.2)  
    REMOTE_IDENT   undefined  
    REFERER   undefined  
     
     
    
     
     OracleAS Reports Services - Servlet Environment Variables    Return to Top 
     
     
     
     
    KeyMapFile   D:\DevSuiteHome_1\reports\conf\cgicmd.dat  
    DBAUTH   D:\DevSuiteHome_1\reports\templates\rwdbauth.htm  
    SYSAUTH   D:\DevSuiteHome_1\reports\templates\rwsysauth.htm  
    server   undefined  
    DIAGNOSTIC   yes  
    traceopts   undefined  
    ERRORTEMPLATE   D:\DevSuiteHome_1\reports\templates\rwerror.htm  
    SERVER_IN_PROCESS   yes  
    COOKIEEXPIRE   30  
    ENCRYPTIONKEY   reports9i  
    DIAGHEADTAGS   undefined  
    DIAGBODYTAGS   undefined  
    HELPURL   undefined  
    RELOAD_KEYMAP   NO  
    IMAGEURL   http://jahangirpc:8889/reports/rwservlet  
    SINGLESIGNON   yes  
     
     
    
     
     OracleAS Reports Services - Server and Engine Environment Variables    Return to Top 
     
     
     
     
    PATH   D:\DevSuiteHome_1\jdk\jre\bin\classic;D:\DevSuiteHome_1\jdk\jre\bin;D:\DevSuiteHome_1\jdk\jre\bin\client;D:\DevSuiteHome_1\jlib;D:\DevSuiteHome_1\bin;D:\DevSuiteHome_1\jre\1.4.2\bin\client;D:\DevSuiteHome_1\jre\1.4.2\bin;e:\orant\bin;E:\oracle\product\10.2.0\db_1\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;e:\orant\jdk\bin  
    DISPLAY    
    LD_LIBRARY_PATH    
    ORACLE_HOME   D:\DevSuiteHome_1  
    TNS_ADMIN    
    NLS_LANG   AMERICAN_AMERICA.WE8MSWIN1252  
    USER_NLS_LANG    
    RW   D:\DevSuiteHome_1\reports  
    REPORTS_PATH   D:\DevSuiteHome_1\repadm61\srw;D:\DevSuiteHome_1\cgenr61\admin\crretc;D:\DevSuiteHome_1\cgenr61\admin;D:\DevSuiteHome_1\reports\templates;D:\DevSuiteHome_1\reports\samples\demo;D:\DevSuiteHome_1\reports\integ;D:\DevSuiteHome_1\reports\printers;  
    REPORTS_TMP   C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp  
    REPORTS_TAGLIB_URI   /WEB-INF/lib/reports_tld.jar  
    java.class.path   D:\DevSuiteHome_1\j2ee\home\lib\ojsp.jar;D:\DevSuiteHome_1\reports\jlib\rwrun.jar;D:\DevSuiteHome_1\jlib\zrclient.jar  
    sourceDir    
    tempDir    
    useDataCache    
    ignoreDataParameter    
     
     
    Edited by: 867210 on Mar 25, 2013 12:10 AM
  • 7. Re: FRM-41213
    HamidHelal Guru
    Currently Being Moderated
    Can you try this code ..How to call a report in Forms 10g ?

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points