2 Replies Latest reply: Mar 22, 2013 9:57 AM by 606331 RSS

    Oracle 10g Install DB with ASM on Linux EL5 unable to find disk devices

    olunebur
      Dear all,

      We are installing a new 10g database with ASM for testing purposes on a Oracle Enterprise Linux 5 server. Once followed all the pre-installation steps, we are trying to configure ASM with block devices (located under /dev/mapper/mpath*). We have done this operation several times in oder servers without any problem, but this time Oracle Installer seems unable to identify the disks. We have tried to modify the "Disk Discovery Path" in the installer without any success, no matter if we put it to "/dev/mapper/" "/dev/mapper/*" "/dev/mapper/mpath*", with and without single quotes.

      We have tried also with partitioned and non-partitioned devices but without any success, the methodology followed was with fdisk and kpartx -a for partitioning.

      Additionally we installed the oracleasm package but when trying to create any disk, the following error is returned:

      oracleasm createdisk DATA1 /dev/mapper/mpath0
      Writing disk header: done
      Instantiating disk: failed
      Clearing disk header: done


      Thanks in advance for your suggestions and help.

      Regards,

      Rubén