4 Replies Latest reply: Mar 22, 2013 11:34 AM by 998631 RSS

    Shp2sdo Need help

    397090
      Hi guys,

      I downloaded the shp2sdo.exe.I placed a shape file in the same director.In a command prompt I tried shp2sdo -h and am getting the help commands.
      Now starts my real problem,when I type
      shp2sdo.exe DepthArea DepthArea
      -g geom -d -x (-180,180) -y (-90,90) -s 8307 -t 0.0001 -v
      it ends with an error saying cannot open the file.
      I am trying to load into an Oracle 10g DB on Win2K.

      This is the error I get:

      shp2sdo - Shapefile(r) To Oracle Spatial Converter
      Version 2.15 21-May-2004
      Copyright 1997,2004 Oracle Corporation
      For use with Oracle Spatial.

      Processing shapefile DepthArea into spatial table DEPTHAREA
      Data model is object-relational
      Geometry column is GEOM
      Points stored in SDO_POINT attributes
      Data is in the control file(s)
      Control file generation for Oracle9i or higher
      Spatial data loaded with 6 digits of precision
      Bounds set to X=[-180.000000,180.000000] Y=[-90.000000,90.000000]
      SRID set to 8307
      Tolerance set to 0.000100
      Unable to open:DepthArea.shp
      Error: No such file or directory


      It doesnt even create a ctl or sql file.I have verified the shape file through Arc GIS and is good.

      Thanks and Regards
      Michael Koshy
        • 1. Re: Shp2sdo Need help
          91061
          Hi,

          Is the file there in the same directory (DepthArea.shp)?
          Also, does the user running shp2sdo have privs to open the file (might need read+write even though we'll only be opening for read)?

          Thanks,

          Dan
          • 2. Re: Shp2sdo Need help
            397090
            Hi,

            I know this looks very odd to me also.The file is there in the directory and has full control for all users.

            Do i need to install anything,I guess nothing must be done just unzipped the shp2sdo.zip and it created 3 folders>shp2sdo_linux,shp2sdo_nt,shp2sdo_solaris.I copied the .shp file to the shp2sdo_nt folder where there is an shp2sdo.exe.When I execute this file it asks for the input file,I provide the name of the shape file(without the extention).I also tried providing the full pathname .

            I cannot really get started and going.
            Please do help.

            Michael Koshy
            • 3. Re: Shp2sdo Need help
              91061
              Hi Michael,

              There needs to be three files with extensions {.shp, .shx, and .dbf} in the same directory for the shp2sdo converter to work. Are all three files in the directory? I took a look at the code, and it returns the same error if the .shp or the .shx file is missing.

              My guess is you are missing at least the .shx file.

              Hope this helps,

              Dan
              • 4. Re: Shp2sdo Need help
                998631
                Good answer; thanks.