1 2 Previous Next 16 Replies Latest reply: Mar 22, 2013 4:57 PM by Gary Graham-Oracle RSS

    ObjectViewer (data grid) paste error

    996446
      Using SQL Developer 3.0.04 on Windows 7. I
      1. open the object viewer for a particular table
      2. click the "insert row" button a few times
      3. copy cells from Excel
      4. click on a cell for one of the new rows in the object viewer
      5. CTRL+V to paste

      The result is that all of the cells from Excel end up pasted in a single object viewer cell. Not only is the behavior wrong (my ancient version of SQL Developer on my now defunct PC did it just fine), but it's maddening because the whole point of the object viewer is to do mass data updates, including pasting from spreadsheets.

      I've played aroud with all of the options on "Tools > Preferences > Database > ObjectViewer" (except for "Set Auto Commit On" with no luck. What gives?
        • 1. Re: ObjectViewer (data grid) paste error
          Jeff Smith Sqldev Pm-Oracle
          I tried this in the latest version, v3.2.20_09 and it works for me.

          The only thing I'm doing differently is that I'm selecting the cells I want to paste into before I paste.

          But if I copy 3 values, then select 3 cells and paste, the 3 go in, just as expected.
          • 2. Re: ObjectViewer (data grid) paste error
            996446
            Unfortunately, that didn't work for me :-( Instead, all the data ended up in the last cell I selected.
            • 3. Re: ObjectViewer (data grid) paste error
              Jeff Smith Sqldev Pm-Oracle
              To clarify, I copied 3 cells from Open Office Calc (not Excel) and pasted into 3 selected cells in the table editor grid. It pasted successfully using v3.2.20_09 with Java 7 JDK

              Maybe someone else can try with Excel?
              • 4. Re: ObjectViewer (data grid) paste error
                Jim Smith
                This is working for me and I don't have to select all the cells.

                Select and copy cells from excel.
                Click new row button several times
                Select first empty row in SQL Developer
                Paste. - Pasted cells go into separate columns.

                If I don't have enough blank rows and i am at the end of the data, the extra cells just don't paste.
                If I am not at the end of the data, the extra cells overwrite the existing data.
                If I paste without creating blank rows, all the cells overwrite existing data.


                Version information -
                Excel: 2007
                Windows Vista Business 32-bit SP2

                About
                -----

                Oracle SQL Developer 3.2.20.09
                Version 3.2.20.09
                Build MAIN-09.87
                Copyright © 2005, 2012 Oracle. All Rights Reserved.
                IDE Version: 11.1.1.4.37.59.48
                Product ID: oracle.sqldeveloper
                Product Version: 11.2.0.09.87

                Version
                -------

                Component     Version
                =========     =======
                Java(TM) Platform     1.6.0_35
                Oracle IDE     3.2.20.09.87
                Versioning Support     3.2.20.09.87
                • 5. Re: ObjectViewer (data grid) paste error
                  996446
                  That's how my old SQL Developer worked on my old PC. Current one, not so much. I don't know if it's a SQL Developer version issue, a JDK issue, or a configuration issue.
                  • 6. Re: ObjectViewer (data grid) paste error
                    Jim Smith
                    What is you JDK version?

                    Also you could try upgrading to 3.2. 3.0 is quite old now.
                    • 7. Re: ObjectViewer (data grid) paste error
                      996446
                      According to Windows Control Panel, I have:
                      Java 7 Update 11
                      Java 7 Update 17 (64-bit)
                      JavaFX 2.1.1

                      and what appears to be sqldeveloper with its own Java libraries (same timestamp as the rest of the files and directories).
                      • 8. Re: ObjectViewer (data grid) paste error
                        Gary Graham-Oracle
                        Hi,

                        Let's hope you aren't using Java 7 (most recent SDK is jdk1.7.0_17) since it is not officially supported, especially not on earlier releases like 3.0.4.34. Perhaps you downloaded the 32-bit SQL Developer 3.0.04 version that comes with it's own jdk (jdk1.6.0_11, as I recall), but just to verify what you are actually using, open
                        Help -> About, then look for the java.home value in the Properties tab.
                        If it is not showing a jdk1.6.0_xx version, where xx >= 11, then at a minimum I would recommend downloading and installing the latest Java 6 update (currently jdk1.6.0_43). Update your ...\sqldeveloper\sqldeveloper\bin\sqldeveloper.conf file so the SetJavaHome line is
                        SetJavaHome C:/Program Files/Java/jdk1.6.0_43
                          or
                        SetJavaHome C:/Program Files (x86)/Java/jdk1.6.0_43
                        depending on whether you use the 64-bit or 32-bit version of SQL Developer. It would also be a good idea to upgrade to the latest production release of SQL Developer (3.2.20.09.87). If you wish, you may keep multiple versions of SQL Developer installed, each in it's own distinct directory. It is not necessary to remove a prior version.

                        By the way, I ran your test case against 3.0.04 32-bit with Java 6u43. The copy/paste worked fine (ctrl-V or Edit -> Paste). My case involved 3 rows and 2 columns (a NUMBER and a VARCHAR2(32)) on Windows 7 64-bit.

                        Regards,
                        Gary
                        SQL Developer Team
                        • 9. Re: ObjectViewer (data grid) paste error
                          996446
                          Good news: my java.home is C:\Program Files (x86)\sqldeveloper\jdk\jre
                          Bad news: it still doesn't work

                          I'll take your advice and download the latest version. More details to follow when I get a moment.
                          • 10. Re: ObjectViewer (data grid) paste error
                            996446
                            So I downloaded and installed the version of sqldeveloper-3.2.20.09.87 with the packaged JDK. Properties says Java platform 1.6.0_35, Oracle IDE 3.2.20.09.87, versioning support same as Oracle IDE version.

                            BUT login broke. I exported the previous set of working connections as an XML file and imported it into the new version of SQLDeveloper. When I test a sample (previously working) connection, I get:

                            Status: Failure -Test failed: oracle.jdbc.driver.T2CConnection.t2cCreateState([BI[BI[BI[BI[BI[BI[BISI[S[BZ[J)I

                            I had this problem on the other version of SQL Developer I have installed, but don't recall exactly how I got around it (fuzzy memory says I found a support forum suggesting that I replace a SQL Developer Java library with another version from somewhere else). We're using OID, a couple of other things, and mandatory mixed case passwords.
                            • 11. Re: ObjectViewer (data grid) paste error
                              Gary Graham-Oracle
                              If you have some kind of Oracle database client installed, it may relate to a conflict in the ocijdbc dll version. So you might try unchecking Use OCI/Thick driver in Tools -> Preferences - Database -> Advanced if it is checked in your environment.
                              • 12. Re: ObjectViewer (data grid) paste error
                                996446
                                It wasn't/isn't checked. I do appear to have a tnsnames directory pointing at an instantclient_11_2 directory.
                                • 13. Re: ObjectViewer (data grid) paste error
                                  Gary Graham-Oracle
                                  There must be a conflict but, if you do not use OCI/Thick, it must be with the ojdbc6.jar rather than the ocijdbc11.dll. The following thread is a bit dated, however I imagine it may apply to your situation if we consider ojdbc6 rather than ojdbc5:
                                  Re: Oracle SQL Developer 2.1 Patch 1 and latest instant client drivers
                                  • 14. Re: ObjectViewer (data grid) paste error
                                    996446
                                    I copied the ojdbc6.jar file from my C:\Oracle11g\instantclient_11_2 location to sqldeveloper-3.2.20.09.87\sqldeveloper\jdbc\lib. (I didn't bother with the ojdbc5.jar file). Having done that, I can login and I can paste, so my problem (at least so far as the original thread goes) is solved. However, it introduced a new "issue". SQL Developer will no longer let me save my connections in the "USER@DB_INSTANCE" format; it says that I can't use characters not allowed on the filesystem, which is funny to me because this is the first time it has ever complained about that format....
                                    1 2 Previous Next