This discussion is archived
3 Replies Latest reply: Apr 8, 2013 2:45 PM by tlue2 RSS

Commit Interval

JB1 Journeyer
Currently Being Moderated
Hi all

Running ODI11g with Hyperion/Essbase 11.1.2.1

I am looking to improve the data load times to a BSO db by increasing the commit interval value within the IKM. I have encountered some memory errors when going past a certain threshold; is anyone able to advise where or what memory/heapsize I should be increasing to allow an increased commit interval value to be used? Is it on the Essbase side or something on the server side where ODI is residing?

Thanks

JB
  • 1. Re: Commit Interval
    Ayush Ganeriwal Journeyer
    Currently Being Moderated
    It need to be done at the odi side. You can increase the heap size of the standalone agent in the odiparams.sh/bat for the standalone agent. For jee agent you need to change is for the manager server configuration.
  • 2. Re: Commit Interval
    JB1 Journeyer
    Currently Being Moderated
    Thanks
  • 3. Re: Commit Interval
    tlue2 Newbie
    Currently Being Moderated
    in addition to the above I would also try some different settings in topology for array fetch size of your staging area.
    have a read i.e. here: http://www.business-intelligence-quotient.com/?tag=array-fetch-size-odi

    I finally (with 10g) ended up exporting from source RDBMS to a .csv file on the Essbase Server and using an old fashioned .rul file to load from that csv (using MaxL or ESSCMD via OdiOSCommand)

    Looking forward to find some improvements around this and maybe some blog entries to learn how to improve settings in the Essbase-KMs.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points