14 Replies Latest reply on Mar 26, 2013 5:50 AM by 998400

    can't find a way to access the URL

      I'm a total "newbie" here, yesterday I installed the Oracle Database Express 11g in my house without any trouble, today I wanted to do the same here at my office, but for some reason I can't find a way to access the URL

      I know this has been an issue from a long time ago, but I can't find the solution, I'm running Windows Vista Business, SP2, the error I get is as simple as "Internet Explorer cannot display the webpage" tried with Chrome, same results, tried to manipulate the Windows Firewall creating a couple of Inbound rules without any luck.

      Last thing I tried was to switch off the windows firewall and the ESET NOD32 antivirus I have installed, no positive results yet
      So this is why I'm asking for help today, hope someone can guide me since I'm starting to learn SQL but this is preventing me to do it

      thanks in advance !
        • 1. Re: can't find a way to access the URL
          switch off the windows firewall
          Firewall isn't relevant when using loopback ( IP address.

          Step One, make sure your database is running. Might need a service start. In a command box:
          sqlplus /nolog
          connect system
           ... password: <use the one set in the install>
          ... Connected.  -- Or ... maybe not. Try starting it:
          conn /as sysdba;
          ... Connected to idle instance ...
          Step Two, make sure your listener is running, back to the command box:
          lsnrctl status
          ... Endpoints:
          ... 1521 ...
          ... http ... 8080 ...
          Step Three, check that `lsnrctl status` command output, you should have two endpoints, the database default 1521 port, and the 8080 web page port. If the 8080 port isn't in the lsnrctl output, the web pages will not work.
          1 person found this helpful
          • 2. Re: can't find a way to access the URL
            thanks a lot for taking your time helping me out
            I had not much success following your instuctions, please check my services status as they are now in the following picture, it seems like everything is up and running but for some reason I still can't log into the web app

            • 3. Re: can't find a way to access the URL
              That .jpg URL won't render for me. Anyways ...
              it seems like everything is up and running
              "seems like" and "actually are" could be two very different things, connecting to the database to ensure it is running and the lsnrctl status command are ways to check and verify.

              In Windows the service can be running but a sysdba connection to the database instance can shut it down and the services won't show any differently. Or the instance could crash, still won't see any differences in the services list.
              1 person found this helpful
              • 4. Re: can't find a way to access the URL
                I don't know if you got my previous reply, it seems like this forum is experiencing some issues today, I don't see my reply, that is why I'm sending you back the last image I capture just a few minutes ago, also I'm sending you yesterdays image (the one you couldn't open)

                maybe this is a dumb comment, but my computer has a static IP address within my works network which is (don't have a clue if this could be trouble or not.....)


                yesterdays image of win services


                Edited by: 995397 on Mar 22, 2013 8:56 AM
                • 5. Re: can't find a way to access the URL
                  Ahhh got the .jpg now. Can see you do indeed have two endpoints, but one of those is the ipc, its not relevant. IPC a.k.a. Inter-Process Communication is a host-only protocol and has no direct effect on networking.

                  And there is no http ... 8080 end point, so yes, the web pages aren't going to work.
                  my computer has a static IP address
                  Actually a static IP is preferred for a server- don't want it to have a different IP every time it boots as can happen with DHCP.

                  What is important, is the host= part. It can be the hostname, but it must be the correct hostname. Depending on how the network client is set up, it may not be.

                  And the Service ... instance "xe" status BLOCKED doesn't look good, could be the host= needing adjustment causing that.

                  Try stopping the listener, set the listener.ora HOST= to your static IP, or slightly easier, the "any IP" address of, start the listener, connect to the database, and force a registration. Back to the command box, the file that needs the change is listed as the "Listener Parameter File" in the lsnrctl status output:
                  lsnrctl stop
                  notepad <drive: ... >\network\admin\listener.ora
                  ... change: HOST=BERNIE 
                  ... to: HOST=
                  ... save and exit, start the listener
                  lsnrctl start
                  ... connect to the database and force it to register
                  sqlplus /nolog
                  connect system
                  ... password ... Connected.
                  alter system register;
                  exit ... check listener status again
                  lsnrctl stat
                  When changing a listener.ora setting be sure the listener is not running, the HOST= tells lsnrctl what address to talk to for controlling the listener.

                  Edited by: clcarter on Mar 22, 2013 12:17 PM
                  add 2nd lsnrctl stat
                  • 6. Re: can't find a way to access the URL
                    Since I'm not a comp tech, I need a little more help from you ( really sorry.....) where exactly do I make all the changes your are proposing here ?
                    Can you be a little more specific, I'm just a regular guy trying to learn more every day, sorry......
                    • 7. Re: can't find a way to access the URL
                      Well, if you want the really really easy GUI way, in the services applet hit the Stop button on the OracleXETNSListener service.

                      Bring up the file explorer and navigate to your C: drive, open the oraclexe folder, and go way way down until you get to the ...\network\ADMIN folder.

                      Right click on the listener.ora file, hit Rename, and change it to something different- "listener.ora.bak" or something that is not "listener.ora".

                      Back to the Services applet, hit the Start button on OracleXETNSListener. It might take a minute, maybe two for the database to get re-registered with the listener. The sqlplus ... connect system ... alter system register; will shorten the wait time a bit.

                      And a helpful tip for the command box, do a right click the "c:\" icon in the upper left corner, click Properties, go to the Options tab and check the "Quick Edit" checkbox. That will let you use the mouse to highlight text in the box, press the Enter key to copy it to the clipboard. Much easier than posting .jpg screen shots ... ;)
                      • 8. Re: can't find a way to access the URL
                        I've had the same experience, it 911g) was working fine for last two weeks , now 'Firefox can't establish a connection to the server at'

                        In brief this is not just a single user experience

                        I'm also a newbie and just want to start writing basic scripts. Can anyoneexplain/help

                        • 9. Re: can't find a way to access the URL
                          I reinstalled 11g and chose the repair option. Application now functioning !

                          Hope that helps fellow newbee

                          • 10. Re: can't find a way to access the URL
                            Sorry for my delyed answer.
                            I tried everything without any luck, the problem must be somewhere else, I repaired the installation, unistalled the software and reintall it again, no luck, cannot log into the web app
                            I thing I will give up and look for another option, maybe my SQL will make it easier for me ?
                            thanks a lot !
                            • 11. Re: can't find a way to access the URL
                              maybe my SQL will make it easier for me ?
                              Maybe. If desktop admin task skills are elusive, maybe not. MS Sqlserver express edition is another "free" database option, it has several prerequisites that the installer usually gets loaded to the desktop OK, if you have admin rights on the desktop.
                              I tried everything without any luck
                              Everything? Stopping the listener, moving/renaming the listener.ora file is not that hard to do.

                              To stop the listener in the GUI, the services applet should be available via Start/run/services.msc look for the "OracleXETNSListener" service. Click it to highlight, click the Stop button.

                              Next try the "windows explore" utility or what ever its called in your particular host. The path is Start/Programs/Accessories on XP, for win7 the path is ... slightly different. Its the program with a folder for an icon.

                              Open up your C: drive, the oraclexe folder, and start digging. The full path to the listener.ora file is shown in your lsnrctl status output, labeled "Listener Parameter File". With that file moved out of the way the Oracle install has a default listener configuration that usually works better, especially if anything is wonky with the networking configuration.

                              After moving the listener.ora file, go back to the Services applet and click Start on the listener. In a command box (Start/Run/cmd) check the lsnrctl status output again. Might see a difference, and when the database instance gets registered with the listener that should get the 8080 port showing up in the lsnrctl status output.
                              • 12. Re: can't find a way to access the URL
                                Thanks a lot, I will try all this again later today and will post my results, I'm not a computer tech, but I'm not also a rookie, it is just a matter of following your instructions strictly, sometimes you have the answer right in front of your eyes and you don't see it......
                                • 13. Re: can't find a way to access the URL
                                  the answer right in front
                                  Yes indeed. Many times I've have the answer right in front of me, but didn't see it because I was expecting something else.

                                  Saw what I wanted to see, not what I was actually seeing. ;)
                                  • 14. Re: can't find a way to access the URL
                                    Working !!!!

                                    thanks a lot I really appreciate your patience !