This discussion is archived
5 Replies Latest reply: Mar 26, 2013 6:18 AM by Jeff Smith SQLDev PM RSS

Unable to name connections with @

Maxo Newbie
Currently Being Moderated
I am using SQL Developer 3.2.20.09. I have traditionally used the format <schema>@<sid> to name my connections. In the newest version, whenever I try to create a new connection, or update an existing connection I get "Connection Name may not contain characters the file system restricts from use in directory and file names."

SQL Developer is clearly not actually checking that capabilities or limitations of the underlying filesystem as I am using Ubuntu 12.04 with EXT4 and can definitely put @ in my file and folder names. I do not know off hand what the limitations are with Windows or other OS/filesystems, but it would be nice if the restriction in connection names only apply to the actual filesystem limitations.
  • 1. Re: Unable to name connections with @
    Jeff Smith SQLDev PM ACE Moderator
    Currently Being Moderated
    The error message is misleading, as you've correctly indicated.

    You have a few options:

    1)Downgrade to an earlier version
    2)Use 'at' instead of @
    3)Manually edit the connections XML file to rename your connections as you please.

    We're not allowing certain characters in the connection names b/c it was causing issues with other features in the product - has nothing to do with the OS file name limitations.
  • 2. Re: Unable to name connections with @
    Maxo Newbie
    Currently Being Moderated
    Jeff Smith SQLDev PM wrote:
    The error message is misleading, as you've correctly indicated.

    You have a few options:

    1)Downgrade to an earlier version
    2)Use 'at' instead of @
    3)Manually edit the connections XML file to rename your connections as you please.

    We're not allowing certain characters in the connection names b/c it was causing issues with other features in the product - has nothing to do with the OS file name limitations.
    Option 3 is what I'm doing. It's not like I add or edit connection names frequently. It would be helpful to update the error message to be more precise about allowable characters in connection names.

    Thanks for the feedback.

    Edited by: Maxo on Jan 3, 2013 2:48 PM
  • 3. Re: Unable to name connections with @
    Jeff Smith SQLDev PM ACE Moderator
    Currently Being Moderated
    Agreed Maxo. For reference, here's the 'illegal' characters for a connection name

    <:/\|?*()%&'$@^~#">
  • 4. Re: Unable to name connections with @
    633274 Newbie
    Currently Being Moderated
    Helpful thread, saved me from making the same question.

    Whatever, this "feature" is like reading this in a form:
    You are not allowed to enter the following terms: «' OR 1=1 --», «INSERT», «DELETE», «UPDATE»...
    ... if you understand what I mean.
  • 5. Re: Unable to name connections with @
    Jeff Smith SQLDev PM ACE Moderator
    Currently Being Moderated
    The error message has been updated to be more accurate in the next version of SQL Developer.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points