14 Replies Latest reply: Sep 17, 2013 10:12 PM by user13062020 RSS

    OTM/run Openscript:Cannot get a connection from helper after 120 seconds.

    994109
      Hi,
      Now I want to run Openscript cases from OTM, OTM is installed in another machine.I add the recorded srcipt to the OTM, set the "Quick Run", then run it from OTM, but always got:"Failed Cannot get a connection from helper after 120 seconds. ".
      I googled this thread to solve the problem: https://forums.oracle.com/forums/thread.jspa?threadID=2134832
      But there is something I don't understand:

      1.Should I install browser helper to my local machine or to the remote machin which installed the OTM? I tried install browser helper to my local machine , but still the same error message("Failed Cannot get a connection from helper after 120 seconds."). While I tried install it to remote machine, it says "There are 3 instances of Internet Explorer running." though I make sure that there are no browser running or restart my PC. Why I cannot install it successfully?

      2.I run "C:\OracleATS\agentmanager\bin\AgentManagerService.exe -c C:\OracleATS\agentmanager\bin" (C:\OracleATS is installed path) in a command prompt on the remote machine which installed the OTM .The following is displayed messages:

      C:\>C:\OracleATS\agentmanager\bin\AgentManagerService.exe -c C:\OracleATS\agentmanager\bin\AgentManagerService.conf
      wrapper | --> Wrapper Started as Console
      wrapperp | port 1787 already in use, using port 1788 instead.
      wrapper | Launching a JVM...
      jvm 1 | Wrapper (Version 3.0.3)
      jvm 1 |
      jvm 1 | java.lang.InterruptedException
      jvm 1 | at java.lang.Object.wait(Native Method)
      jvm 1 | at oracle.oats.empstart.PortListener.getContRequest(PortListe
      .java:251)
      jvm 1 | at oracle.oats.empstart.EmpStartMain.parseRequests(EmpStartMa
      java:1201)
      jvm 1 | at oracle.oats.empstart.EmpStartMain.<init>(EmpStartMain.java
      2)
      jvm 1 | at oracle.oats.empstart.EmpStartMain.main(EmpStartMain.java:3

      jvm 1 | at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method
      jvm 1 | at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAc
      sorImpl.java:39)
      jvm 1 | at sun.reflect.DelegatingMethodAccessorImpl.invoke(Delegating
      hodAccessorImpl.java:25)
      jvm 1 | at java.lang.reflect.Method.invoke(Method.java:597)
      jvm 1 | at org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSim
      App.java:106)
      jvm 1 | at java.lang.Thread.run(Thread.java:662)

      Why is there InterruptedException ??

      So, how can I run recorded scripts from OTM successfully?
      I'm looking forward to your help!Thanks very much!

      Regards,
      Angyoung