5 Replies Latest reply: Mar 28, 2013 10:03 AM by Durgaprasad RSS

    Xelsysadm account not logging in

    Durgaprasad
      I did a fresh installation of OIM 11gr2 to include OES which i forgot to configure in my earlier installation. ALL the installations went well and there was no error.

      I had selected 'Production Mode' while configuring weblogic. So for the first time when i started weblogic and managed servers it failed since when you configure in production mode you cannot enter the password in command prompt. I configured the boot.properties file containing the username and password for admin server and managed servers. After that everything started properly.

      For the first time when i tried logging into Identity console using XELSYSADM account it is giving error message in console as 'Invalid Signin'. I used the same password which i gave during configuring OIM but still it is giving this error. But when i tried logging into the identity console using 'WEBLOGIC' user it seems to work properly. Now how to unlock or change the XELSYSADM account password.

      Note: I did not configure the security questions since it did not allow logging in for the first time itself.
        • 1. Re: Xelsysadm account not logging in
          Nishith Nayan
          check if usr_locked =1 means the user is locked. To unlock this user update database "update usr set usr_locked =0, usr_login_Attempts_ctr=0, where usr_login='XELSYSADM'" and then commit.

          If still you are unable to login using existing passwrod. update XELOPERATOR's usr_password encrypted value for XELSYSADM user and then login password as 'XELOPERATOR' later on you can change it.

          In worst case you can directly update the PCQ table for setting question and answer for xelsysadm( similar as existing one)
          • 2. Re: Xelsysadm account not logging in
            Durgaprasad
            Thanks Nishith. usr_locked is showing as 0 only. I already tried updating the encrypted password of XELOPERATOR into XELSYSADM's password. After that i was tring to login with the password 'xeloperator'. But from your post i am seeing that to be in uppercase ('XELOPERATOR'). So should it work if i try to login with user id XELSYSADM and password XELOPERATOR (uppercase instead of lower case which i previously used).
            • 3. Re: Xelsysadm account not logging in
              Nishith Nayan
              yes. try with that. But if the problem because question is not defined in that case open PCQ table look at that if there is no entry for xelsysadm(usr_key=1) then insert 3 question (encrypted) similar to given one for others . or copy from any other envirnment and insert into PCQ table
              • 4. Re: Xelsysadm account not logging in
                idamGod
                By default all user login ids will be stored in upper case and while logging into console, case does not matter actually.

                Try this update sql to xelsysadm password from xeloperator.

                UPDATE USR
                SET USR_PASSWORD=(SELECT A.USR_PASSWORD FROM USR A WHERE UPPER(A.USR_LOGIN) ='XELOPERATOR')
                WHERE USR_LOGIN='XELSYSADM';
                • 5. Re: Xelsysadm account not logging in
                  Durgaprasad
                  The XELOPERATOR password did not work. I manually inserted values in PCQ table for XELSYSADM user and it worked finally. Thanks