This discussion is archived
6 Replies Latest reply: Mar 29, 2013 9:06 AM by dirkt RSS

DAC/Integration Server Port

dirkt Newbie
Currently Being Moderated
While registering the Informatica integration service to DAC I keep receiving the error when testing the connection:

ERROR: Port number [0] too small.
Usage: pmcmd pingserver
<<-service|-sv> service [<-domain|-d> domain] [<-timeout|-t> timeout]>

With the previous version of DAC a port number of 0 worked. With the 20120711.0516 build this is no longer true. But no matter what port I put in the Test Connection does not work. netstat shows pmserver running on 6014 but it cannot be connected to at that port. What am I missing here?
  • 1. Re: DAC/Integration Server Port
    SunilSharma Expert
    Currently Being Moderated
    For integration services in DAC try using the port 4006 and then try test connection. I hope your repository service connection gets succeed

    Mark helpful/correct

    Thanks,
    RM
  • 2. Re: DAC/Integration Server Port
    Srini VEERAVALLI Guru
    Currently Being Moderated
    make sure you got required info at dac_env.bat
    for INFA_DOMAINS_FILE and INFA_CMD_STYLE settings.

    Integration service port cant be 0 for latest versions try with 6007

    let us know updates
  • 3. Re: DAC/Integration Server Port
    dirkt Newbie
    Currently Being Moderated
    DAC_ENV.BAT is correct. I had already tried ports 4006 and 6007 without success but went and tried Test Connection with both of them; no luck. I have tried 6001-6017 and they fail too. The error looks like:

    -----------------------------------------
    Informatica(r) PMCMD, version [9.0.1 HotFix2], build [242.1111], Windows 64-bit
    Copyright (c) Informatica Corporation 1994 - 2010
    All Rights Reserved.

    Invoked at Thu Mar 28 17:55:11 2013

    The command: [pingserver] is deprecated. Please use the command [pingservice] in the future.
    WARNING: Lost server connection.
    ERROR: Cannot connect to Integration Service [IS_biwhse2c:6014].
    ----------------------------------------
  • 4. Re: DAC/Integration Server Port
    Srini VEERAVALLI Guru
    Currently Being Moderated
    Can you try to ping the service to check valid port, keep change the port for each failure.
    pmcmd pingservice -s HostName:6001
  • 5. Re: DAC/Integration Server Port
    SunilSharma Expert
    Currently Being Moderated
    login to Admin console for Informatica and see the port on node which you have used during the installation of informatica and make sure you have the Infromatica services up and running.

    Have you installed the dac and informatica on same machine. Make sure you have defined the PATH env variables and copied the pmcmd and pmrep files onto informatica client install folder.

    Thanks,
    RM
  • 6. Re: DAC/Integration Server Port
    dirkt Newbie
    Currently Being Moderated
    That did it. I Looking at the node in Informatica Administrator gave me the port range and I was able to identify the correct port as 6014. But Test Connection was still failing. It turns out that although DAV_ENV.BAT was correct since I am starting the DAC server as a service I needed the DAC environment variables defined as system environment variables so they would available in the DAC server environment. Once I did that everything worked as advertised.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points