7 Replies Latest reply: Apr 1, 2013 4:44 AM by hyperionEPM RSS

    Performance Issues when accessing Hyperion using Remote/client computers

    hyperionEPM
      Hello Gurus,

      I have recently installed and configured EPM 11.1.2.2 on windows 2008 server. It is a distributed system and when I access the planning applications in workspace by taking remote access to the servers, the response time is quick. But when I access the same applications using workspace on a remote computer connected using VPN, the response time is unbearable and sometimes the applications just freezes and does nothing.

      Is there a way to increase the performance so that the response time on the remote computer is also good.

      I have sufficient internet bandwidth and I can load other web pages without any delays.. Any help will be appreciated.

      Thanks.
      hyperionEPM
        • 1. Re: Performance Issues when accessing Hyperion using Remote/client computers
          Nicholas King
          The performance of Hyperion over a WAN is largely based on network latency. The Hyperion Web UI is built to send a lot of small packets back and forth between the Hyperion servers and the Client. This is fine for intranet, and most semi-local deployments. However, when you start talking about international sites the latency becomes large and performance suffers greatly. Note, I am not talking about strictly bandwidth - but latency. There are a lot of tuning guidelines, but none I have seen really talk about improving network performance. One trick is to use compression at the HTTP layer, but in my opinion this wont help latency issues.

          A little bit of advice:
          1) figure out where your vpn is connecting to vs where your hyperion data center is - try to get this distance to a minimum. Your network admins should be able to help you connect to the closest vpn servers to your env.
          2) if you are doing international type connections you may look at using Citrix. Citrix will focus on just just painting the screen which will push the Hyperion latency issues back to the Citrix <-> Hyperion interaction in the same DS.
          3) Have your net admins look @ your vpn connection - maybe it is saturated or they can suggest some helpful info
          4) if your setup is pretty much local and your vpn is local - I would point the finger @ your network admins to help resolve - it should not be that slow unless you are working from far distances

          Anyway - just a few hints. Like you mention - the local server to server traffic is fast - so I don't see much direct Hyperion tuning that would help much.


          Nick
          • 2. Re: Performance Issues when accessing Hyperion using Remote/client computers
            hyperionEPM
            Hello Nick,

            I really appreciate your help on this.

            We did a stress testing on the server by logging into workspace using

            1) A client computer which is connected using VPN and
            2) By taking Remote access to the server and accessing workspace.

            We seem to be facing issues only on the Client computers when we give enough load by performing a lot of operations randomly into the planning applications - like Loading forms from multiple applications at the same time, running BR's, Calc Scripts, Launching Task lists etc..

            At certain point it works normally, and after a certain point the response starts degrading ...and then it starts giving the following issues --
            http://s15.postimg.org/bij9pw8iz/Untitled.png

            And the value for PPR keeps increasing...Any ideas on what might be causing the issue to appear only when on client computer and not on remote computer?

            Thanks.
            hyperionEPM
            • 3. Re: Performance Issues when accessing Hyperion using Remote/client computers
              Nicholas King
              I still think this is due to network performance/latency issues over vpn. The more forms, apps..etc you load up in the browser the more processing needs to happen at the web UI layer. Check the items I listed and perhaps also look for lost/dropped packets at the vpn.
              You probably want to get your network engineer involved.

              Thanks
              Nick
              • 4. Re: Performance Issues when accessing Hyperion using Remote/client computers
                Nicholas King
                Also,

                The error you are seeing is at the web/client layer too - I suspect there are no errors coming from the server side. Look over the workspace/planning logs - if no errors present themselves on the server the issue is likely at the client side.
                • 5. Re: Performance Issues when accessing Hyperion using Remote/client computers
                  hyperionEPM
                  Hello Nick,

                  I checked the Planning0, Planning sysout logs and found that there are entries for the error in the log.. so it must be the error on the server side?

                  I will also get in touch with the networking team to get any update on the network issues.


                  Thanks,
                  hyperionEPM
                  • 6. Re: Performance Issues when accessing Hyperion using Remote/client computers
                    Nicholas King
                    What errors do you see in the planning logs?

                    Thanks
                    Nick
                    • 7. Re: Performance Issues when accessing Hyperion using Remote/client computers
                      hyperionEPM
                      Hello Nick,

                      I am getting similar kind of entries as shown in the screenshot in the logs as well. I will be able to share the exact contents tomorrow.

                      The common entries are -

                      java.lang.NumberFormatException with the ADF_FACES-60097 entries in the logs.

                      I have recently checked Oracle support and have found something similar to it there -

                      Bug 15936132 : ADSHYP11122SV6:PLN: ADF_FACES-60097

                      May be this is something worth to check out. Not sure if that is causing the issue at our end when accessing it using client machines.

                      Thanks,
                      hyperionEPM