7 Replies Latest reply: Apr 3, 2013 8:48 PM by User733825-Oracle RSS

    Problem installing OBIEE 11.1.1.6 on Linux 64-bit

    User733825-Oracle
      Hi,

      I am trying to install OBIEE 11.1.1.6 on OEL5.8 64-bit virtual machine.

      The Software Only install (the recommended option when I have other WebLogic apps running) gives me a message "an application server must already be installed" when I give it my MWHOME directory - I am running WebLogic 10.3 - I have an Oracle Forms application running successfully on the machine.

      This is the installActions.log:

      The file oraparam.ini could not be found at ./oraparam.ini
      Using paramFile: /u00/oracle/product/11.2.0/dbhome_1/oui/oraparam.ini


      Checking swap space: must be greater than 500 MB. Actual 5951 MB Passed
      Checking monitor: must be configured to display at least 256 colors. Actual 16777216 Passed


      The number of files bootstrapped for the jre is 594.

      The number of files bootstrapped for the oui is 142.
      Using the umask value '022' available from oraparam.ini

      Execvp of the child jre : the cmdline is /u00/temp/OraInstall2013-03-28_11-32-24AM/jre/bin/java, and the argv is
      /u00/temp/OraInstall2013-03-28_11-32-24AM/jre/bin/java
      -Doracle.installer.library_loc=/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/lib/linux64
      -Doracle.installer.oui_loc=/u00/temp/OraInstall2013-03-28_11-32-24AM/oui
      -Doracle.installer.bootstrap=TRUE
      -Doracle.installer.startup_location=/u00/oracle/product/11.2.0/dbhome_1/oui/bin
      -Doracle.installer.jre_loc=../../jre
      -Doracle.installer.nlsEnabled="TRUE"
      -Doracle.installer.prereqConfigLoc=
      -Doracle.installer.unixVersion=2.6.32-300.39.4.el5uek
      -mx150m
      -cp
      /u00/temp/OraInstall2013-03-28_11-32-24AM::/u00/temp/OraInstall2013-03-28_11-32-24AM/ext/jlib/remoteinterfaces.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/ext/jlib/OraPrereq.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/ext/jlib/OraPrereqChecks.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/ext/jlib/prov_fixup.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/ext/jlib/emagentSDK.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/ext/jlib/jsch.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/ext/jlib/log4j-core.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/ext/jlib/instcommon.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/ext/jlib/ojdbc5.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/ext/jlib/installcommons_1.0.0b.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/ext/jlib/orai18n-utility.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/ext/jlib/cvu.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/ext/jlib/ssh.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/ext/jlib/emConfigInstall.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/ext/jlib/orai18n-mapping.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/ext/jlib/instdb.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/OraInstaller.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/oneclick.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/xmlparserv2.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/share.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/OraInstallerNet.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/emCfg.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/emocmutl.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/OraPrereq.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/jsch.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/ssh.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/remoteinterfaces.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/http_client.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/OraSuiteInstaller.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/OPatch/jlib/opatch.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/OPatch/jlib/opatchactions.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/OPatch/jlib/opatchprereq.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/OPatch/jlib/opatchutil.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/OraCheckPoint.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/InstImages.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/InstHelp.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/InstHelp_de.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/InstHelp_es.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/InstHelp_fr.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/InstHelp_it.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/InstHelp_ja.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/InstHelp_ko.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/InstHelp_pt_BR.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/InstHelp_zh_CN.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/InstHelp_zh_TW.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/oracle_ice.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/help4.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/help4-nls.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/ewt3.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/ewt3-swingaccess.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/ewt3-nls.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/swingaccess.jar::/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/jewt4.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/jewt4-nls.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/orai18n-collation.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/orai18n-mapping.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/ojmisc.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/xml.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/srvm.jar:/u00/temp/OraInstall2013-03-28_11-32-24AM/oui/jlib/srvmasm.jar
      oracle.sysman.oii.oiic.OiicInstaller
      -scratchPath
      /u00/temp/OraInstall2013-03-28_11-32-24AM
      -sourceType
      network
      -timestamp
      2013-03-28_11-32-24AM
      -deinstall
      INFO: Environment Variables:

      INFO: ORACLE_HOME = /u00/oracle/product/11.2.0/dbhome_1

      INFO: PATH = /u00/oracle/product/11.2.0/dbhome_1/bin:/usr/jdk1.6.0_38/bin:/app/GoldenGate:/u00/oracle/product/11.2.0/dbhome_1/bin:/usr/jdk1.6.0_38/bin:/app/GoldenGate:/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/home/oracle/bin

      INFO: CLASSPATH =

      INFO: Username:oracle

      INFO: SRVM ClusterInfo.IsLocalOnly() called. Return value obtained is 'false'.

      INFO: The CRS clusterware location for 'oracle.crs 10.1.0.2.0' is not found.

      INFO: CRS clusterware not found. Defaulting to vendor clusterware.

      INFO: Vendor clusterware is not detected.

      INFO: Install area Control created with access level 1

      INFO: Oracle Universal Installer version is 11.2.0.3.0





      No other log file is created. The only thing I can do is Cancel.

      Thanks, in advance, for any help!

      Nick
        • 1. Re: Problem installing OBIEE 11.1.1.6 on Linux 64-bit
          SunilSharma
          try using the temp folder to a different location(which has good amount of space) instead of using the default one which is /u00/tmp i think its getting filled up during the install. Do df -k and check the space allocated for /u00/tmp
          • 2. Re: Problem installing OBIEE 11.1.1.6 on Linux 64-bit
            User733825-Oracle
            Thank you for your suggestion. I can certainly try pointing to a different temp folder, but how much space does it need?

            /u00/temp appears to have quite a bit of space available...

            [oracle@oel58 logs]$ df -k
            Filesystem 1K-blocks Used Available Use% Mounted on
            /dev/mapper/VolGroup00-LogVol00
            16663980 3820232 11983588 25% /
            /dev/sda2 99188500 18500088 75568500 20% /u00
            /dev/sda1 101086 41172 54695 43% /boot
            tmpfs 3170304 1063332 2106972 34% /dev/shm
            shmfs 3170304 1063332 2106972 34% /dev/shm
            ShareVB 320864252 168386324 152477928 53% /media/sf_ShareVB
            [oracle@oel58 logs]$ df -k /u00/temp
            Filesystem 1K-blocks Used Available Use% Mounted on
            /dev/sda2 99188500 18500088 75568500 20% /u00


            Also, I verified TMP, TMPDIR, and TEMP all point to /u00/temp.

            And the preinstallation check shows this:
            Checking Temp space: must be greater than 1536 MB. Actual 73797 MB Passed
            Checking swap space: must be greater than 500 MB. Actual 5951 MB Passed
            Checking monitor: must be configured to display at least 256 colors. Actual 16777216 Passed

            It might be worth mentioning, as well, that I get the same result, whether I use ...Disk1/runInstall.sh or ...Disk1/install/linux64/runInstall.sh

            The file I originally posted came from trying the linux64 installer.

            What else can we check/try?

            Edited by: user733825 on Mar 28, 2013 6:26 PM

            What is it that tells the installer there is an application server running? Is it checking for some WebLogic environment variable I may have incorrectly configured? I have a WebLogic server running, and it is hosting a Forms server and a help server. Why does the installer think there is no Application Server installed?

            Edited by: user733825 on Mar 28, 2013 7:23 PM
            • 3. Re: Problem installing OBIEE 11.1.1.6 on Linux 64-bit
              SunilSharma
              ya it looks like /u00 has got enough space of around 75gb free. when are you providing the server path with the foldername MWHOME. Try installing the OBIEE on a different folder(eg: /u00/MW_HOME) instead of one already using MWHOME for weblogic server where you forms are running.

              look at this http://obieeelegant.blogspot.com/2012/07/obiee111160-software-only-installation.html

              hope it helps

              Thanks,
              RM
              • 4. Re: Problem installing OBIEE 11.1.1.6 on Linux 64-bit
                User733825-Oracle
                RM, thank you again for helping me.

                Aside from being Linux, and not Windows 7, my installation looks exactly like the on in the blogspot you provided all the way up to OBIEE 11.1.1.6 step 5 of 9.

                On that screen (Installation Location), where in the bottom pane it shows "An Application Server must already be installed." - no matter whether I use my MWHOME, or a different MW_HOME folder, I can not get past that step.
                • 5. Re: Problem installing OBIEE 11.1.1.6 on Linux 64-bit
                  SunilSharma
                  I think its getting auto-populated the install path and when you click next it throws the error "application server must already be installed" So Can you please try to manually browse the same path where you have the weblogic installed which is MW_HOME and see if it works. Generally it should work as i tried the same and it works for me too.

                  Thanks,
                  RM
                  • 6. Re: Problem installing OBIEE 11.1.1.6 on Linux 64-bit
                    User733825-Oracle
                    Hi RM,

                    Yes, the path is auto-populated when I come to the screen.

                    I did try manually typing the correct path where middleware is installed, as well as manually typing a different path, as well as browsing to a different path, and browsing to the correct path, all with the same results. They all show me that same message on the bottom of the screen, and clicking "Next" does nothing.

                    Do you know what it's looking for to determine if an application server is installed and running?

                    Edit (Basically, I am beginning to wonder if I missed a step in installing WebLogic, or have a folder in the wrong place, or named incorrectly, or something...)

                    Thanks,

                    Nick

                    Edited by: user733825 on Mar 29, 2013 4:55 PM
                    • 7. Re: Problem installing OBIEE 11.1.1.6 on Linux 64-bit
                      User733825-Oracle
                      The problem is resolved.

                      I created a new machine and ran into an error with the Enterprise Install of OBIEE, so I reported that problem in the thread "Problem installing OBIEE 11.1.1.6 on Linux 64-bit Redux"

                      Srini saw the error message, and remarked on its similarity to Knowledge Base Document ID 1431688.1

                      My Linux box is a VirtualBox on a Windows7 system. I downloaded and unzipped all the installation files to the WINDOWS shared drive, that is common for all my VirtualBox machines, so I can use the same downloads and install directories, to save time and disk space.

                      It works great for everything, except OBIEE.

                      When I unzipped the files into a space INSIDE the VirtualBox Linux machine, the installer works perfectly, whether I do a full Enterprise install on the new box, or a software only install on the box for which I reported this problem.

                      Apparently, there is something different with the way Windows7 stores the unzipped Linux files, and the way Linux stores the unzipped Linux files, and it's enough to give the install script hiccups.

                      Thank you for all your help!!

                      Nick