4 Replies Latest reply: Apr 21, 2013 5:08 AM by clementeOTN RSS

    Problems installing  OEM Cloud control 12c in Oracle Linux 6.X

    clementeOTN
      Hi

      I'm triying to install Oracle Enterprise Manager Cloud 12c in a Oracle Linux 6.4

      Looking at the installation documentation in in http://docs.oracle.com/cd/E24628_01/install.121/e22624/preinstall_req_packages.htm#CHDEJAFA it sys that I need the packages :

      glibc-devel-2.5-49-i686 (This is a 32-bit package)
      glibc-devel-2.5-49-x86_64 (This is a 64-bit package)



      But I cant find them in the yum repositories.

      If I query to my linux wihch version of glibc-devel are installed the output is

      -----
      [root@emc tmp]# rpm -qa |grep glibc-devel
      glibc-devel-2.12-1.107.el6.x86_64
      -----

      And if i try to install it i receive an error compiling ins_sqlplus.mk due to ld because it can't find crt1.o


      Can anybody help me?
      thanks
        • 1. Re: Problems installing  OEM Cloud control 12c in Oracle Linux 6.X
          Akanksha Sheoran Kaler-Oracle
          What is the version of EM that you are trying to Install? Is it 12.1.0.1 EM ?

          a) If this is em 12.1.0.1 then its a know issues to us which is fixed in next release ( you can refer bug:13833746 from MOS or open an SR to get more detail on this bug)

          Run this below to make usre you have the packages.
          # rpm -qa --queryformat "%{NAME}-%{VERSION}-%{RELEASE}(%{ARCH})\n" | grep glibc-dev
          glibc-devel-2.12-1.80.el6(i686)
          glibc-devel-2.12-1.80.el6(x86_64)

          Checking the pre-requisites step fails as it is looking for i386 instead of i686. (On OEL6, prefix i686 denotes the 32 bit package - and not i386). If the 32 bit and 64 bit glibc-devel packages are present on the system ( check it manually) this Warning can be safely Ignored. Continue with the installation. If you are not sure, pls log an SR with Oracle support and they will help you. Donot ignore the warning in case of any doubts, work with support to get it solved. If you ignore the warning and packages are not on the host then you will get linking error during the install.

          b) If this is em 12.1.0.2, pls log an SR and send me the SR number.

          Edited by: Akanksha on Apr 2, 2013 2:14 PM
          • 2. Re: Problems installing  OEM Cloud control 12c in Oracle Linux 6.X
            clementeOTN
            Hi
            The problem is that i cant found the prerequisites


            [root@emc ~]# rpm -qa --queryformat "%{NAME}-%{VERSION}-%{RELEASE}(%{ARCH})\n" | grep glibc-dev
            glibc-devel-2.12-1.107.el6(x86_64)

            [root@emc ~]# yum install glibc-devel-2.12-1.80.el6
            Loaded plugins: security
            Setting up Install Process
            Package matching glibc-devel-2.12-1.80.el6.x86_64 already installed. Checking for update.
            Nothing to do

            [root@emc ~]# cat /etc/oracle-release
            Oracle Linux Server release 6.4
            [root@emc ~]# uname -a
            Linux emc 2.6.39-400.17.2.el6uek.x86_64 #1 SMP Wed Mar 13 12:31:05 PDT 2013 x86_64 x86_64 x86_64 GNU/Linux

            ¿What can I do?
            • 3. Re: Problems installing  OEM Cloud control 12c in Oracle Linux 6.X
              Loc Nhan -Oracle
              There is copy of glibc-devel-2.12-1.107.el6.i686.rpm available through the link below. You may want to try it out.

              http://www.elders.princeton.edu/data/puias/6/i386/os/Packages/glibc-devel-2.12-1.107.el6.i686.rpm

              Regards,
              - Loc
              • 4. Re: Problems installing  OEM Cloud control 12c in Oracle Linux 6.X
                clementeOTN
                Hi

                I finally do it.
                At the end i saw the command in another post . The trick was add ".i686" ath the end

                yum install glibc-devel.i686


                [root@emc ~]# rpm -qa --queryformat "%{NAME}-%{VERSION}-%{RELEASE}(%{ARCH})\n" | grep glibc-dev
                glibc-devel-2.12-1.107.el6(x86_64)
                glibc-devel-2.12-1.107.el6(i686)


                I haven`t the 2.12-1.80.el6 but with the 2.12-1.107.el6 works fine.
                Thanks everybody and sorry for the annoyances