2 Replies Latest reply on Apr 1, 2013 10:33 PM by 1000026

    Oracle linux server hangs while booting

      I'm running Oracle Linux Server 6.1.64 in VirtualBox 4.1.16 as the guest OS. The host OS is Windows 7.

      After installing, it worked for a week or so. Then I decided to apply the 700 odd updates suggested by the package manager.

      Thereafter while booting, it gets stuck after completing the progress bar for Oracle Linux Server 6.1.

      I am able to go into single mode by editing the GRUB command and there are no issues there.

      I looked into /var/log/dmesg and messages. I am no Linux expert, but I didn't see anything that jumped out as an error.

      Any advice on how to go about debugging this would be appreciated.
        • 1. Re: Oracle linux server hangs while booting
          To see where it hangs, I suggest to press any key at system startup to enter the Grub boot menu. Then move the cursor onto the kernel line and use the letter 'e' to edit and remove the words rhgb and quiet. Press 'b' to boot the system and it should print all kinds of messages during startup. Where does it stop?
          1 person found this helpful
          • 2. Re: Oracle linux server hangs while booting
            The problem, as far as I could determine, was in the incompatibility of the Virtual Box Guest Additions with the X11 package installed.

            There were some error messages in /var/log/X*.log and /var/log/gdm to that effect

            In "single" mode, I edited /etc/X11/xorg.conf, to comment out everything in it as suggested in a post on some other site.

            Thereafter the boot process completed and I was presented with the graphical login screen.

            The user experience was bad of course. No full screen was the primary problem.

            So I upgraded VirtualBox to the latest release, remounted the Guest Additions and installed the latest guest additions.

            It works now.

            Basically after a yum update, there was some incompatibility in the VirtualBox version I was running and the X window system. The boot process was completing, but the X system couldn't start. Upgrading VirtualBox solved the problem.