3 Replies Latest reply: Apr 2, 2013 8:27 AM by 1000463 RSS

    Oracle OCI for iOS : facing build errors

      Hi, I downloaded the following 2 zip files of Version (64-bit)
      1. instantclient-basic-macos.x64-
      2. instantclient-sdk-macos.x64-

      from :

      I unzipped them, and imported them to XCode in a new project. But when i build the project, I get these warnings:


      Can someone please help resolve these issues? Am trying to use OCI for connecting to Oracle DB.

      Edited by: user8451904 on Apr 2, 2013 6:35 AM
        • 1. Re: Oracle OCI for Mac : facing build errors
          Are you developing an OS X application or an iOS application? Because the error message in your screenshot says that the architecture being linked is armv7, which means you're developing an iOS application, but the Oracle Instant Client libraries you downloaded are for the OS X x86_64 architecture. If you are trying to make an OS X application, then your Xcode project is set up for the wrong architecture at least. If you are trying to make an iOS application, then you'll need iOS versions of the Oracle Instant Client libraries—and I don't see any such thing listed on the Oracle Instant Client downloads page.
          • 2. Re: Oracle OCI for Mac : facing build errors
            Thanks for your response. Yes, am trying to develop an iOS application which will use OCI. In the process, am attempting to compile OCI (which has been provided for Mac OS X) for ARM. Thoughts/suggestion?
            • 3. Re: Oracle OCI for Mac : facing build errors
              I realized now that the image I shared previously (showing the warnings) is of poor resolution. Here's a better one: