4 Replies Latest reply on Apr 3, 2013 2:29 AM by Hemant K Chitale

    Unable to restore database using RMAN in oracle 10g

    Tushar Lapani
      Hi Everyone!!!!!!!

      I have following scenario. In which I don't want to drop newly created tablespace (test). So, let me know how to restore database from existing backup without dropping new tablespace and taking new backup?

      1. I took database backup as
      RMAN > backup database;

      2. Create one tablespace "test"

      3. Then I tried to restore database as (In mount mode)
      RMAN > restore database

      4. But I can't restore database. Even I tried after taking "test" tablespace offline , It returns error as follow

      ORA-01119: error in creating database file 'D:\ORACLE\PRODUCT\10.2.0\ORADATA\TESTCAT\TEST.DBF'
      ORA-27038: created file already exists
      OSD-04010: <create> option specified, file already exists

      Please suggest me step/way so that I can restore database without taking new backup or dropping new tablespace (test).........