4 Replies Latest reply: Apr 7, 2013 2:46 PM by 987409 RSS

    Invoking Secure web service from OSB adding soap:mustUnderstand="true"

    987409
      hi,

      We are receiving below response from remote webservice:
      <soap:Fault>
      <soap:Code>
      <soap:Value>soap:MustUnderstand</soap:Value>
      </soap:Code>
      <soap:Reason><soap:Text xml:lang="en">MustUnderstand headers: [{http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd}Security] are not understood.</soap:Text>
      </soap:Reason>
      </soap:Fault>

      OSB is adding attribute-soap:mustUnderstand="true" in header for every outbound request.

      We would like to know the configuration to remove this additional attribute OSB is adding by-default.