4 Replies Latest reply: Apr 12, 2013 5:57 AM by Helios-GunesEROL RSS

    Linux Packages

    1001491
      Hello, i am trying to install oracle database 11g release 2 on linux release 6.3
      but there packages are needed, I am tried to install these packages but i find that its already installed with newer version.
      and still when i am try to install 11gr2 in 'prerequisite checks' have this result:

      *"This is a prerequisite condition to test whether the package "libaio-0.3.105" is available on the system. (more details)*
      *Expected Value : libaio-0.3.105 (i386)*
      *Actual Value: missing"*


      Can someone please help me in this case..
      Best regards..
      khaled..

      Edited by: 998488 on Apr 7, 2013 12:54 AM
        • 1. Re: Linux Packages
          Dude!
          Oracle provides a package named oracle-rdbms-server-11gR2-preinstall that will address installation prerequisites. You can find many references on the web, for instance, https://blogs.oracle.com/linux/entry/oracle_rdbms_server_11gr2_pre
          • 2. Re: Linux Packages
            Avi Miller-Oracle
            khaled.a.n wrote:
            Hello, i am trying to install oracle database 11g release 2 on linux release 6.3
            Also, make sure you are installing 11.2.0.3 or higher of DB. Anything older than that doesn't work on Oracle Linux 6.
            • 3. Re: Linux Packages
              Amar_Singh
              Please note that there are some RPMS which needs 2 version of it, one for the x64 version which you are currently on and one for x32 version.

              As you can see from the output:
              Expected Value : libaio-0.3.105 (i386)
              Actual Value: missing"


              So you might be correct that you have libaio rpm installed on the server, but you also need to install 32bit RPM for libaio. Please do that, once its done the following command: rpm -qa | grep -i libaio should return 2 RPMs installed on it, one for 64 bit version and one for 32 bit, even though you are on 32 bit OS but its still needed.
              • 4. Re: Linux Packages
                Helios-GunesEROL
                Hi;

                What is exact db version? Only 11.2.0.3 higher certfiied with oel&rhel 6.. You can follow

                Requirements for Installing Oracle 11gR2 RDBMS on RHEL6 or OL6 64-bit (x86-64) [ID 1441282.1]
                Master Note of Linux OS Requirements for Database Server [ID 851598.1]


                Regard
                Helios