This discussion is archived
5 Replies Latest reply: Apr 8, 2013 10:30 AM by david.karr RSS

Log file

996933 Newbie
Currently Being Moderated
I am getting the below error in weblogic,

Error 404--Not Found

From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1:

10.4.5 404 Not Found

The server has not found anything matching the Request-URI. No indication is given of whether the condition is temporary or permanent.

The log file(C:\Oracle\Middleware\user_projects\domains\weblogic_domain\servers\AdminServer\logs\weblogic_domain.txt) shows
####<Apr 7, 2013 7:10:29 PM EDT> <Warning> <netuix> <HHQOP780JCJ0QN1> <AdminServer> <[ACTIVE] ExecuteThread: '13' for queue: 'weblogic.kernel.Default (self-tuning)'> <weblogic> <> <> <1365376229955> <BEA-423420> <Redirect is executed in begin or refresh action. Redirect url is /console/console.portal?_nfpb=true&_pageLabel=WebAppApplicationOverviewPage&WebAppApplicationOverviewPortlethandle=com.bea.console.handles.AppDeploymentHandle%28%22com.bea%3AName%3Dmp%2CType%3DAppDeployment%22%29.>

which log file do I need to refer to get further information about the error??
  • 1. Re: Log file
    david.karr Pro
    Currently Being Moderated
    In the same directory as your log file, you should find a "access.log" file. This records attempts to access the web server through http and the resulting HTTP status code. If something resulted in a 404, this will tell you what page it was trying to access.
  • 2. Re: Log file
    996933 Newbie
    Currently Being Moderated
    Previously it used to record, as far as I remember.

    But now it doesn't record anything. The file is empty (0 bytes).

    Do you have any idea?
  • 3. Re: Log file
    david.karr Pro
    Currently Being Moderated
    The file is emptied when you restart your server. Start the server and try accessing pages on it. You might have archived versions of the log in the same directory, or in an "archives" directory.
  • 4. Re: Log file
    996933 Newbie
    Currently Being Moderated
    Thanks for letting me know that the file will be emptied when the server starts, I don't have a clue about this.

    Now I am getting this in the access page,

    0:0:0:0:0:0:0:1 - - [08/Apr/2013:13:11:27 -0400] "GET /favicon.ico HTTP/1.1" 404 1164
    0:0:0:0:0:0:0:1 - - [08/Apr/2013:13:11:27 -0400] "GET /favicon.ico HTTP/1.1" 404 1164
    0:0:0:0:0:0:0:1 - - [08/Apr/2013:13:11:44 -0400] "GET /favicon.ico HTTP/1.1" 404 1164
    0:0:0:0:0:0:0:1 - - [08/Apr/2013:13:11:48 -0400] "GET /favicon.ico HTTP/1.1" 404 1164
    0:0:0:0:0:0:0:1 - - [08/Apr/2013:13:11:51 -0400] "GET /favicon.ico HTTP/1.1" 404 1164
    0:0:0:0:0:0:0:1 - - [08/Apr/2013:13:11:51 -0400] "GET /favicon.ico HTTP/1.1" 404 1164
    2001:0:9d38:6ab8:3ca3:10bf:f5df:fee1 - - [08/Apr/2013:13:11:52 -0400] "GET /main HTTP/1.1" 302 317
    2001:0:9d38:6ab8:3ca3:10bf:f5df:fee1 - - [08/Apr/2013:13:11:52 -0400] "GET /main/ HTTP/1.1" 200 56
    2001:0:9d38:6ab8:3ca3:10bf:f5df:fee1 - - [08/Apr/2013:13:11:52 -0400] "GET /main/index.action HTTP/1.1" 404 1164
    2001:0:9d38:6ab8:3ca3:10bf:f5df:fee1 - - [08/Apr/2013:13:11:52 -0400] "GET /favicon.ico HTTP/1.1" 404 1164
    2001:0:9d38:6ab8:3ca3:10bf:f5df:fee1 - - [08/Apr/2013:13:11:52 -0400] "GET /favicon.ico HTTP/1.1" 404 1164
    2001:0:9d38:6ab8:3ca3:10bf:f5df:fee1 - - [08/Apr/2013:13:11:52 -0400] "GET /favicon.ico HTTP/1.1" 404 1164


    Previously I remember that I used to get some exceptions like FileNotFoundException in weblogic_domain.log/Admin_server.log.
    I couldn't figure why this is not happening now, can you help me out??

    Do you need any details about my war file?
  • 5. Re: Log file
    david.karr Pro
    Currently Being Moderated
    You haven't provided any information that someone could use to diagnose your problem.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points