4 Replies Latest reply on Apr 8, 2013 8:30 PM by Jeets-Oracle

    JRE not found error

    Adi Md
      Hi All,
      I am getting following error while starting WebLogic -
      The JRE was not found in directory C:\Users\bi\Oracle_BI1\jdk. (JAVA_HOME)
      Please edit your environment and set the JAVA_HOME
      variable to point to the root directory of your Java installation.
      Press any key to continue . . .

      There is no directory ORACLE_BI1 on my machine ( May be I deleted by mistake without understanding the impact).

      I have set JAVA_HOME in environmental variable and pointing to C:\\Program Files (x86)\Java\jdk_1.6 where JDK is installed.

      Still WebLogic is checking the old directory and giving error.

      Appreciate help from expert to reset this path in WebLogic.

        • 1. Re: JRE not found error
          Are you trying to start up a WebLogic server or are you trying to start the WebLogic installation? Regardless, your JDK needs to be in your PATH system environment variable. You can easily verify by opening up Command Prompt and running "echo %PATH%". If you see "C:\Program Files (x86)\Java\jdk1.6.0_##\bin" anywhere inside, it is in your PATH environment variable. If it is missing, you will need to add the directory in your PATH system environment variables on your PC/server. Just in case, I would modify the directory in the PATH environment file to read "C:\PROGRA~2\Java\jdk1.6.0_##\bin" which is the same thing as going to C:\Program Files (x86)\... The reason is that I have seen weird issues occur when parentheses (or even spaces) are in the PATH environment variable. NOTE: The ## in the jdk directory is the update version of Java 6 you are using, e.g. Java 1.6.0_35 (jdk1.6.0_35).

          Regarding the possible deletion of the Oracle_BI1 directory, try to see if applying the above fix will allow you to start up your WebLogic environment as well as run it. If you notice any weird errors (different from the one you are currently receiving) when starting up and/or running the WebLogic environment due to the Oracle_BI1 directory missing, you may want to consider reinstalling WebLogic as well as any Fusion Middleware products installed in the Middleware home you are working in.

          As I see this is a Windows environment, what version of Windows are you using? Is it 32-bit or 64-bit? Also, what version of WebLogic Server are you using? Is the WebLogic installer you used or are using 32-bit or 64-bit? Is the JDK/JRE you are using 32-bit or 64-bit? If WebLogic is already installed, what Oracle Fusion Middleware products are installed inside it?

          Scott (PITSS)
          • 2. Re: JRE not found error
            Adi Md
            Thanks for the response.
            I have got this directory in the PATH variable. I also noticed that the PATH has got details of directory pointing to the deleted folder.
            I removed those details. I tried again but I am still getting same error.
            I will restart my system and try again and update you.

            Thanks again
            • 3. Re: JRE not found error
              Adi Md
              I am still getting the message after restarting the machine.

              i am trying to start the WebLogic.
              I am not sure from where is this picking up this path?

              Now the PATH has got only required directory.
              • 4. Re: JRE not found error
                Check your .sh/.cmd files, to confirm which location is the JDK pointing to.

                Weblogic internall uses setWLSEnv or commonEnv to set the JDK_HOME.

                So would request you to check the same in .sh or .cmd files, instead of system environment variables.