This discussion is archived
1 2 3 Previous Next 42 Replies Latest reply: May 3, 2013 9:13 AM by user11952526 RSS

RW-50011:Error: -System Utilities Availability test has returned an error:1

user11952526 Newbie
Currently Being Moderated
Hi,

Getting the following error while installing EBS 11i(11.5.10) on OEL 5.6 32-bit(x86).

How to fix this error ???

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
System Utilities Check :
------------------------------

These utilities need to be accessible on your system in order to do administrative tasks.
command : /u01/eds/stage/EBS_11i-11.5.10_For_Linux_32-bit/startCD/Disk1/rapidwiz/bin/adchkutl.sh
Checking for make...     found - /usr/bin/make
Checking for ld...     found - /usr/bin/ld
Checking for cc...     found - /usr/bin/cc
Checking for ar...     found - /usr/bin/ar
Checking for ksh...     
Unable to find 'kshell' in path
Unable to locate all utilities with system path.
PATH = /usr/bin:/u01/eds/stage/EBS_11i-11.5.10_For_Linux_32-bit/startCD/Disk1/rapidwiz/unzip/Linux:/usr/bin:/usr/local/bin:/usr/lib/qt-
3.3/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin

RW-50011: Error: - System Utilities Availability test has returned an error: 1
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Thanks.
  • 1. Re: RW-50011:Error: -System Utilities Availability test has returned an error:1
    Carlo den Otter Explorer
    Currently Being Moderated
    Hello,

    Make sure /usr/bin/kshell is installed.
    This should be done by adding package/rpm named 'kdelibs'

    Regards, Carlo den Otter.
  • 2. Re: RW-50011:Error: -System Utilities Availability test has returned an error:1
    Hussein Sawwan-Oracle Employee ACE
    Currently Being Moderated
    Unable to find 'kshell' in path
    Unable to locate all utilities with system path.
    Please see the following docs.

    Unable to find 'kshell' in PATH when executing 'adcfgclone.pl' [ID 451994.1]
    Oracle Applications 11i Installation on OEL5 or RHEL5 [ID 730444.1]

    Thanks,
    Hussein
  • 3. Re: RW-50011:Error: -System Utilities Availability test has returned an error:1
    user11952526 Newbie
    Currently Being Moderated
    Hi Carlo,

    Thanks for the update!
    I have installed kdelibs rpm, but getting the same error.

    FYI...
    =========================================================================================================

    # uname -a
    Linux linux1.erp.com 2.6.18-238.el5xen #1 SMP Tue Jan 4 16:18:33 EST 2011 i686 i686 i386 GNU/Linux


    # rpm -qa|grep -i kdelibs
    kdelibs-devel-3.5.4-25.0.1.el5_4.1
    kdelibs-3.5.4-25.0.1.el5_4.1
    kdelibs-apidocs-3.5.4-25.0.1.el5_4.1

    =========================================================================================================

    Regards.
  • 4. Re: RW-50011:Error: -System Utilities Availability test has returned an error:1
    user11952526 Newbie
    Currently Being Moderated
    Hi Hussein,

    Thanks for the update!
    As per doc I did the following steps...

    1.) Rename the existing /usr/bin/ld and then create the symbolic link.
    # mv /usr/bin/ld /usr/bin/ld.old
    # ln -s /usr/bin/ld215 /usr/bin/ld

    # ls -l /usr/bin/ld
    lrwxrwxrwx 1 root root 14 Jan 1 00:51 /usr/bin/ld -> /usr/bin/ld215


    2.) Install pdksh rpm, and startrd the "rapidwiz", but getting the same error.
    # rpm -qa|grep -i pdksh
    pdksh-5.2.14-36.el5


    Note : I noticed from *"Oracle Applications Installation Update Notes, Release 11i (11.5.10.2) [ID 316806.1]"*,
    when I tried to install compat-oracle-rhel4-1.0-5.i386.rpm, getting the following error even though its dependencies already installed...Please let me how to install compat-oracle-rhel4-1.0-5.i386.rpm.

    *# rpm -Uvh compat-oracle-rhel4-1.0-5.i386.rpm
    error: Failed dependencies:
    compat-gcc-32 is needed by compat-oracle-rhel4-1.0-5.i386
    compat-gcc-32-c++ is needed by compat-oracle-rhel4-1.0-5.i386
    openmotif21 is needed by compat-oracle-rhel4-1.0-5.i386*


    # rpm -qa|grep -i compat-gcc
    compat-gcc-34-g77-3.4.6-4.1
    compat-gcc-34-c++-3.4.6-4.1
    compat-gcc-34-3.4.6-4.1


    # rpm -qa|grep -i openmotif
    openmotif22-2.2.3-18


    Regards.
  • 5. Re: RW-50011:Error: -System Utilities Availability test has returned an error:1
    Kashif M Oracle ACE
    Currently Being Moderated
    Note : I noticed from *"Oracle Applications Installation Update Notes, Release 11i (11.5.10.2) [ID 316806.1]"*,
    when I tried to install compat-oracle-rhel4-1.0-5.i386.rpm, getting the following error even though its dependencies already installed...Please let me how to install compat-oracle-rhel4-1.0-5.i386.rpm.

    *# rpm -Uvh compat-oracle-rhel4-1.0-5.i386.rpm
    error: Failed dependencies:
    compat-gcc-32 is needed by compat-oracle-rhel4-1.0-5.i386
    compat-gcc-32-c++ is needed by compat-oracle-rhel4-1.0-5.i386
    openmotif21 is needed by compat-oracle-rhel4-1.0-5.i386*
    in the same note, please refer and download rpms from this location, this path is referred in MOS note and simply install.
    https://oss.oracle.com/projects/compat-oracle/files/RedHat/

    thanks
  • 6. Re: RW-50011:Error: -System Utilities Availability test has returned an error:1
    user11952526 Newbie
    Currently Being Moderated
    Hi,

    Higher version of these rpm's were already installed....


    *# rpm -Uvh compat-oracle-rhel4-1.0-5.i386.rpm
    error: Failed dependencies:
    compat-gcc-32 is needed by compat-oracle-rhel4-1.0-5.i386
    compat-gcc-32-c++ is needed by compat-oracle-rhel4-1.0-5.i386
    openmotif21 is needed by compat-oracle-rhel4-1.0-5.i386*


    *# rpm -qa|grep -i compat-gcc*
    compat-gcc-34-g77-3.4.6-4.1
    compat-gcc-34-c++-3.4.6-4.1
    compat-gcc-34-3.4.6-4.1

    *# rpm -qa|grep -i openmotif*
    openmotif22-2.2.3-18


    Regards.
  • 7. Re: RW-50011:Error: -System Utilities Availability test has returned an error:1
    user11952526 Newbie
    Currently Being Moderated
    Hi Hussein,

    I have installed all the dependencies and able to install compat-oracle-rhel4-1.0-5.i386.rpm. As per the metalink notes all the required rpm have been

    installed, but still getting the same error. Please do let me know how to go about it.

    Thanks.
  • 8. Re: RW-50011:Error: -System Utilities Availability test has returned an error:1
    Hussein Sawwan-Oracle Employee ACE
    Currently Being Moderated
    Are you still getting "Unable to find 'kshell' in path" error?

    Did you download and apply Patch 5972212?

    Thanks,
    Hussein
  • 9. Re: RW-50011:Error: -System Utilities Availability test has returned an error:1
    user11952526 Newbie
    Currently Being Moderated
    Hi Hussein,
    Yes, I am still getting "Unable to find 'kshell' in path".
    I am doing fresh installation. This patch# 5972212 is for already installed EBS.

    Thanks.
  • 10. Re: RW-50011:Error: -System Utilities Availability test has returned an error:1
    Hussein Sawwan-Oracle Employee ACE
    Currently Being Moderated
    user11952526 wrote:
    Hi Hussein,
    Yes, I am still getting "Unable to find 'kshell' in path".
    I am doing fresh installation. This patch# 5972212 is for already installed EBS.

    Thanks.
    What about the workaround solution mentioned in the same doc (setting KSH_VERSION)?

    What does "echo $KSH_VERSION" return?

    Thanks,
    Hussein
  • 11. Re: RW-50011:Error: -System Utilities Availability test has returned an error:1
    user11952526 Newbie
    Currently Being Moderated
    Hi Hussein,

    # echo $KSH_VERSION
    @(#)PD KSH v5.2.14 99/07/13.2

    Now I am through, installation started, but errored out with the following error...
    rw-50004 error code received when running external process linux

    From logfile I am pasting the error...
    *========================================================================================================================================*
    SQL*Plus: Release 9.2.0.5.0 - Production on Tue Jan 1 00:48:05 2002



    Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.



    Connected.

    Database closed.

    Database dismounted.

    ORACLE instance shut down.

    Connected to an idle instance.

    ORACLE instance started.



    Total System Global Area 581506616 bytes

    Fixed Size 452152 bytes

    Variable Size 402653184 bytes

    Database Buffers 167772160 bytes

    Redo Buffers 10629120 bytes

    Database mounted.

    Database opened.

    Database closed.

    Database dismounted.

    ORACLE instance shut down.

    Connected to an idle instance.

    ORACLE instance started.



    Total System Global Area 581506616 bytes

    Fixed Size 452152 bytes

    Variable Size 402653184 bytes

    Database Buffers 167772160 bytes

    Redo Buffers 10629120 bytes

    Database mounted.

    Database opened.

    declare

    *

    ERROR at line 1:

    ORA-12712: new character set must be a superset of old character set

    ORA-06512: at line 16





    Disconnected from Oracle9i Enterprise Edition Release 9.2.0.5.0 - Production

    With the Partitioning, OLAP and Oracle Data Mining options

    JServer Release 9.2.0.5.0 - Production

    ADX-1101 : Rapid Install characterset conversion failed

    Error found while running addbccnv.sql

    Cannot convert database characterset

    RW-50010: Error: - script has returned an error: 1
    RW-50004: Error code received when running external process. Check log file for details.
    Running Database Install Driver for PRD1 instance

    Succesfully changed Permissions for /u01/prd1/prd1db/9.2.0/appsutil/log/PRD1_linux1
    Processing DriverFile = /u01/eds/stage/EBS_11i-11.5.10_For_Linux_32-bit/startCD/Disk1/rapidwiz/template/adridb.drv
    Running Instantiation Drivers for /u01/eds/stage/EBS_11i-11.5.10_For_Linux_32-bit/startCD/Disk1/rapidwiz/template/adridb.drv
    instantiate file:
    source : /u01/eds/stage/EBS_11i-11.5.10_For_Linux_32-bit/startCD/Disk1/rapidwiz/template/adrun9i.sh
    dest : /u01/prd1/prd1db/9.2.0/temp/PRD1_linux1/adrun9i.sh
    backup : /u01/prd1/prd1db/9.2.0/temp/PRD1_linux1/adrun9i.sh to /u01/prd1/prd1db/9.2.0/appsutil/out/PRD1_linux1/templbac/adrun9i.sh
    setting permissions: 755
    setting ownership: oraprd1:dba
    instantiate file:
    source : /u01/eds/stage/EBS_11i-11.5.10_For_Linux_32-bit/startCD/Disk1/rapidwiz/template/adrundb.sh
    dest : /u01/prd1/prd1db/9.2.0/temp/PRD1_linux1/adrundb.sh
    backup : /u01/prd1/prd1db/9.2.0/temp/PRD1_linux1/adrundb.sh to /u01/prd1/prd1db/9.2.0/appsutil/out/PRD1_linux1/templbac/adrundb.sh
    setting permissions: 755
    setting ownership: oraprd1:dba
    Step 0 of 5

    Command: /u01/prd1/prd1db/9.2.0/temp/PRD1_linux1/adrun9i.sh

    Step 1 of 5: Doing UNIX preprocessing
    Executing: chmod -R 777 /etc/oraInventory
    chmod -R 777 /etc/oraInventory has succeeded

    Processing Step 1 of 5

    Step 1 of 5

    Command: /u01/prd1/prd1db/9.2.0/temp/PRD1_linux1/adrundb.sh

    Step 2 of 5: Doing UNIX preprocessing
    Executing: chmod -R 777 /etc/oraInventory
    chmod -R 777 /etc/oraInventory has succeeded

    Processing Step 2 of 5

    Executing: su oraprd1 -c "/u01/prd1/prd1db/9.2.0/temp/PRD1_linux1/adrundb.sh APPS APPS"

    ORA-12712: new character set must be a superset of old character set

    ORA-06512: at line 16



    Disconnected from Oracle9i Enterprise Edition Release 9.2.0.5.0 - Production

    With the Partitioning, OLAP and Oracle Data Mining options

    JServer Release 9.2.0.5.0 - Production

    ADX-1101 : Rapid Install characterset conversion failed

    Error found while running addbccnv.sql

    Cannot convert database characterset

    STARTED INSTALL PHASE : DATABASE : Tue Jan 1 00:52:58 IST 2002

    Preparing environment to install databases ...

    Setting LD_LIBRARY_PATH to - /u01/eds/stage/EBS_11i-11.5.10_For_Linux_32-bit/startCD/Disk1/rapidwiz/lib/Linux -

    Setting PATH to - /u01/eds/stage/EBS_11i-11.5.10_For_Linux_32-bit/startCD/Disk1/rapidwiz/jre/Linux/1.4.2//lib/rt.jar:/u01/eds/stage/EBS_11i-

    11.5.10_For_Linux_
    32-bit/startCD/Disk1/rapidwiz/jre/Linux/1.4.2//lib/i18n.jar:/u01/eds/stage/EBS_11i-11.5.10_For_Linux_32-

    bit/startCD/Disk1/rapidwiz/jlib/java:/u01/eds/stage/EB
    S_11i-11.5.10_For_Linux_32-bit/startCD/Disk1/rapidwiz/jlib/xmlparserv2.zip -

    Setting CLASSPATH to - /u01/eds/stage/EBS_11i-11.5.10_For_Linux_32-bit/startCD/Disk1/rapidwiz/jre/Linux/1.4.2//lib/rt.jar:/u01/eds/stage/EBS_11i-

    11.5.10_For_L
    inux_32-bit/startCD/Disk1/rapidwiz/jre/Linux/1.4.2//lib/i18n.jar:/u01/eds/stage/EBS_11i-11.5.10_For_Linux_32-

    bit/startCD/Disk1/rapidwiz/jlib/java:/u01/eds/sta
    ge/EBS_11i-11.5.10_For_Linux_32-bit/startCD/Disk1/rapidwiz/jlib/xmlparserv2.zip -

    ... installing a fresh install database



    runProcess_6

    Statusstring Performing database characterset conversion



    adsvdcnv.sh started at Tue Jan 1 00:52:58 IST 2002





    The environment settings are as follows ...



    ORACLE_HOME : /u01/prd1/prd1db/9.2.0

    ORACLE_SID : PRD1

    TWO_TASK :

    PATH :

    /u01/prd1/prd1db/9.2.0/Apache/perl/bin:/u01/prd1/prd1db/9.2.0/bin:/usr/bin:/usr/sbin:/u01/prd1/prd1db/9.2.0/jre/1.4.2/bin:/usr/ccs/bin:/b
    in:/usr/bin/X11:/usr/local/bin:/usr/bin:/usr/bin:/u01/eds/stage/EBS_11i-11.5.10_For_Linux_32-

    bit/startCD/Disk1/rapidwiz/unzip/Linux:/usr/bin:/usr/local/bin:/u
    sr/lib/qt-3.3/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin

    LD_LIBRARY_PATH : /u01/prd1/prd1db/9.2.0/lib:/usr/X11R6/lib:/usr/openwin/lib:/u01/prd1/prd1db/9.2.0/ctx/lib



    Executable : /u01/prd1/prd1db/9.2.0/bin/sqlplus





    SQL*Plus: Release 9.2.0.5.0 - Production on Tue Jan 1 00:52:58 2002



    Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.



    ERROR:

    ORA-01035: ORACLE only available to users with RESTRICTED SESSION privilege
    *========================================================================================================================================*

    Note : Database and database listener got started... Please let me know how to fix this...
    # ps -ef|grep -i pmon
    oraprd1 23652 1 0 00:48 ? 00:00:00 ora_pmon_PRD1

    # ps -ef|grep -i tns
    oraprd1 23239 1 0 00:45 ? 00:00:00 /u01/prd1/prd1db/9.2.0/bin/tnslsnr PRD1 -inherit

    Thanks.
  • 12. Re: RW-50011:Error: -System Utilities Availability test has returned an error:1
    Hussein Sawwan-Oracle Employee ACE
    Currently Being Moderated
    ERROR at line 1:

    ORA-12712: new character set must be a superset of old character set

    ORA-06512: at line 16
    Did you chose any characterset when you ran the installer?

    OERR: ORA-12712 new character set must be a superset of old character set [ID 71968.1]
    Changing the NLS_CHARACTERSET From AL32UTF8 / UTF8 (Unicode) to another NLS_CHARACTERSET [ID 1283764.1]
    Database Character Set Healthcheck [ID 225938.1]
    Running Instantiation Drivers for /u01/eds/stage/EBS_11i-11.5.10_For_Linux_32-bit/startCD/Disk1/rapidwiz/template/adridb.drv
    Please avoid using names like "EBS_11i-11.5.10_For_Linux_32-bit" for the directory name.

    Thanks,
    Hussein
  • 13. Re: RW-50011:Error: -System Utilities Availability test has returned an error:1
    user11952526 Newbie
    Currently Being Moderated
    Hi Hussein,

    I am taking the default character set as...

    Database character set : US7ASCII
    APPL_TOP character set : US7ASCII
    IANA character set : US7ASCII

    Do I need to change the default character set, if so which one should I take ???

    Note : As advised, I have changed the stage path and now it is */u01/stage/EBS-11i/*

    Thanks.
  • 14. Re: RW-50011:Error: -System Utilities Availability test has returned an error:1
    Hussein Sawwan-Oracle Employee ACE
    Currently Being Moderated
    I am taking the default character set as...

    Database character set : US7ASCII
    APPL_TOP character set : US7ASCII
    IANA character set : US7ASCII

    Do I need to change the default character set, if so which one should I take ???
    It depends on what languages you are planning to install -- Please see the following docs for details.

    AL32UTF8 / UTF8 (Unicode) Database Character Set Implications [ID 788156.1]
    Which Character Set Supports Which Language [ID 62421.1]
    Oracle Applications 11i Internationalization Guide [ID 333785.1]
    Note : As advised, I have changed the stage path and now it is */u01/stage/EBS-11i/*
    I would avoid using hyphen -- Use /u01/stage11i or /u01/stage/EBS11i instead.

    Thanks,
    Hussein
1 2 3 Previous Next

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points