This discussion is archived
4 Replies Latest reply: Apr 10, 2013 5:46 PM by orafad RSS

Our Java application is built with java 1.4 version and oracle 10g

1001964 Newbie
Currently Being Moderated
Our Java application is built with java 1.4 version and oracle 10g version database, is it possible to upgrade oracle database to 11g?
  • 1. Re: Our Java application is built with java 1.4 version and oracle 10g
    clcarter Expert
    Currently Being Moderated
    is it possible to upgrade
    Yes. SE and the other editions have a migration/upgrade utility, not seeing any mention of that program in the XE license docs. To upgrade to 11gR2 from 10g, the 10g instance must be at patch 10.2.0.2 or higher.

    So if you're a GUI dba, might be out of luck. But the the XE install has the catalog upgrade scripts that need to be run, there is a MOS note explaining the manual upgrade steps.

    Or set up a brand new 11g database instance and datapump your user schema(s) from the 10g instance to the new 11g instance. The database doesn't care what java version you're using, it just does what its told with the data. DDL, DCL, DML ... its not much different. Quite a few new features in 11g.

    But if you're after JVMs that piece is not supported with XE.
  • 2. Re: Our Java application is built with java 1.4 version and oracle 10g
    1001964 Newbie
    Currently Being Moderated
    Hi, Thanks for the reply, you are correct but I am not able to find the ojdbc6.jar file for JAVA 1.4 version for our JDBC connection?

    Thanks for the assistance with this
  • 3. Re: Our Java application is built with java 1.4 version and oracle 10g
    Udo Guru
    Currently Being Moderated
    Hi,
    I am not able to find the ojdbc6.jar file for JAVA 1.4 version for our JDBC connection?
    That's the caveeat: There are no Java 2 (1.4) drivers for Oracle 11g any more. Java 2 fell out of support a long time ago. If you intend to update your target database, I'd also recommend to update to a recent Java release.
    BTW: ojdbc6.jar will always be for Java 6. The oldest release currently available would be ojdbc5.jar for Java 1.5.

    -Udo
  • 4. Re: Our Java application is built with java 1.4 version and oracle 10g
    orafad Oracle ACE
    Currently Being Moderated
    Did you see the Jdbc faq? http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-faq-090281.html#02_03


    Driver and JDK versions compatibility is stated, and also as said with 11.x the ancient Java stuff was dropped.

    >
    10.2.0 OCI and THIN Driver - JDK 1.2.x, JDK 1.3.x, JDK 1.4.x, and JDK 5.0.x
    11.1.0 OCI and THIN Driver - JDK 1.5.x and JDK 1.6.x
    11.2.0 OCI and THIN Driver - JDK 1.5.x and JDK 1.6.x

    Please note that JDK 1.4 is not supported by the 11 drivers.
    >


    JDBC drivers, from e.g. 10.2.0.5, are available for download via the OTN Downloads index -
    http://www.oracle.com/technetwork/indexes/downloads/index.html


    Hth,

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points