5 Replies Latest reply on Apr 9, 2013 9:26 PM by user12019587

    How can I use custom WLST commands for Oracle SOA Suite in Weblogic

      Hi There,

      I'm trying to view and search the weblogic log files using WLST on a Solaris/Unix system.
      I have come across this "custom WLST commands for Oracle SOA Suite" and thought of using the custom logging commands to get my task done.

      However, my WLST shell is not recognizing the commands and giving me the NameError!

      wls:/devDomain1/domainRuntime> listLogs()
      Traceback (innermost last):
      File "<console>", line 1, in ?
      NameError: listLogs

      I tried the commands listLogs, displayLogs, getLogLevel & setLogLevel but in vain!

      I have followed the instructions as per the oracle recommendation of using Custom WLST commands (http://docs.oracle.com/cd/E29597_01/core.1111/e10105/getstart.htm#ASADM10692) as below

      - Launched the WLST shell from Oracle Home.

      cd ORACLE_HOME/common/bin

      - Tried to run the listLogs command from domainRuntime()

      I would like to know if I need to import any additional libraries to run the custom WLST commands for Oracle SOA Suite in my WLST shell?
      I have only weblogic 10.3.1 server installed on my Solaris 10 machine on which I have deployed the OSB application software.
      There is no SOA Suite installed.

      Or is there any other way I can browse the Server Log file and get the list of log messages? Basically I would like to use this feature in my script to customize it according to my requirement of listing specific error logs which I can work it out if I know how to make these commands work.

      Please advise if this is possible and how?

        • 1. Re: How can I use custom WLST commands for Oracle SOA Suite in Weblogic
          Pierluigi Vernetto
          there are several "wlst.sh" around, each with a different classpath... my guess is that you should try using the one provided with SOA Suite... I haven't tested your custom commands however...
          1 person found this helpful
          • 2. Re: How can I use custom WLST commands for Oracle SOA Suite in Weblogic
            Thanks for the reply Pierluigi,
            I don't have SOA Suite installed on my machine. My organization doesn't required entire SOA suite but just the OSB application in the suite installed on Weblogic Server.
            I'm just wondering if there is any way I can download just the additional wlst capabilities of SOA suite and use them.
            Are the libraries used by wlst in SOA Suite available for download?


            Edited by: apsnaidu on Mar 9, 2013 7:22 PM
            • 3. Re: How can I use custom WLST commands for Oracle SOA Suite in Weblogic
              Pierluigi Vernetto
              I have tried on my OSB installation (no SOA Suite here), the command listLogs() works (I was in online mode, after a connect), and the classpath is:


              The wlst.sh I have used is /opt/oracle/fmw11_1_1_5/osb/common/bin/wlst.sh

              I hope this can help
              • 4. Re: How can I use custom WLST commands for Oracle SOA Suite in Weblogic
                Thanks for that Pierluigi,

                I have checked my classpath and all those jar files under ..../oracle_common/common/wlst/.... are not present!

                This is how my WLST Classpath looks like.


                Does your wlst folder (..../oracle_common/common/wlst/....) came as part of your osb installation or oracle installation itself?

                I have installed the oracle product in a separate path than that of osb & weblogic.

                WL Installation path: /opt/osb_prod/osb1031/wlserver_10.3
                OSB Installation path: /opt/osb_prod/osb1031/osb_10.3
                Oracle Installation path: /opt/oracle/product/10.2.0/client_1

                Looks like the required wlst libraries are missing from my classpath but I don't know from where to get them. A version upgrade? All the other wlst functions are working fine though.

                • 5. Re: How can I use custom WLST commands for Oracle SOA Suite in Weblogic
                  I had the same issues and I found this note 1284015.1

                  This error show up if WLST command is executed from an incorrect location. For example:

                  you need to make sure that you launch the WLST command from IDM Home. For example, use the one under <Middleware>\Oracle_IDM1\common\bin
                  ( on my Windows installation it's D:\Oracle\Middleware\oracle_common\common\bin)

                  I have a problem to redirect the output of displayLogs command to text file. I have tried redirect but how doesn't work

                  Is anybody know how to send the output of this command to the text file?