3 Replies Latest reply: Apr 10, 2013 11:00 AM by Avinash P RSS

    Error occurred when saving user preferences

    Avinash P
      Hi,

      we Copy catalog and RPD to production Environment. when i am try to change the my account(Weblogic) setting getting bellow error.

      Exception occurred when saving user preferences to the catalog access denied for user to path /users/weblogic/_prefs/userprefsxmlstore.

      I need to change any catalog permission? in Dev it is working fine.

      Thx,
        • 1. Re: Error occurred when saving user preferences
          Srini VEERAVALLI
          1 Open the online web catalog in offline mode.
          2. Navigate to /users/weblogic/_prefs/ folder,Right click and select permissions.
          3. From the drop-down list select users and click on the List button.
          4. Now, you can see all the users with access to this folder.
          5. Grant your user FULL CONTROL on this folder and apply recursively to all files under this folder (click on Apply Recursively check box).
          6. Restart The OBIEE Presentation Server.

          ref: http://www.cool-bi.com/Issues/CatalogPermissions.php
          If helps mark as correct

          Edited by: Srini VEERAVALLI on Apr 10, 2013 9:31 AM
          • 2. Re: Error occurred when saving user preferences
            Avinash P
            weblogic user can't displayed in my users list.

            But I am able to login em,console,analytics through weblogic user only...
            • 3. Re: Error occurred when saving user preferences
              Srini VEERAVALLI
              Exception occurred when saving user preferences to the catalog access denied for user to path /users/weblogic/_prefs/userprefsxmlstore
              This is weird !! how come error message with user folder?

              Then the issue is with copy!
              Make sure webcat folder number files/folders are matching with source webcat after copying into prod.


              Thanks

              Edited by: Srini VEERAVALLI on Apr 10, 2013 11:03 AM