This discussion is archived
1 Reply Latest reply: Apr 11, 2013 10:58 PM by 1002667 RSS

sql developer 한글 문제?

573092 Newbie
Currently Being Moderated
DB의 NLS setting은 다음과 같습니다.

=====================================================
NLS_LANGUAGE     KOREAN
NLS_TERRITORY     KOREA
NLS_CURRENCY     $
NLS_ISO_CURRENCY     AMERICA
NLS_NUMERIC_CHARACTERS     .,
NLS_CALENDAR     GREGORIAN
NLS_DATE_FORMAT     DD-MON-RR
NLS_DATE_LANGUAGE     KOREAN
NLS_CHARACTERSET     US7ASCII
NLS_SORT     BINARY
NLS_TIME_FORMAT     HH24:MI:SSXFF
NLS_TIMESTAMP_FORMAT     DD-MON-RR HH.MI.SSXFF AM
NLS_TIME_TZ_FORMAT     HH24:MI:SSXFF TZR
NLS_TIMESTAMP_TZ_FORMAT     DD-MON-RR HH.MI.SSXFF AM TZR
NLS_DUAL_CURRENCY     ?
NLS_NCHAR_CHARACTERSET     AL16UTF16
NLS_COMP     BINARY
NLS_LENGTH_SEMANTICS     BYTE
NLS_NCHAR_CONV_EXCP     FALSE
=====================================================

sql developer에서 query를 실행시키면 한글이 다음과 같이 깨지네요!
=====================================================
AAA-ㅁㅁㅁㅁㅁㅁㅁㅁㅁㅁㅁㅁㅁㅁㅁㅁㅁ
=====================================================

sql developer 환경 설정의 NSL Parameters는 서버랑 맞는거 같고...
인코딩은 바꾸어봐도 아무 효과가 없네요!

무슨 방법이 있을 까요?
  • 1. Re: sql developer 한글 문제?
    1002667 Newbie
    Currently Being Moderated
    한글을 지원하는 폰트가 안깔려서 그런거 같아요.

    저도 동일한 증상이 있었는데

    fonts-ttf-seoul-fonts-1.0-0pclos2007.noarch.rpm ( http://www.no1linux.com/?module=file&act=procFileDownload&file_srl=2135&sid=f6c6b4f51dccb0b935decb784f643ea8 )
    다운받으시고
    rpm -ivh fonts-ttf-seoul-fonts-1.0-0pclos2007.noarch.rpm 실행하면

    /usr/share/fonts/Seoul
    디렉토리에 설치가 될겁니다.

    거기서
    su -c 'fc-cache -fv' 명령어로 적용시키고

    sql Developer 를 실행한 다음 Too->Preferences->Code Editor -> Fonts 에서 폰트를 Seoul Namsan 으로 설정하니까
    한글이 안깨지고 잘 나왔습니다.