3 Replies Latest reply on Nov 12, 2007 9:05 AM by 337537

    ORA-12535: TNS:operation timed out

      I keep getting this TNS:operation timed out error when trying to run commands against our VMWare RAC setup. Sometimes commands will suceed, othertimes they will timeout. Repeated Test Service in Net Manager is enough to cause this problem. By about the 5th test, it will timeout. The 6th may or may not succeed, then it will work for several tests in a row before timing out again.

      This happens when connecting to either Instance 1 (port 1521) or Instance 2 (port 1522). Both are setup to use Service Name O10G.

      I used the RHEL3-DVD-Oracle-v1.4.zip and RHEL3-DVD2-Linux-v1.4.zip. It is running with the standard setup, I used the Oracle installer to install VMware 4.5. I've given it 1.5GB of RAM, the host machine has 2GB of RAM with a P4 2Ghz processor and Windows XP. I've mapped ports 1521 and 1522 through the VMWare NAT configuration and am using a second machine with the Oracle 9 client.

      If I shut down one of the instances and connect only to the other one, then things do not timeout.

      Running very simple Oracle scripts (create procedure, create function, create table, etc) will cause the connection to timeout and subsequent commands to fail.
        • 1. Re: ORA-12535: TNS:operation timed out
          The Oracle 10 client has approximately the same problem, but produces a different error number/message:

          ORA-12170: TNS:Connect timeout occurred
          • 2. Re: ORA-12535: TNS:operation timed out
            We fixed this problem, it was due to the listener redirecting the client to a different listener by name, not by IP. The subsequent DNS lookup was failing on the client OR the lookup would suceed and point to an IP that the client couldn't connect to. This causes all sorts of wierd, intermittant problems that only happen when the listener decides to redirect the client.

            Once we figured out what the listener was sending out for the redirect to the other listener and got all the DNS and IP issues worked out, our RAC setup worked fine. We had the same issue on a non VM RAC as well.
            • 3. Re: ORA-12535: TNS:operation timed out
              Hi Saturn,

              I'm faced the same problem, kindly provide details guidelines on how you resolved this.

              Many thanks...