1 Reply Latest reply: Apr 23, 2013 6:21 AM by Vijaya Moderator -Oracle RSS

    Using apllication jars before weblogic ones


      we have an old j2ee application based on ADF (version 10.1.3)/TopLink
      and need to deploy it on WebLogic (10.3.6). After many trials and errors we
      were successfull, but this action was needed - removing library
      com.oracle.toplink_1.1.0.0_11-1-1-6-0.jar from weblogic. We were not able
      to make our apllication's library toplink.jar (in WEB-INF\lib) be used first.

      We tried to modify weblogic.xml on Weblogic server


      , tried to deploy our apllication via ear instead of war with

      <?xml version="1.0" encoding="UTF-8"?>
      <weblogic-application xmlns="http://www.bea.com/ns/weblogic/90">

      But application still reports

      java.lang.VerifyError: (class: oracle/toplink/tools/sessionmanagement/SessionManager, method: getWASSession signature: (Loracle/toplink/tools/sessionconfiguration/WASXMLSessionConfigLoader;Ljava/lang/ClassLoader;)Loracle/toplink/publicinterface/Session;) Wrong return type in fu...

      which means, that still WebLogic version of toplink library is used before application one...

      Do you have any other idea, what we must to do ? Thanks
        • 1. Re: Using apllication jars before weblogic ones
          Vijaya Moderator -Oracle

          What you've tried doing is inducing a filtering classloader..

          Have you ensured to add the dependency toplink library in the APP-INF/lib directory ?

          As you have set the filtering classloader in the weblogic-application.xml file

          If you've set filtering classloader in weblogic.xml, you need to add the dependency library under web-inf/lib directory.

          Hope this helps!!

          Also share the complete stacktrace of the error if the issue still persists...