4 Replies Latest reply on Apr 17, 2013 4:39 PM by 990261

    Solaris 8 boot block

      I have a Solaris 8 machine that was having a hard drive issue. I shut the system down and then it will not boot.

      I booted off a CD and ran fsck /dev/rdsk/c0t0d0s0 and it came back with a superblock error and I typed yes to fix it. I then tried to boot again and it still would not boot.

      I then tried to reinstall the boot block but that did not seem to help. # installboot /usr/platform/`uname -i`/lib/fs/ufs/bootblk /dev/rdsk/c0t0d0s0

      Where is the boot block suppose to go? Does it always go on slice 0 of the boot drive or does it go where the root partition is located. The root partition is actually on slice 4 c0t0d0s4.

      # df -k | grep dev
      /dev/dsk/c0t0d0s4 8256660 3799018 4375076 47% /

      I have been fighting this issue all day. I am almost to the point of restoring the whole system. Thanks in advance.
        • 1. Re: Solaris 8 boot block
          Is the eeprom of the system setup to boot off slice 4? If so, then the boot block needs to be installed on slice 4. Whatever slice the eeprom is configured to boot from is the slice that requires the bootblock...
          1 person found this helpful
          • 2. Re: Solaris 8 boot block
            When I do a printenv boot-device I get boot device = disk:b. What does disk:b refer to? I have tried to do a boot disk0 but that did not work. Is there a way to tell it what slice to boot off of on disk0? Thanks.
            • 3. Re: Solaris 8 boot block
              987258 wrote:
              When I do a printenv boot-device I get boot device = disk:b. What does disk:b refer to?
              You system is set to boot from Slice #1 of whatever your system's hardware defaults to for the first disk location.

              If you were seeing "disk:a" then it would refer to the zero slice of the drive (S0).
              If you saw "disk:c" then it would boot from the third slice (S3).

              Perhaps the following two old OBP reference manuals can be of help.
              Save them as bookmarks in your browser.

              OBP 3.x Command Reference Manual
              OBP 4.x Command Reference Manual
              • 4. Re: Solaris 8 boot block
                That helped clear up things. I still am not able to get the system to boot so I am restoring the drive contents from a backup. I am restoring the root partition to slice #0 this time. I am not sure why it was on on slice #4 before. I specialize more with Windows systems so this is definitely a learning experience. Our current UNIX admin of 25+ years is out on medical leave.