4 Replies Latest reply: Apr 17, 2013 4:15 PM by user11391721 RSS

    Discovering Local Drives in 3.2.2 OVM

    Mike Crow-Oracle
      Hi,
      I've seen a number of questions on accessing local drives, but haven't found anything that addresses the trouble I'm having.

      I'm Installing 3.2.2
      My System has LSI MegaRAID controller. It has 2 mirrored drives, configured as 2 Virtual Disks. 1 disk has 322 installed. 1 disk is unpartitioned. I have OVM Mgr installed on a second system

      Everything seems to be installed, I can discover the VM server from the manager.
      Nothing is listed in any of the storage tabs. But I can detect my empty drive in the repository tab, while creating a repository. I can’t complete the repository creation because I don’t have a server pool created. I can’t create a server pool because there are no repositories, nor does it detect the physical disk from the server pool creation window.

      I’ve checked the VM server and the empty drive is not blacklisted, and it seems to have the bit’s it needs (it’s listed in /dev/mapper).

      I don’t have a SAN or a Network storage system, and intend to use drives installed in the server itself.

      I can add my server the unmanaged iSCSI storage arry under SAN Servers, but can't find my disk there.

      So where am I going wrong?
        • 1. Re: Discovering Local Drives in 3.2.2 OVM
          BjornNaessens
          Hi,

          Since 3.0.3 local drives are no longer possible as a repository. You need a San or File Server. If this is a test environment, I would recommend to export your disks via Nfs and access it as a fileserver.

          Hope it helps
          B.
          • 2. Re: Discovering Local Drives in 3.2.2 OVM
            user11391721
            On 3.2.1 I have local repositories using full local un-partitioned disks.

            On our first physical dev ovm host, I did a single server this way with a dedicated small ssd boot drive and did the first repository on a dedicated single hard disk (neither were mirrored). I then later added a larger internal SSD as a repository for DB VMs & then lastly added an external USB 3.0 HDD to backup up VMs to (since all my disks in my dev machine were not mirrored).

            On our PoC 3.2.1 HA cluster I used a shared ZFS filesystem over a storage network to host NFS repositories (1GB NICs on OVM hosts & bonded GB NICs on NFS/ZFS server). Performance was OK for the mid-tier VMs but the DB performance was lacking so I put local SSDs for them (not HA for that DB VMs but super high performance)...

            Not sure what is wrong with your config as I assume 3.2.2 still supports local storage like 3.2.1 does...

            If you do the setups correctly and it doesn't work I suspect it may be the way your storage card is presenting the local storage as separate "virtual disks" that aren't emulating a real UN-paritioned disk properly...

            Edit: Try going through the tutorial on setting up the disk and the Server Pool step by step. You should be able to get to in the upper right hand corner by clicking "help > getting started". I would start with the following URL on your OVM Manager server and read all the steps. It has been awhile since I setup a local repository & I remember it being a little counter-intuitive (especially the first time). On 3.2.1, if you search on the word "local" you should get 22+ hits (some are not helpful)... I would go though them all starting with the first two hits.

            These links may not work for you but in my OVM Manager they are as follows:

            Using Local Storage:

            https://localhost:7002/ovm/help/faces/helppages/config.help/locale.en/topics/navSetId._/ovmhelp/vmusg-storage-local-use.html

            Local Storage:

            https://localhost:7002/ovm/help/faces/helppages/main.jspx?_afrLoop=1263383948527688&config=help&vtTopicFile=ovmhelp%2Fvmusg-storage-local.html&_afrWindowMode=0&locale=en&_adf.ctrl-state=aq7ybph84_24

            Managing Storage Repositories:

            https://localhost:7002/ovm/help/faces/helppages/main.jspx?_afrLoop=1263525952060023&config=help&vtTopicFile=ovmhelp%2Fvmusg-repo-manage.html&_afrWindowMode=0&locale=en&_adf.ctrl-state=aq7ybph84_29

            Edited by: user11391721 on Apr 17, 2013 12:27 PM: Added search parameter and the URLs that I would start with...
            • 3. Re: Discovering Local Drives in 3.2.2 OVM
              Mike Crow-Oracle
              I figured it out, I had the Clustered Server check box selected.
              Once I unselected that, the storage requirement for creating the Server Pool was removed.
              My pool is created, and the repository is getting created now.

              Thanks for all of the help!
              • 4. Re: Discovering Local Drives in 3.2.2 OVM
                user11391721
                Very cool !

                I think that making sure that HA/cluster box was unchecked for local storage was on the links I sent.

                I remember seeing it when reviewing them to send to you...

                Glad that Oracle is including some decent tutorial documentation with the product and cool that it is all local when you install.