This discussion is archived
2 Replies Latest reply: Apr 18, 2013 12:08 PM by 1003974 RSS

ORE installation on a mac - ROracle will not load

1003974 Newbie
Currently Being Moderated
Hi,

I'm having problems installing the ORE client on my Mac. After running through the installation procedure this is what I get:
library(ORE)
Loading required package: OREbase

Attaching package: ‘OREbase’

The following object(s) are masked from ‘package:base’:

cbind, data.frame, eval, interaction, order, paste, pmax, pmin,
rbind, table

Loading required package: OREstats
Loading required package: MASS
Loading required package: OREgraphics
Loading required package: OREeda
Loading required package: OREdm
Loading required package: lattice
Error in library.dynam(lib, package, package.lib) :
shared object ‘ROracle.so’ not found
Error: package ‘OREdm’ could not be loaded
>
library(ROracle)
Error: package ‘ROracle’ is not installed for 'arch=x86_64'

I have followed the Linux installation guide for ORE cllient on a MBP running MacOSX 10.7.4.

http://docs.oracle.com/cd/E27988_01/doc/doc.112/e26499/install.htm#autoId14

Taking consideration of remarks on:

http://cran.r-project.org/web/packages/ROracle/INSTALL

I'm using following packages:

ore-supporting-linux-x86-64-1.3.1.zip
ore-client-linux-x86-64-1.3.1 (1).zip
instantclient-basic-linux.x64-11.2.0.3.0.zip

Set LD_LIBRARY_PATH to point to the instantclient libs as well as ROracle.so. I am suspecting that I may have to compile ROracle.so from scratch and may not be able to use the Linux binaries here.

Any help appreciated.

Vincent

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points