8 Replies Latest reply: Apr 21, 2013 11:00 AM by 639800 RSS

    11.1.1.7 Installation issue - Installation stops at Presenation server star

    639800
      I have installed the loopback adapter and also ensured that there are blocking firewall rules.

      Still when the installer comes the the step at the end where it starts the Presentation server, it fails with the following error:

      Any ideas?

      Thanks!

      [2013-04-18T13:21:39.000-05:00] [OBIPS] [ERROR:10] [] [saw.security.odbcuserpopulationimpl.initialize] [ecid: ] [tid: ] Odbc driver returned an error (SQLDriverConnectW).
      State: IM002. Code: 10040. [NQODBC] [SQL_STATE: IM002] [nQSError: 10040] The requested data source name is either not found, incomplete, or incorrect. (IM002)[[
      File:odbcuserpoploaderimpl.cpp
      Line:329
      Location:
           saw.security.odbcuserpopulationimpl.initialize
           saw.catalog.local.loadCatalog
           saw.subsystems.catalogbootstrapper.loadcatalog
           saw.webextensionbase.init
           saw.sawserver
           saw.sawserver.initializesawserver
           saw.sawserver
      ecid:
      ]]
      [2013-04-18T13:21:39.000-05:00] [OBIPS] [ERROR:16] [] [saw.security.odbcuserpopulationimpl.initialize] [ecid: ] [tid: ] Unable to create a system user connection to BI Server during start up. Trying again.[[
      File:odbcuserpoploaderimpl.cpp
      Line:330
      Location:
           saw.security.odbcuserpopulationimpl.initialize
           saw.catalog.local.loadCatalog
           saw.subsystems.catalogbootstrapper.loadcatalog
           saw.webextensionbase.init
           saw.sawserver
           saw.sawserver.initializesawserver
           saw.sawserver
      ecid:
      ]]
      [2013-04-18T13:21:44.000-05:00] [OBIPS] [ERROR:31] [] [saw.security.odbcuserpopulationimpl.initialize] [ecid: ] [tid: ] Could not create a system user connection to Oracle BI Server during start-up. Please check the error message and try again.[[
      File:odbcuserpoploaderimpl.cpp
      Line:347
      Location:
           saw.security.odbcuserpopulationimpl.initialize
           saw.catalog.local.loadCatalog
           saw.subsystems.catalogbootstrapper.loadcatalog
           saw.webextensionbase.init
           saw.sawserver
           saw.sawserver.initializesawserver
           saw.sawserver
      ecid:
      ]]
      [2013-04-18T13:21:44.000-05:00] [OBIPS] [NOTIFICATION:1] [] [saw.sawserver] [ecid: ] [tid: ] Oracle BI Presentation Services are shutting down.[[
      File:sawserver.cpp
      Line:713
      Location:
           saw.sawserver
           saw.sawserver.terminatesawserver
           saw.sawserver
      ecid:
      ]]
        • 1. Re: 11.1.1.7 Installation issue - Installation stops at Presenation server star
          user12210196
          The system user was not created to login to the BI server.

          Looks like the MW schema is not accessible due to the server not able to query the database. Make sure you have the required database clients/configuration files configured correctly in your machine.
          • 2. Re: 11.1.1.7 Installation issue - Installation stops at Presenation server star
            639800
            When u say MW Schema, are you referring to the BIPLATFORM/MDS schemas that are created using the RDU?

            I have confirmed that the 2 schemas are not locked and are accessible using the userid/password mentioned during install.

            Any other pointers?

            -SJ

            Edited by: Jainnys on Apr 18, 2013 3:00 PM
            • 3. Re: 11.1.1.7 Installation issue - Installation stops at Presenation server star
              Srini VEERAVALLI
              Check this
              How Should etc/hosts File be Configured Before OBIEE 11g Installation (Doc ID 1323461.1)
              • 4. Re: 11.1.1.7 Installation issue - Installation stops at Presenation server star
                639800
                I did that and now I have an entry to this effect in the host file.

                192.168.1.4 <machine-name>

                I have a couple of issues with this. The machine is a Windows 7 laptop which I travel with, This means that the IP address can change depending on the network I am connected to. I thought we used the Loopback adapter to avoid this.

                Anyway after this here is the log - still not able to start The Presentation server.

                Any pointers?

                [2013-04-18T19:14:10.000-05:00] [OBIPS] [NOTIFICATION:1] [] [saw.sawserver] [ecid: ] [tid: ] Oracle BI Presentation Services (OBIPS) 11.1.1.7.0 (Build 130303.2025 32-bit) are starting up.[[
                File:sawserver.cpp
                Line:455
                Location:
                     saw.sawserver
                     saw.sawserver.initializesawserver
                     saw.sawserver
                ecid:
                ]]
                [2013-04-18T19:14:10.000-05:00] [OBIPS] [WARNING:16] [] [saw.mas.csf] [ecid: ] [tid: ] Database security store is not available, do not re-associate to this provider type.[[
                File:csfwrapperimpl.cpp
                Line:152
                Location:
                     saw.mas.csf
                     saw.sawserver
                     saw.sawserver.initializesawserver
                     saw.sawserver
                ecid:
                ]]
                [2013-04-18T19:14:10.000-05:00] [OBIPS] [NOTIFICATION:1] [] [saw.sawserver] [ecid: ] [tid: ] Security query timeout sec is: 120[[
                File:odbcuserpoploaderimpl.cpp
                Line:1068
                Location:
                     saw.sawserver
                     saw.sawserver.initializesawserver
                     saw.sawserver
                ecid:
                ]]
                [2013-04-18T19:14:10.000-05:00] [OBIPS] [WARNING:1] [] [saw.webextensionbase.init.workstationCheck] [ecid: ] [tid: ] WARNING: The Oracle BI Presentation Services server is running on a workstation class machine (Windows XP Professional, Windows 7 Professional etc.). The number of concurrent users may be severely limited by the operating system.[[
                File:webextensionbase.cpp
                Line:492
                Location:
                     saw.webextensionbase.init.workstationCheck
                     saw.webextensionbase.init
                     saw.sawserver
                     saw.sawserver.initializesawserver
                     saw.sawserver
                ecid:
                ]]
                [2013-04-18T19:14:11.000-05:00] [OBIPS] [ERROR:10] [] [saw.security.odbcuserpopulationimpl.initialize] [ecid: ] [tid: ] Odbc driver returned an error (SQLDriverConnectW).
                State: IM002. Code: 10040. [NQODBC] [SQL_STATE: IM002] [nQSError: 10040] The requested data source name is either not found, incomplete, or incorrect. (IM002)[[
                File:odbcuserpoploaderimpl.cpp
                Line:329
                Location:
                     saw.security.odbcuserpopulationimpl.initialize
                     saw.catalog.local.loadCatalog
                     saw.subsystems.catalogbootstrapper.loadcatalog
                     saw.webextensionbase.init
                     saw.sawserver
                     saw.sawserver.initializesawserver
                     saw.sawserver
                ecid:
                ]]
                [2013-04-18T19:14:11.000-05:00] [OBIPS] [ERROR:16] [] [saw.security.odbcuserpopulationimpl.initialize] [ecid: ] [tid: ] Unable to create a system user connection to BI Server during start up. Trying again.[[
                File:odbcuserpoploaderimpl.cpp
                Line:330
                Location:
                     saw.security.odbcuserpopulationimpl.initialize
                     saw.catalog.local.loadCatalog
                     saw.subsystems.catalogbootstrapper.loadcatalog
                     saw.webextensionbase.init
                     saw.sawserver
                     saw.sawserver.initializesawserver
                     saw.sawserver
                ecid:
                ]]
                [2013-04-18T19:14:16.000-05:00] [OBIPS] [ERROR:10] [] [saw.security.odbcuserpopulationimpl.initialize] [ecid: ] [tid: ] Odbc driver returned an error (SQLDriverConnectW).
                State: IM002. Code: 10040. [NQODBC] [SQL_STATE: IM002] [nQSError: 10040] The requested data source name is either not found, incomplete, or incorrect. (IM002)[[
                File:odbcuserpoploaderimpl.cpp
                Line:329
                Location:
                     saw.security.odbcuserpopulationimpl.initialize
                     saw.catalog.local.loadCatalog
                     saw.subsystems.catalogbootstrapper.loadcatalog
                     saw.webextensionbase.init
                     saw.sawserver
                     saw.sawserver.initializesawserver
                     saw.sawserver
                ecid:
                ]]
                [2013-04-18T19:14:16.000-05:00] [OBIPS] [ERROR:16] [] [saw.security.odbcuserpopulationimpl.initialize] [ecid: ] [tid: ] Unable to create a system user connection to BI Server during start up. Trying again.[[
                File:odbcuserpoploaderimpl.cpp
                Line:330
                Location:
                     saw.security.odbcuserpopulationimpl.initialize
                     saw.catalog.local.loadCatalog
                     saw.subsystems.catalogbootstrapper.loadcatalog
                     saw.webextensionbase.init
                     saw.sawserver
                     saw.sawserver.initializesawserver
                     saw.sawserver
                ecid:
                ]]

                <<<<<<<<<<<<repeats>>>>>>>>>>>>>>


                [2013-04-18T19:15:51.000-05:00] [OBIPS] [NOTIFICATION:1] [] [saw.sawserver] [ecid: ] [tid: ] Oracle BI Presentation Services are shutting down.[[
                File:sawserver.cpp
                Line:713
                Location:
                     saw.sawserver
                     saw.sawserver.terminatesawserver
                     saw.sawserver
                ecid:
                ]]

                Edited by: Jainnys on Apr 18, 2013 7:27 PM
                • 5. Re: 11.1.1.7 Installation issue - Installation stops at Presenation server star
                  639800
                  I turned off the firewall on the laptop, still it is the same issue...

                  This time I am getting a new error:

                  [2013-04-18T20:52:25.000-05:00] [OBIPS] [ERROR:31] [] [saw.rpc.client.impl.verify] [ecid: 00iEKCvlERMFg4WFLzmJOA0001No000002,0] [tid: 1596] An error occurred during connect to "192.168.1.7:9810". No connection could be made because the target machine actively refused it.
                  [Socket:1088][[
                  File:socket.cpp
                  Line:923
                  Location:
                       saw.rpc.client.impl.verify
                       saw.rpc.client.impl.initFixedRPC
                       saw.rpc.client.endpoint.noncluster.initFixedLenRPC
                       saw.rpc.ping.send
                       saw.threads
                  ecid: 00iEKCvlERMFg4WFLzmJOA0001No000002,0
                  ThreadID: 1596
                  ]]
                  • 6. Re: 11.1.1.7 Installation issue - Installation stops at Presenation server star
                    864639
                    Check if OBI Server is up or not?
                    • 7. Re: 11.1.1.7 Installation issue - Installation stops at Presenation server star
                      639800
                      Abhi, This is happening while the installation is in the last steps of configuring the system.

                      I have made some changes to the network - namely re-configured the Loopback adapter to have a static IP and then added the appropriate entry in the hosts file to point this static ip to the localhost and machine name strings.
                      details @

                      http://www.oracledistilled.com/windows/configuring-the-loopback-adapter-on-microsoft-windows/

                      Will install again and see if this takes care of the issues.

                      Edited by: Jainnys on Apr 19, 2013 8:02 AM
                      • 8. Re: 11.1.1.7 Installation issue - Installation stops at Presenation server star
                        639800
                        The loopback adapter did not help.

                        Any ideas?