This content has been marked as final. Show 11 replies
go to http://public-yum.oracle.com and configure the yum repo,m read the instructions, and configure the yum
then, do yum install gcc gcc-c++
Go to http://public-yum.oracle.com/repo and broswe for the files
If you have ULN access, configure the ULN access for the machine, and do yum install gcc gcc-c++
The packages are not there:
the packages are there.. the versions may not be the same.
I don't know from where you got those versions, but you should configure yum, and do yum update, and then install the packages you want.
In that way you will end with a updated installation.
4.1.12 is fully compatible with 4.1.10 and includes bug fixes and improvements. I cannot think of any reason why you would want or need 4.1.10 specifically. http://gcc.gnu.org/gcc-4.1
I have an oracle application which is hard coded with this versions, so I need ONLY this versions. Unfortunately are not anywhere:(.
Edited by: user635184 on Apr 22, 2013 3:04 AM
Sorry I don't know any Oracle product that is "hard coded" with any specific GCC patch level. If specific libraries are required, they are installed by the Oracle software installation and located in the Oracle home directory. Please provide more details, such as software product, error message, or what you are trying to accomplish.
For BI Publisher 188.8.131.52.0:
See the following doc:
for the section:
x86 Oracle Linux 5 (UL3+)
Red Hat Linux 5 (UL3+)
GCC-4.1.0-28.4 was probably the last known version required and available when the document was created. Also showing Oracle Linux 5.3 or later. It does not mean later software maintenance or bug fix releases do not work and that you should not or cannot install any OS updates.
Edited by: Dude on Apr 22, 2013 3:36 AM
If the OS version is not supported, e.g. OL 6, you need a Oracle product upgrade and cannot simply install older core system components, since it will break your system.
I tried with higher versions. Only this 2 packages don't accept higher version. The others from the list accepted.
What is your OS version? What version of GCC do you have installed? Not accepted where? Please provide all details.
It is common practice and sometimes necessary to ignore the software prerequisite checks in the installer or at the command line when installing older products under current OS versions. I suggest to ask such specific questions in the appropriate product forum, or contact Oracle support.
Downgrading the GCC version installed by the OS installation is nonsense and the only thing it will do is to break your system beyond repair.
I use BIP on OL6, integrated with EM12c, and haven't gotten any warning on versions for any package.
You should give a try to the actual versions on public-yum on the latest channel.
In some old products were some specific version required, like binutils on some ebs, but haven't heard anything will fail on having a new gcc version.
if you have support, you can open an SR to double check.