6 Replies Latest reply: Apr 22, 2013 6:16 AM by 1004590 RSS

    HTTP Server from iAS 10.1.2 does not start after cloning

    Sasharo
      After cloning iAS 10.1.2, Oracle HTTP Server does not start. Here is the log file $ORACLE_HOME/Apache/Apache/logs/error_log.NNNN

      Syntax error on line 232 of /v01/oracle/fr10gR2/Apache/Apache/conf/httpd.conf:
      Cannot load /v01/oracle/fr10gR2/Apache/Apache/libexec/mod_fastcgi.so into server: rtld: 0712-001 Symbol fcgi_pm_pipe was referenced
      from module /v01/oracle/fr10gR2/Apache/Apache/libexec/mod_fastcgi.so(), but a runtime definition
      of the symbol was not found.
      rtld: 0712-001 Symbol fastcgi_module was referenced
      from module /v01/oracle/fr10gR2/Apache/Apache/libexec/mod_fastcgi.so(), but a runtime definition
      of the symbol was not found.
      rtld: 0712-001 Symbol fastcgi_handlers was referenced
      from module /v01/oracle/fr10gR2/Apache/Apache/libexec/mod_fastcgi.so(), but a runtime definition
      of the symbol was not found.
      rtld: 0712-001 Symbol fcgi_config_set_authoritative_slot was referenced
      from module /v01/oracle/fr10gR2/Apache/Apache/libexec/mod_fastcgi.so(), but a runtime definition
      of the symbol was not found.
      rtld: 0712-001 Symbol fcgi_config_new_auth_server was referenced
      from module /v01/oracle/fr10gR2/Apache/Apache/libexec/mod_fastcgi.so(), but a runtime definition
      of the symbol was not found.
      rtld: 0712-001 Symbol fcgi_config_set_config was referenced
      from module /v01/oracle/fr10gR2/Apache/Apache/libexec/mod_fastcgi.so(), but a runtime definition
      of the symbol was not found.
      rtld: 0712-001 Symbol fcgi_config_set_wrapper was referenced
      from module /v01/oracle/fr10gR2/Apache/Apache/libexec/mod_fastcgi.so(), but a runtime definition
      of the symbol was not found.
      0509-021 Additional errors occurred but are not reported.
      Syntax error on line 232 of /v01/oracle/fr10gR2/Apache/Apache/conf/httpd.conf:
      Cannot load /v01/oracle/fr10gR2/Apache/Apache/libexec/mod_fastcgi.so into server: rtld: 0712-001 Symbol fcgi_pm_pipe was referenced
      from module /v01/oracle/fr10gR2/Apache/Apache/libexec/mod_fastcgi.so(), but a runtime definition
      of the symbol was not found.
      rtld: 0712-001 Symbol fastcgi_module was referenced
      from module /v01/oracle/fr10gR2/Apache/Apache/libexec/mod_fastcgi.so(), but a runtime definition
      of the symbol was not found.
      rtld: 0712-001 Symbol fastcgi_handlers was referenced
      from module /v01/oracle/fr10gR2/Apache/Apache/libexec/mod_fastcgi.so(), but a runtime definition
      of the symbol was not found.
      rtld: 0712-001 Symbol fcgi_config_set_authoritative_slot was referenced
      from module /v01/oracle/fr10gR2/Apache/Apache/libexec/mod_fastcgi.so(), but a runtime definition
      of the symbol was not found.
      rtld: 0712-001 Symbol fcgi_config_new_auth_server was referenced
      from module /v01/oracle/fr10gR2/Apache/Apache/libexec/mod_fastcgi.so(), but a runtime definition
      of the symbol was not found.
      rtld: 0712-001 Symbol fcgi_config_set_config was referenced
      from module /v01/oracle/fr10gR2/Apache/Apache/libexec/mod_fastcgi.so(), but a runtime definition
      of the symbol was not found.
      rtld: 0712-001 Symbol fcgi_config_set_wrapper was referenced
      from module /v01/oracle/fr10gR2/Apache/Apache/libexec/mod_fastcgi.so(), but a runtime definition
      of the symbol was not found.
      0509-021 Additional errors occurred but are not reported.

      Do you have any idea how could I resolve this?

      The OS is aix 6.1.

      Thanks,
      Sasharo

      Edited by: Sasharo on 16.01.2013 01:41
        • 1. Re: HTTP Server from iAS 10.1.2 does not start after cloning
          Fabian
          Syntax error on line 232 of /v01/oracle/fr10gR2/Apache/Apache/conf/httpd.conf
          Can paste httpd.conf file or lines between 225-240 from httpd.conf file
          • 2. Re: HTTP Server from iAS 10.1.2 does not start after cloning
            Fabian
            Syntax error on line 232 of /v01/oracle/fr10gR2/Apache/Apache/conf/httpd.conf
            Can you paste httpd.conf file or lines between 225-240 from httpd.conf file
            • 3. Re: HTTP Server from iAS 10.1.2 does not start after cloning
              user3402410
              I have the exact same issue except I patched aix 6.1 from tl 01 to tl 08
              here is my file
              +225 LoadModule expires_module libexec/mod_expires.so
              +226 LoadModule headers_module libexec/mod_headers.so
              +227 LoadModule usertrack_module libexec/mod_usertrack.so
              +228 LoadModule unique_id_module libexec/mod_unique_id.so
              +229 LoadModule setenvif_module libexec/mod_setenvif.so
              +230 LoadModule perl_module libexec/libperl.so
              +231 LoadModule fastcgi_module libexec/mod_fastcgi.so
              +232 LoadModule php4_module libexec/libphp4.so
              +233
              +234 <IfDefine SSL>
              +235 LoadModule ossl_module libexec/mod_ossl.so
              +236 </IfDefine>
              +237
              +238 LoadModule wchandshake_module libexec/mod_wchandshake.so
              +239 #
              +240 # ExtendedStatus controls whether Apache will generate "full" status
              +241 # information (ExtendedStatus On) or just basic information (ExtendedStatus
              +242 # Off) when the "server-status" handler is called. The default is Off.
              +243 #
              +244 ExtendedStatus On
              +245 ### Section 2: 'Main' server configuration
              +246 #
              +247 # The directives in this section set up the values used by the 'main'
              +248 # server, which responds to any requests that aren't handled by a
              +249 # <VirtualHost> definition. These values also provide defaults for
              +250 # any <VirtualHost> containers you may define later in the file.
              • 4. Re: HTTP Server from iAS 10.1.2 does not start after cloning
                Sasharo
                Here are the 225-240 lines of httpd.conf

                LoadModule cern_meta_module libexec/mod_cern_meta.so
                LoadModule expires_module libexec/mod_expires.so
                LoadModule headers_module libexec/mod_headers.so
                LoadModule usertrack_module libexec/mod_usertrack.so
                LoadModule unique_id_module libexec/mod_unique_id.so
                LoadModule setenvif_module libexec/mod_setenvif.so
                LoadModule perl_module libexec/libperl.so
                LoadModule fastcgi_module libexec/mod_fastcgi.so
                LoadModule php4_module libexec/libphp4.so

                <IfDefine SSL>
                LoadModule ossl_module libexec/mod_ossl.so
                </IfDefine>

                LoadModule wchandshake_module libexec/mod_wchandshake.so
                #
                • 5. Re: HTTP Server from iAS 10.1.2 does not start after cloning
                  user3402410
                  trying patching libperl.so from a working 10.1.2.2 apache libexec home and try starting again.
                  there is now a documented fault where it will not start if the OS is AIX 6100_08

                  BUG:16191656 - R2 - RMS 13.1.6 HTTP SERVER WILL NOT START AFTER UPGRADE TO AIX 6.1 TL8

                  Edited by: user3402410 on 25-Jan-2013 02:06
                  • 6. Re: HTTP Server from iAS 10.1.2 does not start after cloning
                    1004590
                    I facing similar issue on AIX 6.1 64 bit platform

                    here I am trying to load webgate agent on apache 2.2 :


                    httpd: Syntax error on line 420 of /home/installApache/conf/httpd.conf: Cannot load /home/oracleHomeDir/webgate/apache/lib/myTestModule.so into server: rtld: 0712-001 Symbol Slfgfn was referenced\n from module /home/libnnz11.so(), but a runtime definition\n of the symbol was not found.\nrtld: 0712-001 Symbol XmlCreate was referenced\n from module /home/libnnz11.so(), but a runtime definition\n of the symbol was not found.\nrtld: 0712-001 Symbol XmlLoadDom was referenced\n from module /home/libnnz11.so(), but a runtime definition\n of the symbol was not found.\nrtld: 0712-001 Symbol ber_free/home/libnnz11.so was referenced\n from module /home/libnnz11.so(), but a runtime definition\n of the symbol was not found.\nrtld: 0712-001 Symbol ldap_add_s was referenced\n from module /home/libnnz11.so(), but a runtime definition\n of the symbol was not found.\nrtld: 0712-001 Symbol ldap_bind_s was referenced\n from module /home/libnnz11.so(), but a runtime definition\n of the symbol was not found.\nrtld: 0712-001 Symbol ldap_count_entries was referenced\n from module /home/libnnz11.so(), but a runtime definition\n of the symbol was not found.\n\t0509-021 Additional errors occurred but are not reported.