10 Replies Latest reply: Apr 26, 2013 1:13 AM by Veeresh Rayan RSS

    how to use a repository in a new report

    Andre_NL
      Hello,

      I am starting to learn OBIEE and installed it in my home environment. I installed OBIEE, and used the RCU to install a repository in an Oracle database.
      Then, I used the BI Administration tool to make a 'repository' which connects to my data (also in an Oracle database).
      In the BI Administration tool I now have a physical layer, a business model and mapping, and a presentation layer. I saved this as a rpd file on my harddisk.
      Then, in the Oracle BIEE Home I choose 'New report'. But I cannot find how I can choose my 'repository' with my data. I also tried to make a new datamodel, but here I am also not able to choose my repository.

      How can I connect to my data in a report ? How does it work ?

      Many thanks in advance,
      Best Regards,
      André.
        • 1. Re: how to use a repository in a new report
          Veeresh Rayan
          You may need to open the RPD in online mode...

          Launch the Administration tool and Heighlight on the Online mode ICON and Provide necessary details.

          It wil open up online mode and you wil also be able to find your repository metadata.

          Mark correct or helpfull if it helps.

          Regards,
          Veeresh Rayan
          • 2. Re: how to use a repository in a new report
            Andre_NL
            Thank you for your reply.
            When I trie to open in online mode, I have to give a repository password, and a user&password.
            For the repository password I give the password I gave when I created the repository (let's say pw1)
            For the user & password I give the user&passw I entered when I ran RCU (create new BI system). It is admin & pw1 (I have the same password for both)
            But I get an error 'Repository password is wrong'. I don't understand it, what do I do wrong ?

            Do I understand correctly that the repository I made in the Administration tool (physical layer, business and presentation layer) is something different from the repository the RCU created ?

            Thanks in advance, best regards,
            André.
            • 3. Re: how to use a repository in a new report
              Veeresh Rayan
              You are totally getting Confused..

              Have these understanding first.

              You have DB installed.
              You will create schema(Two users) in DB using RCU(Repository Creation Utility:Basically stores metadata required for OBIEE).
              You will install OBIEE and use these schema there.
              Above installation installs weblogic and then deploy BI files to weblogic to make them work.You should remember weblogic password.

              Now when you open up Admin tool --Repository password should be 'Admin123' (A in capital)  and username is weblogic and password should be weblogic password.

              You will be able to open up the RPD in online mode.

              I suggest you to first go through the Architecture of OBIEE and then start installation and start exercises.

              mark correct or helpfull if it helps.Also let me know if you were able to open RPD and answers.

              Regards,
              Veeresh Rayan
              • 4. Re: how to use a repository in a new report
                Andre_NL
                Thank you for your help.

                I opened the repository with Admin123 and user/passw=admin/pw1.
                I then added the metadata for my data (the three layers).
                I checked in changes. Save.

                But I still don't see it anywhere when creating a new 'Report'. When choose 'New -> Report' I have a choice between 'use existing data model' and 'create new data model'. What would be the way to proceed ? I tried both, but I never get to see my metadata.

                many thanks en regards,
                André.
                • 5. Re: how to use a repository in a new report
                  JasonBaer
                  Hi Andre,

                  The "Report" option you're selecting is part of Published Reporting, or BI Publisher. That's an entirely different animal.

                  Try New -> Analysis. You should be able to see your new Subject Area there.

                  JB
                  • 6. Re: how to use a repository in a new report
                    Veeresh Rayan
                    You need to login to presentation services..

                    Use this url.


                    http://localhost(ip where OBIEE installed):9704/analyitcs (Ex . http://localhost:9704/analytics).

                    login using weblogic and password.then click on new -->create new analysis .you should be able to create report from there.

                    Let me know if it helps.

                    Regards,
                    Veeresh Rayan
                    • 7. Re: how to use a repository in a new report
                      Andre_NL
                      OK, so I try to make an analysis. I saw in the documentation that it is possible to distribute an anlysis. I will try to figure this out. Because I want to make a daily publication of a report. I wonder what the 'Report' thing, which I tried before, is ment for then ?

                      When I choose 'New analysis', I see my metadata, so that starts good. But when I want to expand a table, to see the colums, a circle appears, and nothing happens. The circle is not moving/circling. What could be going wrong ?

                      Thanks in advacne for the help,
                      Best regards, André.
                      • 8. Re: how to use a repository in a new report
                        Veeresh Rayan
                        If you are checking out any metadata object in RPD and viewing the same in Answers at the same time You face this error.

                        So please check in all the objects in RPD first and then try.

                        Try logging out from the answers and if doesn't work then restart the BI services.

                        Mark correct or helpfull which is dsipayed on the upper most corner(right hand side) of each post.

                        Regards,
                        Veeresh Rayan
                        • 9. Re: how to use a repository in a new report
                          Andre_NL
                          I can't get it to work.
                          Today I started the server (everything was closed yesterday). In the BI Administration (repository opened in online mode) nothing was checked out; there was no option to checkin, only to checkout. But I still have the same behaviour in the Oracle BI Answers module.

                          Thanks in advance, André.
                          • 10. Re: how to use a repository in a new report
                            Veeresh Rayan
                            Send me the screnshot to veereshrayan@gmai.com .

                            I will take a look.

                            Regards,
                            Veeresh Rayan