This discussion is archived
4 Replies Latest reply: Apr 22, 2013 10:05 AM by fugglefeet RSS

Solaris 11.1 on SPARC T5240 - Gnome issue

1001890 Newbie
Currently Being Moderated
Hi,
I've installed Solaris 11.1 on a SPARC T5240 (text install) and - after - installed the solaris-desktop pkg. Starting the GUI, I cannot see both bottom and top panels (the menu bar). The same installation work perfectly on x86 devices (eg. Sunfire X4170M2). Any hints about what to check?

Many thanks,

L
  • 1. Re: Solaris 11.1 on SPARC T5240 - Gnome issue
    1001890 Newbie
    Currently Being Moderated
    This is the last part from /var/log/Xorg.0.log:

    [  1945.834] (II) LoadModule: "xtsol"
    [  1945.836] (WW) Warning, couldn't open module xtsol
    [  1945.837] (II) UnloadModule: "xtsol"
    [  1945.837] (II) Unloading xtsol
    [  1945.837] (EE) Failed to load module "xtsol" (module does not exist, 0)
    [  1945.837] (WW) could not get frame buffer identifier from /dev/fb
    [  1945.926] (==) Assigned the driver to the xf86ConfigLayout
    [  1945.926] (EE) No drivers available.
    [  1945.926]
    Fatal server error:
    [  1945.927] no screens found
    [  1945.927]
    Please consult the Oracle Corporation, based on X.Org Foundation sources support
    at http://support.oracle.com/
    for help.
    [  1945.927] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    [  1945.927]
    [  1945.928] Server terminated with error (1). Closing log file.


    and from /var/log/gdm/:0.log.4:

    X.Org X Server 1.12.2
    Release Date: 2012-05-29
    X Protocol Version 11, Revision 0
    Build Operating System: SunOS 5.11 sun4v
    Current Operating System: SunOS sun26 5.11 11.1 sun4v
    Solaris ABI: 64-bit
    Current version of pixman: 0.24.4
    Before reporting problems, check http://support.oracle.com/
    to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Tue Apr 9 14:13:06 2013
    (==) Using default built-in configuration (3 lines)

    Fatal server error:
    no screens found

    Please consult the Oracle Corporation, based on X.Org Foundation sources support
    at http://support.oracle.com/
    for help.
    Please also check the log file at "/var/log/Xorg.0.log" for additional information.

    Server terminated with error (1). Closing log file.


    I'd really appreciate any help!

    L
  • 2. Re: Solaris 11.1 on SPARC T5240 - Gnome issue
    fugglefeet Newbie
    Currently Being Moderated
    Hi,

    It would seem odd that your install on the Sparc T5240 should give problems (as both systems are listed as being certified to work with Solaris 11 as shown at [http://www.oracle.com/webfolder/technetwork/hcl/data/s11ga/systems/views/all_servers_all_results.mfg.page7.html] ). Have you thought of installing from the Live Installer to see if this would fix the problem? Since I am a newbie, I am aware I run the risk of critism, as I have only managed to install Solaris 11 with Gnome from a live installer onto an Intel PC with a core i7 3770 with 4GB of RAM and I have not even scratched the surface of even learning how to work with it yet.

    Hope this can of some help.

    fugglefeet

    Edited by: fugglefeet on Apr 21, 2013 9:24 PM
  • 3. Re: Solaris 11.1 on SPARC T5240 - Gnome issue
    Pascal Kreyer - Oracle Expert
    Currently Being Moderated
    Live CD doesn't exist for SPARC.

    Based on th Xorg log file, you should not have an graphical output on video output. Either these errors are old, or you have really no graphical output.
  • 4. Re: Solaris 11.1 on SPARC T5240 - Gnome issue
    fugglefeet Newbie
    Currently Being Moderated
    Thanks Pascal,

    My mistake. I did not even see the obvious.

    fugglefeet

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points