3 Replies Latest reply on Apr 24, 2013 5:06 PM by sh.hazeri

    select * from v$session; (sqlplus hangs)

      select * from v$session; (sqlplus hangs)
      select username from v$session; (sqlplus work!)

      My machine
      Oracle Client 11g R2 32 bit on Windows 7 64 bit
      Servers: (I have tried two servers)
      11g R2 on Win 2003 32 bit
      11g R2 on Win 2008 64 bit

      Note 1: I do not think this issue is unique to Sqlplus becauseToad uses the same Oracle client and it freezes too and also Oracle SQL developer hangs too. So seems to be the Oracle 11gR2 client issue on Windows 7. I tried same scenario but this time from SQLPlus running on a Windows 2008 R2 (64 bit) to connect to one of the two above servers and the 'Select * from v$session' works just fine.

      Note 2: If I connect to a 32 bit 10G DB using the same client on my machine (Oracle Client 11g R2 32 bit on Windows 7 64) then it works fine too.

      Note 3: V$Session is one of many's. ( Pretty much all V$ views seems to have the same issue with)

      Note 4: I've got a Server 11g R2 on my machine and using the same client I mentioned above, I can not connect and run the faulty 'Select' no problem. ( I am using the client to connect to my server - both on my laptop)

      So I am stuck - it just does not make sense at all!

      Any Idea please?
        • 1. Re: select * from v$session; (sqlplus hangs)
          if you have database control or Grid control then try searching for your session and see if this is active and what is showing under activity.

          please update.

          • 2. Re: select * from v$session; (sqlplus hangs)
            I should have said that I'd already checked this:
            I see the session. Its inactive but I see the sql-text "Select * from v$session" under the open-cursors so the sqltext is passed to the DB. Under waits, I see "SQL *net message from client" and the second in waits increases as I click on refresh and it sits there forever.
            • 3. Re: select * from v$session; (sqlplus hangs)
              One more thing: I installed a 10g client on this machine ( that means now I have 11g and 10g client on this machine) and if I connect with 10g then there is no problem and it works just fine. so the issue only happens with 11g client ...