This discussion is archived
11 Replies Latest reply: May 1, 2013 8:05 AM by Terry Phelps RSS

Cannot  update server (3.2.1) from my yum repository

Terry Phelps Newbie
Currently Being Moderated
I have been maintaining a YUM repository, and updating my VM servers for a year now. It has always worked with no problems. Suddenly, it fails. I even created a new YUM repository from scratch, and I get the same problem, so I don't think the repo is hosed. To get more details about the problem, SSHed into one of the VM servers, and did a "yum update" manually, just to see the error messages. Here they are:

-------------------------
# yum update
Repository 'ovm_repo' is missing name in configuration, using id
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package enterprise-linux-ovs.x86_64 0:5-5.208.13 set to be updated
---> Package ovs-agent.x86_64 0:3.2.1-183.4 set to be updated
---> Package ovs-release.x86_64 0:3.2-5.208.13 set to be updated
ovm_repo/filelists_db | 37 kB 00:00
--> Processing Dependency: nscd for package: ovs-release
--> Processing Dependency: nss_ldap for package: ovs-release
--> Processing Dependency: vmpinfo3-sosreport for package: ovs-release
--> Processing Dependency: /lib/libc.so.6 for package: ovs-release
--> Processing Dependency: openldap-clients for package: ovs-release
--> Processing Dependency: acpid for package: ovs-release
---> Package xen.x86_64 0:4.1.3-25.el5.6 set to be updated
---> Package xen-devel.x86_64 0:4.1.3-25.el5.6 set to be updated
---> Package xen-tools.x86_64 0:4.1.3-25.el5.6 set to be updated
--> Running transaction check
---> Package acpid.x86_64 0:1.0.4-12.el5 set to be updated
---> Package nscd.x86_64 0:2.5-49.el5_5.4 set to be updated
---> Package nss_ldap.x86_64 0:253-25.el5_5.3 set to be updated
---> Package openldap-clients.x86_64 0:2.3.43-12.el5_5.2 set to be updated
---> Package ovs-release.x86_64 0:3.2-5.208.13 set to be updated
--> Processing Dependency: vmpinfo3-sosreport for package: ovs-release
--> Processing Dependency: /lib/libc.so.6 for package: ovs-release
--> Processing Dependency: /lib/libc.so.6 for package: ovs-release
--> Finished Dependency Resolution
ovs-release-3.2-5.208.13.x86_64 from ovm_repo has depsolving problems
--> Missing Dependency: vmpinfo3-sosreport is needed by package ovs-release-3. 2-5.208.13.x86_64 (ovm_repo)
ovs-release-3.2-5.208.13.x86_64 from ovm_repo has depsolving problems
--> Missing Dependency: /lib/libc.so.6 is needed by package ovs-release-3.2-5. 208.13.x86_64 (ovm_repo)
Error: Missing Dependency: vmpinfo3-sosreport is needed by package ovs-release-3 .2-5.208.13.x86_64 (ovm_repo)
Error: Missing Dependency: /lib/libc.so.6 is needed by package ovs-release-3.2-5 .208.13.x86_64 (ovm_repo)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va nofiles nodigest
The program package-cleanup is found in the yum-utils package.
------------------------

See the "missing dependency" lines?
Has anyone seen this problem?
Can anyone suggest what is wrong, and how to resolve it?

"It's always something."

Edited by: Terry Phelps on Apr 24, 2013 3:16 PM

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points