5 Replies Latest reply on Apr 24, 2013 7:56 PM by Gary Graham-Oracle

    compiling and debugging woes

      SQL Developer
      I feel so dumb ...
      I modified a package, now it won't compile. When I run the sql-File that holds package specification and body it rightly complains that there are errors. I tells me to check the compiler log. First question: where to I find the log?
      Ok, than I navigate in the connection browser to the package body itself which is marked as erroneous. ok. I open it. I right click and choose "compile" in the context menu. I would expect now that it shows me a list of syntax errors. But it does not. Nothing happens.
      How am I suppose to debug this now? Should I switch back to sql-plus?
      thanks for any help!
        • 1. Re: compiling and debugging woes
          Chandrakaanth Ramamurthy
          Go to view-->Log (shortcut is ctrl+shift+L)

          This should give u access to see all the logs.

          Then click on the pkb that you want to compile, click compile and then see that the logs are displayed with the errors.
          • 2. Re: compiling and debugging woes
            Thanks for your help - but this seems to get even more tricky:
            I've tried to do the same thing on a windows machine, and there it works without problems.
            The instance of sqldeveloper I have problems with is on ubuntu linux, I have downloaded and installed Sql Developer 3.2.2 for other platforms.
            Apart from not being able to compile the package I also miss all the usual icons in the code editor view. See https://dl.dropboxusercontent.com/u/8595447/img86.png
            Any ideas how to solve this?


            Edited by: steph0h on 24.04.2013 12:05
            • 3. Re: compiling and debugging woes
              Gary Graham-Oracle
              Hi Stephan,

              Not only are many Code tab toolbar icons missing , even the Code tab itself (along with tabs for Grants, ..., Details, Profile) is missing. Your install must be corrupted.

              Did you install from an rpm or zip? Personally, I have multiple SQL Developer versions installed (whatever the OS), so I tend to just unzip into an empty directory.

              Hope this helps,
              SQL Developer
              • 4. Re: compiling and debugging woes
                I investigated more and found I was running SQL Developer with Java 7. Apparently it should only be run with java 6. So I made sure that it is started with the correct java version - and now it works ok. Icons are there again and it is possible to compile. Hurray!
                • 5. Re: compiling and debugging woes
                  Gary Graham-Oracle
                  Thanks for posting your solution! The impact of using Java 7 against seems to vary by Java 7 update number and by OS. Perhaps someone else already posted a warning about Java 7 on Ubuntu, I don't recall, but it is always best to stick with certified versions.