4 Replies Latest reply: Aug 21, 2013 11:28 AM by fe8f727b-ee0c-42c7-aef0-36f07bb72dd5 Branched to a new discussion. RSS

    FRM-92095

    1005338
      Hi,

      I am working on windows 7 64 bit.
      I have problem with running the form. I got the message FRM-92095 Oracle Jinitiator version too low.

      I have tried two things but still it is not working: 1- I added this parameter to java runtime parameters:
      -Djava.vendor="Sun Microsystems Inc."

      2- In runtime, application server url: http://127.0.01:8889/forms/frmservlet?config=jpi
        • 1. Re: FRM-92095
          HamidHelal
          1002335 wrote:
          Hi,
          Welcome to the Oracle Forums. Please take a few minutes to review the following:

          <ul>
          <li>Oracle Forums FAQ
          <li>Before posting on this forum please read
          <li>10 Commandments for the OTN Forums Member
          <li>How to ask questions the smart way
          </ul>

          Following these simple guidelines will ensure you have a positive experience in any forum; not just this one!
          I am working on windows 7 64 bit.
          You also have to provide your JRE version, browser name and version, of course forms or application server version.
          Without the above information it's hard to say anything.
          I have problem with running the form. I got the message FRM-92095 Oracle Jinitiator version too low.

          I have tried two things but still it is not working: 1- I added this parameter to java runtime parameters:
          -Djava.vendor="Sun Microsystems Inc."

          2- In runtime, application server url: http://127.0.01:8889/forms/frmservlet?config=jpi
          It's issue of in-compatible JRE and form version.


          Hamid
          • 2. Re: FRM-92095
            Matthew D.
            On your system you must create environment variable JAVA_TOOL_OPTIONS and set value -Djava.vendor="Sun Microsystems Inc.".
            This solution is only for Windows 7 machines.

            Regards
            • 3. Re: FRM-92095
              CraigB

              I have problem with running the form. I got the message FRM-92095 Oracle Jinitiator version too low.

              What is your Forms version?  The Oracle Jinitiator is too old or Windows 7.  That's like trying to put an engine from Ford Model T in a Ferri.  They are just not made for each other!

              You should be using the latest Oracle (Sun) Java Runtime 1.6 or 1.7 (depending on your Forms version).

               

               

              2- In runtime, application server url: http://127.0.01:8889/forms/frmservlet?config=jpi

              When using the JPI (Java Plug-In) you must have the Oracle Java Runtime installed - not the Oracle Jinitiator.

              Please tell what Forms version (eg: Forms 11.1.2.0.0 not Forms 11g).  How are you running your form?  Are you running it from the Forms Builder or running it from an application server?

               

              Craig...

              • 4. Re: FRM-92095
                fe8f727b-ee0c-42c7-aef0-36f07bb72dd5

                Thank you mdra801108!

                I had to do the following:
                (1) Go to Control Panel -> system -> advanced system settings -> Environment Variables -> New System Variable -> and set a new environment variable name JAVA_TOOL_OPTIONS with value -Djava.vendor="Sun Microsystems Inc."
                (2) Verify that in Control Panel -> (tab) Java -> View... -> (tab) System, under Runtime Parameters we see the -Djava.vendor="Sun Microsystems Inc."
                (3) Restart Internet Explorer

                Then the app that was giving me the problem started working!  This worked on both a Windows 8 system and on a Windows 7 SP1 system, with only the latest version of Java 7 (25) installed.