This discussion is archived
8 Replies Latest reply: Jun 7, 2013 6:50 AM by Dude! RSS

Oracle Redhat 6.4 - eth0: no IPv6 routers present

599860 Newbie
Currently Being Moderated
Dear Experts,

I installed Oracle Redhat 6.4.

But the network is not working.

What is the secret to making it work?

Analysis below.

Thanks a lot!

--------

Use:
file /usr/share/system-config-network/netconf_tui.py
/usr/share/system-config-network/netconf_tui.py: a /usr/bin/python script text executable

- brings up a character based GUI

DEVICE CONFIGURATION
DNS Configuration

change DNS Configuration from Belkin to the DNS of the router.


Device:

DHCP

save and quit

(This will be changed to static eventually, but my
practice/experience is to get it to first work with DHCP)

------

/sbin/ifdown eth0
Error: Device 'eth0' (/org/freedesktop/NetworkManager/Devices/0) disconnecting failed: This device is not active

/sbin/ifup eth0

Active connection state: activating
Active connection path: /org/freedesktop/NetworkManager/ActiveConnection/32

** (process:29591): WARNING **: nmobject_get_property: Error getting 'State' for /org/freedesktop/NetworkManager/ActiveConnection/32: (19) Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist

state: unknown
Error: Connection activation failed.

-------

Reboot.

dmesg | grep -i "eth"

e1000e 0000:04:00.0: eth0: (PCI Express:2.5GT/s:Width x4) 00:23:54:73:5f:01
e1000e 0000:04:00.0: eth0: Intel(R) PRO/1000 Network Connection
e1000e 0000:04:00.0: eth0: MAC: 6, PHY: 5, PBA No: FFFFFF-0FF
e1000e 0000:04:00.1: eth1: (PCI Express:2.5GT/s:Width x4) 00:23:54:73:5f:00
e1000e 0000:04:00.1: eth1: Intel(R) PRO/1000 Network Connection
e1000e 0000:04:00.1: eth1: MAC: 6, PHY: 5, PBA No: FFFFFF-0FF
ADDRCONF(NETDEV_UP): eth0: link is not ready
e1000e: e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: Rx/Tx
e1000e 0000:04:00.0: eth0: 10/100 speed: disabling TSO
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
8021q: adding VLAN 0 to HW filter on device eth0
ADDRCONF(NETDEV_UP): eth1: link is not ready
8021q: adding VLAN 0 to HW filter on device eth1
eth0: no IPv6 routers present
eth0: no IPv6 routers present
eth0: no IPv6 routers present


-------

ping yahoo.com
ping: unknown host yahoo.com


-------

ifconfig
eth0 Link encap:Ethernet HWaddr 00:23:54:73:5F:01
inet6 addr: fe80::223:54ff:fe73:5f01/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:38 errors:0 dropped:0 overruns:0 frame:0
TX packets:61 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:7121 (6.9 KiB) TX bytes:6394 (6.2 KiB)
Interrupt:18 Memory:b0200000-b0220000
  • 1. Re: Oracle Redhat 6.4 - eth0: no IPv6 routers present
    TommyReynolds Expert
    Currently Being Moderated
    Please do this:
    # /sbin/ifconfig -a
    to show us the current configuration.

    Then show us the content of the files:
    /etc/sysconfig/network-scripts/ifcfg-*
    Are you running NetworkManager? It's files are in */etc/sysconfig/network/* and deeper.
  • 2. Re: Oracle Redhat 6.4 - eth0: no IPv6 routers present
    599860 Newbie
    Currently Being Moderated
    Thanks for responding.

    I edited a few of the files. But the symptom remains.
    See the output below.



    ----

    cd /etc/sysconfig

    cat network

    NETWORKING=yes
    NETWORKING_IPV6=yes
    HOSTNAME=black

    --------


    cd /etc/sysconfig/network-scripts


    cat ifcfg-eth0

    IPADDR=192.168.2.201
    NETMASK=255.255.255.0
    GATEWAY=192.168.2.1
    DEVICE=eth0
    TYPE=Ethernet
    UUID=b87686b8-079b-4e86-a6ed-ad9dbc14f2ac
    ONBOOT=yes
    NM_CONTROLLED=yes
    BOOTPROTO=dhcp
    HWADDR=00:23:54:73:5f:01
    DEFROUTE=yes
    PEERDNS=yes
    PEERROUTES=yes
    IPV4_FAILURE_FATAL=yes
    IPV6INIT=yes
    IPV6_AUTOCONF=yes
    IPV6_DEFROUTE=yes
    IPV6_PEERDNS=yes
    IPV6_PEERROUTES=yes
    IPV6_FAILURE_FATAL=yes
    NAME="System eth0"
    USERCTL=no


    --------

    cat /etc/resolv.conf
    nameserver 192.168.2.1


    ------

    Reboot

    ping yahoo.com
    ping: unknown host yahoo.com


    ------


    dmesg | grep -i "eth0"

    e1000e 0000:04:00.0: eth0: (PCI Express:2.5GT/s:Width x4) 00:23:54:73:5f:01
    e1000e 0000:04:00.0: eth0: Intel(R) PRO/1000 Network Connection
    e1000e 0000:04:00.0: eth0: MAC: 6, PHY: 5, PBA No: FFFFFF-0FF
    ADDRCONF(NETDEV_UP): eth0: link is not ready
    e1000e: e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: Rx/Tx
    e1000e 0000:04:00.0: eth0: 10/100 speed: disabling TSO
    ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    8021q: adding VLAN 0 to HW filter on device eth0
    eth0: no IPv6 routers present
    eth0: no IPv6 routers present
    eth0: no IPv6 routers present
    eth0: no IPv6 routers present
    eth0: no IPv6 routers present
    eth0: no IPv6 routers present
    eth0: no IPv6 routers present
    eth0: no IPv6 routers present


    -------

    ifconfig -a
    eth0 Link encap:Ethernet HWaddr 00:23:54:73:5F:01
    inet6 addr: fe80::223:54ff:fe73:5f01/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:50 errors:0 dropped:0 overruns:0 frame:0
    TX packets:76 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:6775 (6.6 KiB) TX bytes:8918 (8.7 KiB)
    Interrupt:18 Memory:b0200000-b0220000

    eth1 Link encap:Ethernet HWaddr 00:23:54:73:5F:00
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:19 Memory:b0220000-b0240000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:16 errors:0 dropped:0 overruns:0 frame:0
    TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:960 (960.0 b) TX bytes:960 (960.0 b)

    virbr0 Link encap:Ethernet HWaddr 52:54:00:26:12:A9
    inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    virbr0-nic Link encap:Ethernet HWaddr 52:54:00:26:12:A9
    BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:500
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)



    which nm-connection-editor
    /usr/bin/nm-connection-editor

    Showed 2 connections for eth0
    Deleted one.


    IPV4 - set to Automatic DHCP
    IPV6 - set to Automatic

    No routes.


    ----

    Yes, the ethernet cable is in the correct port.

    Whatis:

    8021q: adding VLAN 0 to HW filter on device eth0
    ???

    How can I tell if I'm running NetworkManager?

    Thanks a lot!
  • 3. Re: Oracle Redhat 6.4 - eth0: no IPv6 routers present
    Dude! Guru
    Currently Being Moderated
    You have configured eth0 to use a fixed IP address and also DHCP?

    I suggest you try to Google to find out how to configure a TCP/IP under Enterprise Linux - there are plenty of examples and resources.
    ADDRCONF(NETDEV_UP): eth0: link is not ready
    You do not have a physical connection.

    What is your output of: ethtool eth0

    I suggest to check whether you might have a TCP/IP address conflict or cabling problem. Perhaps your wall sockets have port security enabled preventing the device from going online.
  • 4. Re: Oracle Redhat 6.4 - eth0: no IPv6 routers present
    599860 Newbie
    Currently Being Moderated
    Thanks for responding.


    And yet, you'll notice a few lines further:
    ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready


    Good catch on the static vs DHCP.
    I'd started what had worked successfully before.

    But even after I completed all the steps that
    have successfully made my servers use static IP on
    Redhat 5.5, the symptom remains.

    I'm convinced that the cause/problem is with IPV6.

    Let me start over, and I'll post all the original files.
  • 5. Re: Oracle Redhat 6.4 - eth0: no IPv6 routers present
    599860 Newbie
    Currently Being Moderated
    Here is what I did:

    Reinstall Redhat 6.4.
    This time I tried to not install UEL.
    (Which is Unbreakable Enterprise Linux, although you need
    to know what that marketing acronym stands for.)

    And I installed fewer packages this time.
    Although, there were still over 2000 packages installed.

    ----

    boot the system.

    Again, the network is not working.

    ----

    Change the taskbar to the bottom of the screen, (normal).

    Notice an icon in the bottom right.
    Between the sound, and the date icons.
    It is making a circular clockwise motion.

    It is:
    Network Manager Applet 0.8.1
    Written by The Red Hat Desktop Team.

    ---

    Left Click the icon.
    and it lists the ethernet controllers.
    It says they are disabled.

    ---

    Right click the icon, and there is a check box to enable networking.
    Enable it.

    And the internet works as DHCP.

    ---

    Right click the icon, Edit connections.
    Brings up:

    nm-connection-editor
    /usr/bin/nm-connection-editor

    ---

    After the networking engages, the icon changes to two terminals.

    ---

    It looks like there is no IPV6.


    cd /etc/sysconfig/network-scripts

    cat ifcfg-eth0

    DEVICE=eth0
    HWADDR=00:23:54:73:5F:01
    TYPE=Ethernet
    UUID=5be37185-af41-4144-958f-7612df4d1bee
    ONBOOT=no
    NM_CONTROLLED=yes
    BOOTPROTO=dhcp


    cd /etc/sysconfig

    cat network
    NETWORKING=yes
    HOSTNAME=black


    ---

    Surprise! Yet another Redhat "feature".
    So obscure, no one in the forums knows or mentioned it.
  • 6. Re: Oracle Redhat 6.4 - eth0: no IPv6 routers present
    Dude! Guru
    Currently Being Moderated
    You are obviously not using IPv6, which is typically configured to do stateless autoconfiguration. The error you received "no IPv6 routers present" often means that you do not have an IPv6 network or router, or the physical link is down, in which case IPv4 will fail too. IPv6 and IPv4 are separate issues. If you are not using IPv6, errors about it can be ignored, or best IPv6 should be disabled.

    Perhaps you are confusing the task of the network manager with the task to configure your TCP/IP network. The NetworkManager gnome applet will connect any network device when a connection for that device becomes available. It is useful for user Desktop or Laptop systems where automatic setups are desired, for instance, to automatically have the system switch between WIFI and wired connections..

    The Network Manager It is typically not useful for server installations, which is the primary focus of OL or RHEL. It can interfere with your intended network setup. Of course, if your TCP/IP configuration is incorrect, the NetworkManager can help to establish a network connection.
  • 7. Re: Oracle Redhat 6.4 - eth0: no IPv6 routers present
    599860 Newbie
    Currently Being Moderated
    An update.

    I doubted it, but I wondered if my server's hardware suddenly changed.
    Other Linux distributions installed perfectly fine, and started networking with no intervention on my part.
    And previous installs of Redhat 5.5, and Windows booted and networked fine.


    Here is the secret.

    After installing Redhat 6.4 yet another time, I noticed an icon in the lower right hand corner of the screen.
    It was making either a clockwise, or counter clockwise motion.

    When I clicked it, there was a pop up menu.
    One option said: Enable network
    !!

    Turns out that Redhat 6.4 does not automatically enable the network by default !!!!
  • 8. Re: Oracle Redhat 6.4 - eth0: no IPv6 routers present
    Dude! Guru
    Currently Being Moderated
    What you are playing with is the NetworkManager gnome applet, which only works under the Gnome Desktop and only after you have logged into a Gnome session.

    When you install the OS, the anaconda installer provides a "connect automatically" checkbox in the network device configuration screen. You most likely missed it and as a result it does not set the "ONBOOT=yes" parameter in the ifcfg-eth0 network script, which won't "UP" the device after a system restart. As far as I remember, this was the same behavior in the previous OS release.

    The gnome NetworkManager applet serves a different purpose, like I previously tried to explain.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points