4 Replies Latest reply: May 3, 2013 12:05 PM by 941300 RSS

    GCC library required on linux for webgate installation ?

    941300
      Hi Expert,

      I am refering Installation guide for IAM 11gR2 version e27301 on page no. 202 which says,==== start

      On the Linux 64 on x86-64 platform:
      Run the following commands and ensure that their output is always greater than 0:
      strings -a libgcc_s.so.1 | grep -c "GCC_3.0"
      strings -a libgcc_s.so.1 | grep -v "GCC_3.3.1" | grep -c "GCC_3.3"
      strings -a libgcc_s.so.1 | grep -c "GCC_4.2.0"
      file libgcc_s.so.1 | grep "64-bit" | grep -c "x86-64"
      file -L libstdc++.so.6 | grep "64-bit" | grep -c "x86-64"=====end

      Now below is the output of running above command which gives 0 output any help appreciated. am i doing anywrong ?

      [root@localhost temp]# strings -a libgcc_s.so.1 | grep -c "GCC_3.0"
      strings: 'libgcc_s.so.1': No such file
      0
      [root@localhost temp]# strings -a libgcc_s.so.1 | grep -v "GCC_3.3.1" | grep -c "GCC_3.3"
      strings: 'libgcc_s.so.1': No such file
      0
      [root@localhost temp]# strings -a libgcc_s.so.1 | grep -c "GCC_4.2.0"
      strings: 'libgcc_s.so.1': No such file
      0
      [root@localhost temp]# file libgcc_s.so.1 | grep "64-bit" | grep -c "x86-64"
      0
      [root@localhost temp]# file -L libstdc++.so.6 | grep "64-bit" | grep -c "x86-64"
      0
      [root@localhost temp]# rpm -q libgcc_s.so.1
      package libgcc_s.so.1 is not installed
      [root@localhost temp]# yum whatprovides */libgcc_s.so.1
      http://public-yum.oracle.com/repo/OracleLinux/OL5/latest/x86_64/repodata/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
      Trying other mirror.
      el5_u5_base | 1.1 kB 00:00
      el5_latest/filelists | 24 MB 05:41
      libgcc-4.1.2-54.el5.x86_64 : GCC version 4.1 shared support library
      Repo : el5_latest
      Matched from:
      Filename : /lib64/libgcc_s.so.1



      libgcc-4.1.2-52.el5.x86_64 : GCC version 4.1 shared support library
      Repo : el5_latest
      Matched from:
      Filename : /lib64/libgcc_s.so.1



      libgcc-4.1.2-52.el5_8.1.i386 : GCC version 4.1 shared support library
      Repo : el5_latest
      Matched from:
      Filename : /lib/libgcc_s.so.1



      libgcc-4.1.2-52.el5.i386 : GCC version 4.1 shared support library
      Repo : el5_latest
      Matched from:
      Filename : /lib/libgcc_s.so.1



      libgcc-4.1.2-52.el5_8.1.x86_64 : GCC version 4.1 shared support library
      Repo : el5_latest
      Matched from:
      Filename : /lib64/libgcc_s.so.1



      libgcc-4.1.2-51.el5.x86_64 : GCC version 4.1 shared support library
      Repo : el5_latest
      Matched from:
      Filename : /lib64/libgcc_s.so.1



      libgcc-4.1.2-51.el5.i386 : GCC version 4.1 shared support library
      Repo : el5_latest
      Matched from:
      Filename : /lib/libgcc_s.so.1



      libgcc-4.1.2-50.el5.i386 : GCC version 4.1 shared support library
      Repo : el5_latest
      Matched from:
      Filename : /lib/libgcc_s.so.1



      libgcc-4.1.2-50.el5.x86_64 : GCC version 4.1 shared support library
      Repo : el5_latest
      Matched from:
      Filename : /lib64/libgcc_s.so.1



      libgcc-4.1.2-54.el5.i386 : GCC version 4.1 shared support library
      Repo : el5_latest
      Matched from:
      Filename : /lib/libgcc_s.so.1



      libgcc-4.1.2-48.el5.i386 : GCC version 4.1 shared support library
      Repo : el5_u5_base
      Matched from:
      Filename : /lib/libgcc_s.so.1



      libgcc-4.1.2-48.el5.x86_64 : GCC version 4.1 shared support library
      Repo : el5_u5_base
      Matched from:
      Filename : /lib64/libgcc_s.so.1



      libgcc-4.1.2-54.el5.i386 : GCC version 4.1 shared support library
      Repo : installed
      Matched from:
      Filename : /lib/libgcc_s.so.1



      libgcc-4.1.2-52.el5_8.1.x86_64 : GCC version 4.1 shared support library
      Repo : installed
      Matched from:
      Filename : /lib64/libgcc_s.so.1



      [root@localhost temp]# rpm -q libgcc_s.so.1
      package libgcc_s.so.1 is not installed
      [root@localhost temp]# yum install *libgcc_s.so.1
      el5_latest | 1.4 kB 00:00
      Setting up Install Process
      No package *libgcc_s.so.1 available.
      Nothing to do
      [root@localhost temp]# rpm -ivh *libgcc_s.so.1
      error: File not found by glob: *libgcc_s.so.1
      [root@localhost temp]# rpm -ivh */libgcc_s.so.1
      error: File not found by glob: */libgcc_s.so.1
      [root@localhost temp]# rpm -ivh libgcc_s.so.1
      error: open of libgcc_s.so.1 failed: No such file or directory
      [root@localhost temp]# rpm -ivh libgcc-4.1.2-52.el5_8.1.x86_64
      error: open of libgcc-4.1.2-52.el5_8.1.x86_64 failed: No such file or directory
      [root@localhost temp]# rpm -ivh /lib64/libgcc_s.so.1
      /lib64/libgcc_s.so.1: not an rpm package (or package manifest):
      [root@localhost temp]# strings -a libgcc_s.so.1 | grep -c "GCC"
      strings: 'libgcc_s.so.1': No such file
      0
      [root@localhost temp]#
        • 1. Re: GCC library required on linux for webgate installation ?
          chinni
          Hi IgnitedMind,

          Yes, GCC library are required for webgate installation on Linux and Solaris.

          Please download it from http://gcc.gnu.org/ and install.

          Refer below link for more details which clearly says gcc libraries are required

          http://docs.oracle.com/cd/E27559_01/install.1112/e27301/webgate.htm#CACHAFHG

          Thanks & Regards,
          Chinni
          • 2. Re: GCC library required on linux for webgate installation ?
            941300
            Hi Chinni,

            You are repeting the same information which i have already shared in my problem summary.

            I have already shared the doc details which i am refering and the problem occur while executing it.

            I have also pasted commands i am using which actaully not downloading/installing specific lib.

            Can you please walkthought output mentioned above & suggest how to rerun the commands ?
            • 3. Re: GCC library required on linux for webgate installation ?
              chinni
              Hi,

              As you asked in subject regarding gcc library are required for webgate installation which I have provided in previous reply. So, if you have not installed gcc libraries, please install and try to repeat same steps.

              Try below 3 command and provide the output.

              $gcc
              $gcc -v
              $uname -r
              or
              $gcc --version

              Regards,
              Chinni
              • 4. Re: GCC library required on linux for webgate installation ?
                941300
                Hi Chinni,

                Thanks your the response. when runned the $find -name gcc , found below output
                ./usr/bin/gcc
                ./usr/lib/gcc
                ./usr/libexec/gcc

                here is the output of the command yuo requested.

                $./usr/bin/gcc
                gcc.orgi: no input files

                $./usr/bin/gcc -v
                gcc.orgi: no input files

                $./usr/lib/gcc -v
                is a directory

                $./usr/libexec/gcc -v
                is a directory

                $uname -r
                2.6.18-308.11.1.0.1.e15

                Help Appreciated