This discussion is archived
0 Replies Latest reply: Apr 26, 2013 5:39 PM by 970947 RSS

Apache SSL and weblogic app server

970947 Newbie
Currently Being Moderated
Hi Friends,

My OS is Linux.
WL server with http webserver works good.

But, I am unable to configure SSL webserver.
Below are the logs

Fri Apr 26 17:08:59 2013 <2243313670212701> Hdrs to WLS:[Connection]=[Keep-Alive]
Fri Apr 26 17:08:59 2013 <2243313670212701> Hdrs to WLS:[WL-Proxy-SSL]=[true]
Fri Apr 26 17:08:59 2013 <2243313670212701> Hdrs to WLS:[WL-PATH-TRIM]=[Registration]
Fri Apr 26 17:08:59 2013 <2243313670212701> Hdrs to WLS:[WL-Proxy-Client-IP]=[]
Fri Apr 26 17:08:59 2013 <2243313670212701> Hdrs to WLS:[Proxy-Client-IP]=[]
Fri Apr 26 17:08:59 2013 <2243313670212701> Hdrs to WLS:[X-Forwarded-For]=[]
Fri Apr 26 17:08:59 2013 <2243313670212701> Hdrs to WLS:[X-WebLogic-KeepAliveSecs]=[30]
Fri Apr 26 17:09:34 2013 <2243313670212701> EOF was reached was reached in ssl_read_callback()
Fri Apr 26 17:09:34 2013 <2243313670212701> ERROR: SSLWrite failed
Fri Apr 26 17:09:34 2013 <2243313670212701> SEND failed (ret=-1) at 747 of file ../nsapi/URL.cpp
Fri Apr 26 17:09:34 2013 <2243313670212701> *******Exception type [WRITE_ERROR_TO_SERVER] raised at line 748 of ../nsapi/URL.cpp
Fri Apr 26 17:09:34 2013 <2243313670212701> Marking hostname:7008 as bad
Fri Apr 26 17:09:34 2013 <2243313670212701> got exception in sendRequest phase: WRITE_ERROR_TO_SERVER [os error=0,  line 748 of ../nsapi/URL.cpp]: at line 3160
Fri Apr 26 17:09:34 2013 <2243313670212701> INFO: Closing SSL context
Fri Apr 26 17:09:34 2013 <2243313670212701> Failing over after WRITE_ERROR_TO_SERVER exception in sendRequest()
Fri Apr 26 17:09:34 2013 <2243313670212701> request [] did NOT process successfully..................

My conf details are like below
<IfModule weblogic_module>
SecureProxy ON
TrustedCAFile "/opt/app/xxx/Apache/conf/verisign/trustedcafile.pem"
Debug ALL
WLTempDir /opt/app/xxxx/Apache/logs/Bce8ssl/tmp
WLLogFile /opt/app/xxxx/Apache/logs/wlproxy.log
EnforceBasicConstraints off
</IfModule>

<Location /Registration>
SetHandler weblogic-handler
WebLogicHost xxxxx
WebLogicPort xxxx
PathTrim /Registration
ConnectTimeoutSecs 1000
ConnectRetrySecs 1000
</Location>


Any help would be much appreciated. Thanks.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points