This discussion is archived
4 Replies Latest reply: Apr 29, 2013 6:15 AM by Scott_Symonds RSS

Two versions of Weblogic server in the same machine

977698 Newbie
Currently Being Moderated
Hi everyone!

i'd like to know if it is possible to have two versions of oracle weblogic server in the same machine.
i have installed weblogic server 10.3.4 with oracle forms and reports 11.1.1.4 in C:\Oralce\FMW... and it works just fine.

now, i want to install oracle weblogic 10.3.6 with oracle forms and reports 11.1.2.1.0 in C:\Oracle\FMW2... for example.

if it is possible, please tell me how to do it or send an URL to follow the steps of how to do it.

thanks a lot guys i really appreciate any help.
  • 1. Re: Two versions of Weblogic server in the same machine
    Scott_Symonds Explorer
    Currently Being Moderated
    Hi,

    It is certainly possible to have multiple versions of WebLogic in one machine. I have seen installations where this is configured. Here are the requirements to do so:

    1. Specify a different Middleware home. For example, using C:\Oracle\FMW2 will work since it is separate from the other one.
    2. If you plan to use Node Manager in FMW2, make sure to use a port number other than 5556 unless it is not being used for the first Middleware home.
    3. You must name your Oracle instance in FMW2 something different than what you have in the first home.
    4. Although not a requirement but more of an important note, but the ports which FMW2 will use for Forms and Reports will be slightly different than the first home.
    5. Once everything is installed, you will need to update the setDomainEnv.cmd script in both C:\Oracle\FMW\user_projects\domains\%DOMAIN%\bin and C:\Oracle\FMW2\user_projects\domains\%DOMAIN%\bin to use the PATH environment variable specific to the Middleware home.

    Example: Let's say that PATH is: C:\Oracle\FMW2\Oracle_FRHome1\bin;C:\Windows\system32;C:\Oracle\FMW\as_1\bin;...
    The setDomainEnv.cmd for FMW should have the following set:
    set PATH=C:\Oracle\FMW\as_1\bin;C:\Windows\system32;... (NOTE: Notice that C:\Oracle\FMW2\Oracle_FRHome1\bin for the FMW2 is missing)
    The setDomainEnv.cmd for FMW2 should have the following set:
    set PATH=C:\Oracle\FMW2\Oracle_FRHome1\bin;C:\Windows\system32;... (NOTE: Notice that C:\Oracle\FMW\as_1\bin for the FMW is missing)

    Other than that, that's all that needs to be done to run multiple WLS/Forms domains. Hope this helps!

    Thanks,
    Scott
    http://pitss.com/us
  • 2. Re: Two versions of Weblogic server in the same machine
    977698 Newbie
    Currently Being Moderated
    Hi Scott

    thanks a lot for your help I did just what you said but i have another issue:

    when i was installing oracle forms and reports 11.1.2.1.0, i first chose the option that refer to left the software configure the ports automatically, later when it was creating the domain (the fist step of the enviroment configuration) it just stay there, it doesn't give me an error or something, when i checked the Task Manager, the CPU was working at just 1%, it wasn't installing the software.

    Later i checked the log and i saw that the new home was using the DOMAIN_PORT=7001, that's the port that the other home is using, so i prepared a "staticports.ini" file to configure the new enviorment to use the DOMAIN_PORT=7005. but it got stuck again. i left it for a while and 45 minutes later it still stuck.

    any suggestion?

    thanks a lot again.
  • 3. Re: Two versions of Weblogic server in the same machine
    977698 Newbie
    Currently Being Moderated
    Hi again...

    after 67 minutes of the installation, the creation of the domain gave me an error. Here's the end of the log file by the time the error show up.

    *****************************************************************************

    [2013-04-26T15:46:12.874-04:30] [as] [TRACE] [] [oracle.as.install.engine.modules.presentation] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] [SRC_CLASS: oracle.as.install.template.screens.ConfigurationPage] [SRC_METHOD: onDescriptionChange] [CONFIG PAGE] New Description: Configuración de la Aplicación
    [2013-04-26T15:46:12.874-04:30] [as] [TRACE] [] [oracle.as.install.engine.modules.presentation] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] [SRC_CLASS: oracle.as.install.template.screens.ConfigurationPage] [SRC_METHOD: onDescriptionChange] [CONFIG PAGE] Old Description: Application Configuration
    [2013-04-26T15:46:12.906-04:30] [as] [NOTIFICATION] [] [oracle.as.install.engine] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] Setting valueOf(DOMAIN_HOME_PATH) to:C:/Oracle/FMW_K/user_projects/domains/Komat_Domain. Value obtained from:USER
    [2013-04-26T15:46:12.984-04:30] [as] [NOTIFICATION] [] [oracle.as.install.engine] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] Setting valueOf(DOMAIN_PORT) to:7003. Value obtained from:USER
    [2013-04-26T15:46:13.140-04:30] [as] [TRACE:16] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] [SRC_CLASS: oracle.as.install.classic.ca.standard.ClassicConfigMain] [SRC_METHOD: doExecute] ENTRY
    [2013-04-26T15:46:15.840-04:30] [as] [WARNING] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] CSF Entries will not be parsed since the AdminServer is unreachable
    [2013-04-26T15:46:15.871-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] Executing a Jaxb workflow ...
    [2013-04-26T15:46:15.871-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] Begining Oracle Fusion Middleware Configuration ...
    [2013-04-26T15:46:15.871-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] Begining Oracle Fusion Middleware Configuration ...
    [2013-04-26T15:46:15.918-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] ENTRY ASDomain.createDomain
    [2013-04-26T15:46:15.918-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] ENTRY ASDomain.createDomain
    [2013-04-26T15:46:15.918-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] reportStartConfigAction: ENTRY........
    [2013-04-26T15:46:15.918-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] reportStartConfigAction: eventStatus........oracle.as.provisioning.engine.ConfigEventStatus@7b79688d
    [2013-04-26T15:46:15.918-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] reportStartConfigAction: 2........
    [2013-04-26T15:46:15.918-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] reportStartConfigAction: Set the Extion Id to START........
    [2013-04-26T15:46:15.918-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] reportStartConfigAction: Did the assignment...
    [2013-04-26T15:46:15.918-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] reportStartConfigAction: EXIT........
    [2013-04-26T15:46:16.198-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] Domain Home: C:/Oracle/FMW_K/user_projects/domains/Komat_Domain
    [2013-04-26T15:46:16.198-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] Oracle Home: C:/Oracle/FMW_K/Oracle_KOMAT
    [2013-04-26T15:46:16.198-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] Setting os object values in Python
    [2013-04-26T15:46:30.567-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] RETURN: createDomain
    [2013-04-26T15:46:30.567-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] RETURN: createDomain
    [2013-04-26T15:46:30.567-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] ENTRY ASDomain.startDomain
    [2013-04-26T15:46:30.567-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] reportStartConfigAction: ENTRY........
    [2013-04-26T15:46:30.567-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] reportStartConfigAction: eventStatus........oracle.as.provisioning.engine.ConfigEventStatus@f108c18
    [2013-04-26T15:46:30.567-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] reportStartConfigAction: 2........
    [2013-04-26T15:46:30.567-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] reportStartConfigAction: Set the Extion Id to START........
    [2013-04-26T15:46:30.567-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] reportStartConfigAction: Did the assignment...
    [2013-04-26T15:46:30.567-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] reportStartConfigAction: EXIT........
    [2013-04-26T15:47:29.004-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] RETURN: startDomain
    [2013-04-26T15:47:29.004-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] ENTRY ASDomain.startNodeManager
    [2013-04-26T15:47:29.004-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] ENTRY ASDomain.startNodeManager
    [2013-04-26T15:47:29.004-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] reportStartConfigAction: ENTRY........
    [2013-04-26T15:47:29.004-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] reportStartConfigAction: eventStatus........oracle.as.provisioning.engine.ConfigEventStatus@360c069e
    [2013-04-26T15:47:29.004-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] reportStartConfigAction: 2........
    [2013-04-26T15:47:29.004-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] reportStartConfigAction: Set the Extion Id to START........
    [2013-04-26T15:47:29.004-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] reportStartConfigAction: Did the assignment...
    [2013-04-26T15:47:29.004-04:30] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] reportStartConfigAction: EXIT........
    [2013-04-26T16:47:53.884-04:30] [as] [ERROR] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000Jt7zIDxFw005zzWByW1HUhyp000004,0] [[
    oracle.as.provisioning.exception.ASProvWorkflowException: Error Executing workflow.
         at oracle.as.provisioning.engine.WorkFlowExecutor._createDomain(WorkFlowExecutor.java:686)
         at oracle.as.provisioning.engine.WorkFlowExecutor.executeWLSWorkFlow(WorkFlowExecutor.java:391)
         at oracle.as.provisioning.engine.Config.executeConfigWorkflow_WLS(Config.java:866)
         at oracle.as.install.classic.ca.standard.StandardWorkFlowExecutor.execute(StandardWorkFlowExecutor.java:65)
         at oracle.as.install.classic.ca.standard.AbstractProvisioningTask.execute(AbstractProvisioningTask.java:26)
         at oracle.as.install.classic.ca.standard.StandardProvisionTaskList.execute(StandardProvisionTaskList.java:61)
         at oracle.as.install.classic.ca.ClassicConfigMain.doExecute(ClassicConfigMain.java:124)
         at oracle.as.install.engine.modules.configuration.client.ConfigAction.execute(ConfigAction.java:371)
         at oracle.as.install.engine.modules.configuration.action.TaskPerformer.run(TaskPerformer.java:88)
         at oracle.as.install.engine.modules.configuration.action.TaskPerformer.startConfigAction(TaskPerformer.java:105)
         at oracle.as.install.engine.modules.configuration.action.ActionRequest.perform(ActionRequest.java:15)
         at oracle.as.install.engine.modules.configuration.action.RequestQueue.perform(RequestQueue.java:64)
         at oracle.as.install.engine.modules.configuration.standard.StandardConfigActionManager.start(StandardConfigActionManager.java:160)
         at oracle.as.install.engine.modules.configuration.boot.ConfigurationExtension.kickstart(ConfigurationExtension.java:81)
         at oracle.as.install.engine.modules.configuration.ConfigurationModule.run(ConfigurationModule.java:86)
         at java.lang.Thread.run(Thread.java:662)

    ]]

    *********************************************************************************

    P.D: when i installed the weblogic server 10.3.6 i chose to install the nodemanager as a windows service in the port 5557 because the other home is using the port 5556, then i notice that the service doesn't starts.

    i really need help,

    thanks guys.
  • 4. Re: Two versions of Weblogic server in the same machine
    Scott_Symonds Explorer
    Currently Being Moderated
    Hi Josua,

    The problem you are having at the Creating Domain step is a very common problem. There is a KB article which addresses the solution to this problem: http://pitss.com/us/2012/10/08/oracle-forms-configuration-hangs-at-creating-domain/. The KB article talks about the PATH environment variable and how it is known to cause the configuration to "hang" at this step and err out 1 hour later. The article also mentions about having any Node Manager windows services needing to be turned off in Windows Services. Otherwise, you will receive a separate error at a future step in the configuration.

    Regarding the second Node Manager using port 5557, I would check in the nodemanager.log file in C:\Oracle\FMW2\wlserver_10.3\common\nodemanager to see the root cause of the error is for not being able to start up the Node Manager using port 5557. I would try to fix this after the config.bat for Forms completes successfully.

    Hope this helps!

    Thanks,
    Scott

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points