4 Replies Latest reply on May 9, 2013 10:11 PM by User517694-OC

    weblogic.version gives java error after install of D33T


      I just installed patch D33T (Oracle WebLogic Server Patch Set Update - released April 2013. Before installing the patch, I checked my weblogic version (running setWLSEnv and java weblogic.version) following the instructions in the readme and the command worked.

      The patch installed fine, I then checked the version again (first doing setWLSEnv and then running java weblogic.version) - however this produced the java error 'NoClassDefFoundError' - could not find the main class: weblogic.version.

      I found a blog entry that suggested adding the weblogic.jar to the classpath, so I did that, then exported the classpatch, ran the setWLSEnv.sh again and tried the java weblogic.version command again - but still received the java error. I then tried running the command from the folder containg the weblogic.jar and still no luck.

      Anyone have any ideas why this may be producing errors?



      Environment info: RHEL 64 - Weblogic SErver 11gR1 ( - The servers start and seem to be running fine after the patch install.