2 Replies Latest reply on May 2, 2013 9:26 AM by Masood

    Listners Problem While Deploying on a Managed Server

      I am using weblogic server with Jdeveloper
      When I deploy my sample application on AdminServer then it gets deployed successfully but when I deploy it on my Managed Server namely ADFServer then it gives me the following listeners error.

      [08:44:25 AM] ---- Deployment started. ----
      [08:44:25 AM] Target platform is (Weblogic 10.3).
      [08:44:26 AM] Retrieving existing application information
      [08:44:26 AM] Running dependency analysis...
      [08:44:26 AM] Building...
      [08:44:32 AM] Deploying 2 profiles...
      [08:44:33 AM] Wrote Web Application Module to C:\JDeveloper\mywork\ITSDemo\ViewController\deploy\ITSDemo_ViewController_webapp1.war
      [08:44:34 AM] Wrote Enterprise Application Module to C:\JDeveloper\mywork\ITSDemo\deploy\ITSDemo_application1.ear
      [08:44:34 AM] Deploying Application...
      [08:44:36 AM] [Deployer:149193]Operation 'deploy' on application 'ITSDemo_application1' has failed on 'ADFServer'
      [08:44:36 AM] [Deployer:149034]An exception occurred for task [Deployer:149026]deploy application ITSDemo_application1 on ADFServer.: .

      *[08:44:36 AM] Weblogic Server Exception: weblogic.management.DeploymentException:*
      *[08:44:36 AM] Caused by: java.lang.ClassNotFoundException: oracle.adf.share.weblogic.listeners.ADFApplicationLifecycleListener*
      *[08:44:36 AM] See server logs or server console for more details.*
      *[08:44:36 AM] weblogic.management.DeploymentException:*
      *[08:44:36 AM] #### Deployment incomplete. ####*
      *[08:44:36 AM] Remote deployment failed (oracle.jdevimpl.deploy.common.Jsr88RemoteDeployer)*

      Can anybody tell me how to clear this error.

        • 1. Re: Listners Problem While Deploying on a Managed Server

          Have you started your managed server using nodemanager?
          There is Oracle doc id 1475367.1 which says if nodemanager has been used to start managed servers with nodemanager.properties entry "startScriptEnabled=false"
          then Weblogic starts the managed server from location <$Middleware_Home>wlserver_10.3/common/bin which do not refer to JRF libraries causing the exception you reported.

          If this is the issue then to resolve change nodemanager.properties configuration to "startScriptEnabled=true" which will then use script from $DOMAIN_HOME/bin/ to start the servers.

          rank if answer is useful.

          • 2. Re: Listners Problem While Deploying on a Managed Server
            Thank you, It worked. Really appreciable.

            Now when I run a deployed application using the below URL. This is just a sample application.


            It shows me message as loading with a ring rotating but not opening application page.

            What it can be, pls let me know.