1 Reply Latest reply on May 2, 2013 10:17 PM by user12106734

    Invalid Java Home on install of Weblogic

      I’ve got an issue with installing Weblogic. I’m on RHEL 6, trying to install wls1036_generic.jar.
      I’ve downloaded and installed jdk-6u43-linux-x64.bin. When I go to install weblogic I get to the section that allows you to choose your jdk, I point to the directory where I installed it and Weblogic gives me 'Invalid Java Home' error. I’ve removed the JDK tried it in another directory, same thing. I re-downloaded the jdk thinking maybe it was corrupt, still same error. I’ve exported the java home to the directory, still same thing.
      I can run-

      [oracle@blu common]$ cd jdk1.6.0_43/
      [oracle@blu jdk1.6.0_43]$ java -version
      java version "1.6.0_24"
      OpenJDK Runtime Environment (IcedTea6 1.11.11) (rhel-
      OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

      When I do a
      [oracle@blu jdk1.6.0_43]$ which java
      I get /usr/bin/java, so I added /u01/app/oracle/common/jdk1.6.0_43/bin to my path variables, still same thing.

      When I export JAVA_HOME to /u01/app/oracle/common/jdk1.6.0_43
      and add /u01/app/oracle/common/jdk1.6.0_43/bin to the path I get

      [oracle@gil jdk1.6.0_43]$ which java
      [oracle@gil jdk1.6.0_43]$ java -version
      Error occurred during initialization of VM
      java/lang/NoClassDefFoundError: java/lang/Object

      Is this a Java Issue or a Weblogic issue? I would like to mention I have already installed Weblogic on this box, I screwed up an install of OAM and thought I’d restart.
      When I tried to install Weblogic I received the Java Home error, and thought I’d start fresh. I grabbed a clean VM copy of RHEL, to my surprise I’m still getting the error.

      Any help would be appreciated.
      Thanks in advance.