This discussion is archived
3 Replies Latest reply: May 3, 2013 9:44 AM by Jeff Smith SQLDev PM RSS

SQL Developer 3.2.20.09 and Windows 7

apex_disco Newbie
Currently Being Moderated
Which SQL Developer 3.2.20.09 should I use with Win7 x64??

From http://www.oracle.com/technetwork/developer-tools/sql-developer/downloads/index.html
I tried Windows 32-bit - zip file includes the JDK1.6.0_35. I was able to launch it; but, it doesn't find any TNSNames when I try to add connections. Oracle client is on the machine and I am able to connect using SQLPlus.
So I tried pasting the TNS entry to Connect Identifier and I get the following error
Status: Failure - Test failed: C:\Oracle\product\11.2.0\client_1\BIN\ocijdbc11.dll: Can't load AMD 64-bit .dll on a IA 32-bit platform.

So I tried Windows 64-bit SQL Developer with no jre. Looks like it can't find Java.exe because when I launch SQL Developer, it asks me to Enter the full pathname for java.exe
I point it to my C:\Program Files\Java and I get the following error Cannot find a J2SE SDK installed at path C:\Program Files\Java\jre6

Java belongs to Oracle now. SQL Developer belongs to Oracle. Why aren't the left hand talking to the right hand?
  • 1. Re: SQL Developer 3.2.20.09 and Windows 7
    Jeff Smith SQLDev PM ACE Moderator
    Currently Being Moderated
    You can use the 32 or the 64 bit versions.

    But if you want to use the OCI/thick stuff, the bit level will have to match, 32 bit SQLDev with 32 bit Oracle Client with 32 bit JDK. Same goes with 64.

    When you download the 64 bit dist of SQLDev for windows, you'll need to get a 64bit JDK, and make sure you have a 64 bit Oracle Client if you want to use that.

    If you need more info, I wrote up more detailed instructions here
    http://www.thatjeffsmith.com/archive/2012/05/getting-started-with-sql-developer-less-than-5-minutes/
  • 2. Re: SQL Developer 3.2.20.09 and Windows 7
    apex_disco Newbie
    Currently Being Moderated
    Appreciate your help.

    I'm going to go ahead and use 64bit.

    I tried pointing to Oracle Client 11.2.0 (C:\Oracle\product\11.2.0\client_1\jdk\bin) but it says "Java version 1.5.0_17 not supported. The minimum version required is 1.6.0_04. Without having to install a new JDK (don't ask - work machine installation security approval is almost impossible); is there a way to upgrade the JDK Java.exe in the Oracle Client?
  • 3. Re: SQL Developer 3.2.20.09 and Windows 7
    Jeff Smith SQLDev PM ACE Moderator
    Currently Being Moderated
    Maybe.

    You could install it on another machine, zip it up, and then extract the jdk directory onto your new machine.

    Java5 is really old, and 6 is on it's way out. We're going to require 7 here soon, so you may want to just request to your network admin to install that for you...or at least get the ball rolling.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points