This discussion is archived
1 Reply Latest reply: May 3, 2013 8:55 AM by alwu RSS

Jena Adapter for Oracle JVM 1.5

martani Newbie
Currently Being Moderated
Hi,

We are trying to develop java stored procedures within Oracle *11g r2* using the Jena Adapter. The main point of using java stored procedures with the Jena Adapter is to be able to emit SPARQL 1.1 queries which get translated automatically to SQL calls.

We have succeeded running Jena 2.6.4 within the Oracle JVM; but with no luck with the Jena Adpater (version 11.2.0.3) since it requires JDK 1.6.

My question is: is there any compatible JDK 1.5 Jena Adapter available (old packages maybe)? In case there are none, what workaround is there for using SPARQL 1.1 from within Oracle stored procedures.


Regards.
  • 1. Re: Jena Adapter for Oracle JVM 1.5
    alwu Pro
    Currently Being Moderated
    Hi,

    I replied in another thread.

    You probably know this already. In Jena Adapter, we have a feature called S2S (SPARQL 2 SQL). Meaning that if there is a SPARQL query coming in, we will first build a SEM_MATCH based SQL query, then call server-side logic to convert it into a plain SQL, and finally run the plain SQL in the database. This happens automatically unless you have set "s2s=f" in your query.

    Please search for S2S in the following doc for more details.
    http://docs.oracle.com/cd/E11882_01/appdev.112/e11828/sem_jena.htm

    Hope it helps,

    Zhe Wu

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points