This discussion is archived
1 Reply Latest reply: May 6, 2013 2:29 AM by Erik Janssen RSS

application server

1007179 Newbie
Currently Being Moderated
I am new to application server stuff and installing above mentioned release on Oracle enterprise linux AS 4. I have installed repository/OID on a separate machine and installing infrastructure on different machine but when installer asks for hostname and port of OID for connection, upon pressing next button it given error that "Error in getting port information" however listener is up and running on the machine where repository is installed


\Watch Iron Man 3 Online Putlocker
Edited by: 1004176 on May 5, 2013 9:00 AM

Edited by: 1004176 on May 5, 2013 9:00 AM
  • 1. Re: application server
    Erik Janssen Pro
    Currently Being Moderated
    For connectivity issues, telnet is still a great tool to do initial diagnostics. From the host where you are initiating the LDAP connection (application server where you are installing), attempt to telnet to the OID server specifying the port number of the LDAP server, e.g. :
    $ opmnctl status -l
    
    Processes in Instance: asinst_1
    ---------------------------------+--------------------+---------+----------+------------+----------+-----------+------
    ias-component                    | process-type       |     pid | status   |        uid |  memused |    uptime | ports
    ---------------------------------+--------------------+---------+----------+------------+----------+-----------+------
    ovd1                             | OVD                |    4889 | Alive    | 1094295844 |  1126940 | 1320:53:~ | http:8899,ldaps:7501,ldap:6501
    oid1                             | oidldapd           |    4942 | Alive    | 1094295846 |   993124 | 1320:53:~ | N/A
    oid1                             | oidldapd           |    4928 | Alive    | 1094295845 |   439772 | 1320:53:~ | N/A
    oid1                             | oidmon             |    4890 | Alive    | 1094295843 |   826860 | 1320:53:~ | LDAPS:3131,LDAP:3060
    EMAGENT                          | EMAGENT            |    4891 | Alive    | 1094295842 |   106096 | 1320:53:~ | N/A
    My LDAP server runs on port 3060 in plain mode, 3131 is the SSL port.
    $ telnet oid.acme.org 3060
    Trying 192.168.178.11...
    Connected to oid.acme.org.
    Escape character is '^]'.
    If you get the error message 'telnet: connect to address 192.168.178.11: Connection refused', it indicates that there is no daemon process listening on port 3060. Should the connection timeout, it may indicate that there is a network component (e.q. firewall) which may be blocking your connection.

    Thanks,
    EJ

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points