5 Replies Latest reply: May 6, 2013 4:16 AM by rukbat RSS

    Webserver keepalive logs getting full

    875551
      - - [22/Apr/2013:10:39:49 -0400] "HEAD /health/keepalive.html HTTP/1.1" 200 0
      - - [22/Apr/2013:10:39:50 -0400] "HEAD /health/keepalive.html HTTP/1.1" 200 0
      - - [22/Apr/2013:10:39:52 -0400] "HEAD /health/keepalive.html HTTP/1.1" 200 0
      - - [22/Apr/2013:10:39:54 -0400] "HEAD /health/keepalive.html HTTP/1.1" 200 0
      - - [22/Apr/2013:10:39:54 -0400] "HEAD /health/keepalive.html HTTP/1.1" 200 0
      - - [22/Apr/2013:10:39:55 -0400] "HEAD /health/keepalive.html HTTP/1.1" 200 0
      - - [22/Apr/2013:10:39:57 -0400] "HEAD /health/keepalive.html HTTP/1.1" 200 0

      The LB wants one page to be deployed on the app, and appears to hit this page every second. Now this is increasing the logs at an exponential rate. It now makes it extremely difficult to do a tail or try and search this log for any useful information. This will also become a space issue.

      What are the log preferense settings through the admin console to block the webserver from not writing the keepalive response to the access logs ?
        • 1. Re: Webserver keepalive logs getting full
          rukbat
          You made your first OTN Forums post to a HARDWARE forum.
          It does not appear to be a computer hardware inquiry.
          The LB wants one page to be deployed on the app,
          What is "LB" and what software are you using as your "Webserver" ?
          We will attempt to find a better location for your question, once you have revealed that.
          • 2. Re: Webserver keepalive logs getting full
            875551
            LB - An external Cisco[ Load Balancer ] that is configured to send a keep alive request to the Web Server every 2 seconds . the Webserver is Oracle iplanet Webserver version 7.1 . We would like to keep the keepalive request from the load balancer , however it is difficulet to maintain the logs that are updated every seconds . They make it cumbersome to debug if there are any issues as the log files though in rotaition keep geeting full within a very short time . What i would like is to add custom log preferences where i can not log the keep alive response header into the access logs of the Java webserver and then write all the other info that is usefull when accessing my application .
            • 3. Re: Webserver keepalive logs getting full
              Pascal Kreyer-Oracle
              Are you sure that you have the version 7.1 ? The last version is 7.0.17.

              To customize log files, you can still try to configure it based on documentation content. Section "Using the Custom Log File Format" in "Oracle® iPlanet Web Server 7.0.9 Administrator's Configuration File Reference" PDF file.
              • 4. Re: Webserver keepalive logs getting full
                875551
                Oracle iPlanet Web Server 7.0.15 .. I am going through the document but i am not hands on to make the changes . Can you please post in the entries that would be required in the respective configuration files where

                Either i can filter out the keepalive header responses from getting logged in the access.log OR

                I can log the these type of header responses in a separate log file which i can keep purging ..

                Thanks for your advice and help.
                • 5. Re: Webserver keepalive logs getting full
                  rukbat
                  Moderator Action:
                  Thread moved from the Sun Servers forum, which is fir HARDWARE questions,
                  to a Weblogic web server oriented SOFTWARE forum, for closer topic alignment.

                  You either have a misconfigured software kit or you need to go to your other hardware vendor for help with their product(s).

                  (BTW, I know what "LB" was likely referring to but you needed to actually describe it instead of just using cryptic abbreviations.)